1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-09-29 02:17:36 +03:00

cgminer: update to 2.10.2

This commit is contained in:
Xiangfu 2012-12-25 08:59:02 +08:00
parent 05f8519acc
commit d3474a134b
2 changed files with 3 additions and 18 deletions

View File

@ -9,9 +9,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cgminer
PKG_VERSION:=20120905
PKG_REV:=ba0122535a7045f75adcab2953f51c241683b0de
# this is upstream version 2.7.5
PKG_VERSION:=20121225
PKG_REV:=b9c7f3d169942417e04f13fab6e86d944aff37cb
# this is upstream version 2.10.2
PKG_RELEASE:=1
PKG_INSTALL:=1

View File

@ -1,15 +0,0 @@
diff --git a/miner.h b/miner.h
index 120d763..7b7d6d5 100644
--- a/miner.h
+++ b/miner.h
@@ -159,6 +159,10 @@ void *alloca (size_t);
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
#endif
+#ifndef roundl
+#define roundl(x) (long double)((long long)((x==0)?0.0:((x)+((x)>0)?0.5:-0.5)))
+#endif
+
enum alive {
LIFE_WELL,
LIFE_SICK,