1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-26 04:02:20 +03:00

4th: compile fine now

This commit is contained in:
Xiangfu Liu 2011-04-22 12:54:44 +08:00
parent 3a40dc04f7
commit d938d67000
2 changed files with 41 additions and 19 deletions

View File

@ -1,26 +1,24 @@
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
#
include $(TOPDIR)/rules.mk
##Nombre del paquete
## Nombre del paquete
PKG_NAME:=4th
## version del programa que vamos incluir en el paquete
PKG_VERSION:=3.60.1-unix
PKG_VERSION:=3.61.1
## numero de version del paquete
PKG_RELEASE:=3
##Nombre del archivo con el codigo fuente usamos las variables que acabamos de definir http://www.xs4all.nl/~thebeez/4tH/4th-3.60.1-unix.tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nano.tar.gz
##Url donde se encuetra el el codigo fuente
PKG_SOURCE_URL:=http://www.xs4all.nl/~thebeez/4tH/
PKG_SOURCE_URL:=http://4th.googlecode.com/files/
## programa con el que descomprimir el codigo fuente
PKG_CAT:=zcat
include $(INCLUDE_DIR)/package.mk
#Definicion del paquet Titulo, seccion, categoria, la url del proyecto,
#esto se usa para generar el ipkg y para incluirlo en el menuconfig
define Package/4th
MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
TITLE:=4th
SECTION:=Programming
CATEGORY:=prog
@ -34,22 +32,19 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/4th-$(PKG_VERSION)
define Package/4th/description
4th forth compiler
endef
#Si no hay que darles instrucciones especiales al ./configure esto se queda tal como esta.
define Build/Prepare
#PKG_BUILD_DIR=$(PKG_BUILD_DIR)/src
$(call Build/Prepare/Default)
$(CP) $(PKG_BUILD_DIR)/sources/* $(PKG_BUILD_DIR)/
endef
MAKE_VARS+=LIBRARIES="${PKG_INSTALL_DIR}/usr/lib" BINARIES="${PKG_INSTALL_DIR}/usr/bin"
MAKE_FLAGS+=-C $(PKG_BUILD_DIR)/sources
define Build/Configure
$(call Build/Configure/Default)
endef
#Definimos donde se copiaran los binarios y las librerias cuando queramos instalarlo,
#emacs genera el binario en el directorio src
define Package/4th/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/4th $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4th $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4tsh $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/pp4th $(1)/usr/bin/
$(CP) $(PKG_BUILD_DIR)/sources/lib4th.a $(1)/usr/lib/
endef
#Instrucion final para construir el paquete.
$(eval $(call BuildPackage,4th))

View File

@ -0,0 +1,27 @@
diff --git a/sources/Makefile b/sources/Makefile
index d0f9569..a059412 100644
--- a/sources/Makefile
+++ b/sources/Makefile
@@ -15,15 +15,15 @@
#
# The following five variables may need to be changed
-LIBRARIES=/usr/lib
-INCLUDES=/usr/include
-BINARIES=/usr/local/bin
-CC=$(CROSS)gcc
-CFLAGS= -DUNIX -DZAURUS -fsigned-char -Wall -O3 -s
+LIBRARIES?=/usr/lib
+INCLUDES?=/usr/include
+BINARIES?=/usr/local/bin
+CC?=$(CROSS)gcc
+CFLAGS:=$(CFLAGS) -DUNIX -DZAURUS -fsigned-char -Wall -O3 -s
# Cross compilation variables
-LD=$(CROSS)ld
-AR=$(CROSS)ar
+LD?=$(CROSS)ld
+AR?=$(CROSS)ar
OBJ4TH = errs_4th.o save_4th.o load_4th.o free_4th.o comp_4th.o \
name_4th.o dump_4th.o exec_4th.o open_4th.o cgen_4th.o