mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-19 08:57:12 +02:00
Merge branch 'master' of git@projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
da1d7940d1
@ -16,6 +16,8 @@ PKG_SOURCE_URL:=http://www.libsdl.org/projects/SDL_image/release/
|
|||||||
PKG_MD5SUM:=6c06584b31559e2b59f2b982d0d1f628
|
PKG_MD5SUM:=6c06584b31559e2b59f2b982d0d1f628
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/SDL_image-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/SDL_image-$(PKG_VERSION)
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/libsdl-image
|
define Package/libsdl-image
|
||||||
@ -38,21 +40,17 @@ CONFIGURE_ARGS += \
|
|||||||
CONFIGURE_VARS += \
|
CONFIGURE_VARS += \
|
||||||
LIBS="-lSDL -ldirect -ldirectfb -lfusion"
|
LIBS="-lSDL -ldirect -ldirectfb -lfusion"
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib/pkgconfig
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/include/SDL/SDL_image.h \
|
$(PKG_INSTALL_DIR)/usr/include/SDL/SDL_image.h \
|
||||||
$(1)/usr/include/SDL/
|
$(1)/usr/include/SDL/
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libSDL_image*.{a,so*} \
|
$(PKG_INSTALL_DIR)/usr/lib/libSDL_image*.{a,so*} \
|
||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
|
||||||
|
$(1)/usr/lib/pkgconfig/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libsdl-image/install
|
define Package/libsdl-image/install
|
||||||
|
45
pygame/Makefile
Normal file
45
pygame/Makefile
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
# This is free software, licensed under the GNU General Public License
|
||||||
|
# v3. See /LICENSE for more information.
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=pygame
|
||||||
|
PKG_VERSION:=1.9.1release
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://www.pygame.org/ftp/
|
||||||
|
|
||||||
|
PKG_BUILD_DEPENDS:=python
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
|
||||||
|
|
||||||
|
define Package/pygame
|
||||||
|
SUBMENU:=Python
|
||||||
|
SECTION:=lang
|
||||||
|
CATEGORY:=Languages
|
||||||
|
TITLE:=pygame
|
||||||
|
URL:=http://pygame.org
|
||||||
|
DEPENDS:=+python-mini +libsdl +libpng +libjpeg +libsdl-image +libsdl-mixer
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/pygame/description
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Build/Compile/PyMod,,\
|
||||||
|
install \
|
||||||
|
--prefix="$(PKG_INSTALL_DIR)/usr" \
|
||||||
|
, \
|
||||||
|
LOCALBASE="$(STAGING_DIR)/usr" \
|
||||||
|
NO_SCRAP=1 \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/pygame/install
|
||||||
|
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
||||||
|
$(1)$(PYTHON_PKG_DIR)
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,pygame))
|
106
pygame/patches/010-fix-paths.patch
Normal file
106
pygame/patches/010-fix-paths.patch
Normal file
@ -0,0 +1,106 @@
|
|||||||
|
diff --git a/config_unix.py b/config_unix.py
|
||||||
|
index 1cece2a..0fec7e0 100644
|
||||||
|
--- a/config_unix.py
|
||||||
|
+++ b/config_unix.py
|
||||||
|
@@ -69,6 +69,39 @@ class DependencyProg:
|
||||||
|
else:
|
||||||
|
print (self.name + ' '[len(self.name):] + ': not found')
|
||||||
|
|
||||||
|
+class DependencyPkgConfig:
|
||||||
|
+ def __init__(self, name, lib):
|
||||||
|
+ self.name = name
|
||||||
|
+ self.lib_dir = ''
|
||||||
|
+ self.inc_dir = ''
|
||||||
|
+ self.libs = []
|
||||||
|
+ self.cflags = ''
|
||||||
|
+ command = os.environ.get('PKG_CONFIG', 'pkg-config')
|
||||||
|
+ try:
|
||||||
|
+ version = os.popen('%s %s --modversion 2> /dev/null' % (command, lib)).readline()
|
||||||
|
+ if not version.strip():
|
||||||
|
+ self.found = 0
|
||||||
|
+ return
|
||||||
|
+
|
||||||
|
+ cflags = os.popen('%s %s --cflags 2> /dev/null' % (command, lib)).readline().strip()
|
||||||
|
+ libs = os.popen('%s %s --libs 2> /dev/null' % (command, lib)).readline().strip()
|
||||||
|
+
|
||||||
|
+ self.ver = version
|
||||||
|
+ self.found = 1
|
||||||
|
+
|
||||||
|
+ self.cflags = '%s %s' % (cflags, libs)
|
||||||
|
+ except Exception, e:
|
||||||
|
+ print e
|
||||||
|
+ print ('WARNING: "pkg-config" failed!')
|
||||||
|
+ self.found = 0
|
||||||
|
+ self.ver = '0'
|
||||||
|
+
|
||||||
|
+ def configure(self, incdirs, libdir):
|
||||||
|
+ if self.found:
|
||||||
|
+ print (self.name + ' '[len(self.name):] + ': found ' + self.ver)
|
||||||
|
+ else:
|
||||||
|
+ print (self.name + ' '[len(self.name):] + ': not found')
|
||||||
|
+
|
||||||
|
class Dependency:
|
||||||
|
def __init__(self, name, checkhead, checklib, libs):
|
||||||
|
self.name = name
|
||||||
|
@@ -137,18 +170,22 @@ sdl_lib_name = 'SDL'
|
||||||
|
def main():
|
||||||
|
print ('\nHunting dependencies...')
|
||||||
|
DEPS = [
|
||||||
|
- DependencyProg('SDL', 'SDL_CONFIG', 'sdl-config', '1.2', ['sdl']),
|
||||||
|
+ DependencyPkgConfig('SDL', 'sdl'),
|
||||||
|
Dependency('FONT', 'SDL_ttf.h', 'libSDL_ttf.so', ['SDL_ttf']),
|
||||||
|
- Dependency('IMAGE', 'SDL_image.h', 'libSDL_image.so', ['SDL_image']),
|
||||||
|
+ DependencyPkgConfig('IMAGE', 'SDL_image'),
|
||||||
|
Dependency('MIXER', 'SDL_mixer.h', 'libSDL_mixer.so', ['SDL_mixer']),
|
||||||
|
DependencyProg('SMPEG', 'SMPEG_CONFIG', 'smpeg-config', '0.4.3', ['smpeg']),
|
||||||
|
- Dependency('PNG', 'png.h', 'libpng', ['png']),
|
||||||
|
+ DependencyPkgConfig('PNG', 'libpng'),
|
||||||
|
Dependency('JPEG', 'jpeglib.h', 'libjpeg', ['jpeg']),
|
||||||
|
- Dependency('SCRAP', '', 'libX11', ['X11']),
|
||||||
|
Dependency('PORTMIDI', 'portmidi.h', 'libportmidi.so', ['portmidi']),
|
||||||
|
Dependency('PORTTIME', 'porttime.h', 'libporttime.so', ['porttime']),
|
||||||
|
#Dependency('GFX', 'SDL_gfxPrimitives.h', 'libSDL_gfx.so', ['SDL_gfx']),
|
||||||
|
]
|
||||||
|
+ if not os.environ.get('NO_SCRAP', None):
|
||||||
|
+ DEPS += Dependency('SCRAP', '', 'libX11', ['X11']),
|
||||||
|
+ else:
|
||||||
|
+ DEPS += Dependency('SCRAP', '', '', []),
|
||||||
|
+
|
||||||
|
if not DEPS[0].found:
|
||||||
|
print ('Unable to run "sdl-config". Please make sure a development version of SDL is installed.')
|
||||||
|
raise SystemExit
|
||||||
|
@@ -159,10 +186,10 @@ def main():
|
||||||
|
else:
|
||||||
|
incdirs = []
|
||||||
|
libdirs = []
|
||||||
|
- incdirs += ["/usr"+d for d in origincdirs]
|
||||||
|
- libdirs += ["/usr"+d for d in origlibdirs]
|
||||||
|
- incdirs += ["/usr/local"+d for d in origincdirs]
|
||||||
|
- libdirs += ["/usr/local"+d for d in origlibdirs]
|
||||||
|
+# incdirs += ["/usr"+d for d in origincdirs]
|
||||||
|
+# libdirs += ["/usr"+d for d in origlibdirs]
|
||||||
|
+# incdirs += ["/usr/local"+d for d in origincdirs]
|
||||||
|
+# libdirs += ["/usr/local"+d for d in origlibdirs]
|
||||||
|
|
||||||
|
for arg in DEPS[0].cflags.split():
|
||||||
|
if arg[:2] == '-I':
|
||||||
|
|
||||||
|
|
||||||
|
--- a/config_unix.py
|
||||||
|
+++ b/config_unix.py
|
||||||
|
@@ -182,15 +209,6 @@ def main():
|
||||||
|
for d in DEPS:
|
||||||
|
d.configure(incdirs, libdirs)
|
||||||
|
|
||||||
|
- for d in DEPS[1:]:
|
||||||
|
- if not d.found:
|
||||||
|
- if not confirm("""
|
||||||
|
-Warning, some of the pygame dependencies were not found. Pygame can still
|
||||||
|
-compile and install, but games that depend on those missing dependencies
|
||||||
|
-will not run. Would you like to continue the configuration?"""):
|
||||||
|
- raise SystemExit
|
||||||
|
- break
|
||||||
|
-
|
||||||
|
return DEPS
|
||||||
|
|
||||||
|
if __name__ == '__main__':
|
68
pygame/patches/020-scrup-stub.patch
Normal file
68
pygame/patches/020-scrup-stub.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
--- a/src/scrap.c
|
||||||
|
+++ b/src/scrap.c
|
||||||
|
@@ -70,7 +70,7 @@ static uint32_t _cliptype = 0;
|
||||||
|
#define MAC_SCRAP
|
||||||
|
#include "scrap_mac.c"
|
||||||
|
#else
|
||||||
|
- #error Unknown window manager for clipboard handling
|
||||||
|
+ #include "scrap_stub.c"
|
||||||
|
#endif /* scrap type */
|
||||||
|
|
||||||
|
/**
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/src/scrap_stub.c
|
||||||
|
@@ -0,0 +1,54 @@
|
||||||
|
+/*
|
||||||
|
+ pygame - Python Game Library
|
||||||
|
+
|
||||||
|
+ This library is free software; you can redistribute it and/or
|
||||||
|
+ modify it under the terms of the GNU Library General Public
|
||||||
|
+ License as published by the Free Software Foundation; either
|
||||||
|
+ version 2 of the License, or (at your option) any later version.
|
||||||
|
+
|
||||||
|
+ This library is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||||
|
+ Library General Public License for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU Library General Public
|
||||||
|
+ License along with this library; if not, write to the Free
|
||||||
|
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
+*/
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+pygame_scrap_init (void)
|
||||||
|
+{
|
||||||
|
+ return 1;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+pygame_scrap_lost (void)
|
||||||
|
+{
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+pygame_scrap_put (char *type, int srclen, char *src)
|
||||||
|
+{
|
||||||
|
+ return 1;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+char*
|
||||||
|
+pygame_scrap_get (char *type, unsigned long *count)
|
||||||
|
+{
|
||||||
|
+ return NULL;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+pygame_scrap_contains (char *type)
|
||||||
|
+{
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+char**
|
||||||
|
+pygame_scrap_get_types (void)
|
||||||
|
+{
|
||||||
|
+ return NULL;
|
||||||
|
+}
|
@ -1,5 +1,5 @@
|
|||||||
# This is free software, licensed under the GNU General Public License
|
# This is free software, licensed under the GNU General Public License
|
||||||
# v2. See /LICENSE for more information.
|
# v3. See /LICENSE for more information.
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=robots
|
PKG_NAME:=robots
|
||||||
@ -8,7 +8,7 @@ PKG_RELEASE:=6
|
|||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://pyneo.org/t
|
PKG_SOURCE_URL:=http://pyneo.org/t
|
||||||
PKG_MD5SUM:=c673aaab232243c660484d2969e3cf30
|
PKG_MD5SUM:=bbc3134ec29c15fac7e39793046ba6ab
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -46,15 +46,15 @@ define Build/Compile
|
|||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
# define Build/InstallDev
|
define Build/InstallDev
|
||||||
# $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/include/google $(1)/usr/lib
|
||||||
# $(CP) \
|
$(CP) \
|
||||||
# $(PKG_INSTALL_DIR)/usr/include/SDL/SDL_image.h \
|
$(PKG_INSTALL_DIR)/usr/include/google/* \
|
||||||
# $(1)/usr/include/SDL/
|
$(1)/usr/include/google/
|
||||||
# $(CP) \
|
# $(CP) \
|
||||||
# $(PKG_INSTALL_DIR)/usr/lib/libSDL_image*.{a,so*} \
|
# $(PKG_INSTALL_DIR)/usr/lib/libSDL_image*.{a,so*} \
|
||||||
# $(1)/usr/lib/
|
# $(1)/usr/lib/
|
||||||
# endef
|
endef
|
||||||
|
|
||||||
define Package/sparsehash/install
|
define Package/sparsehash/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
@ -8,10 +8,10 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
|
|||||||
src/gconf_file.cpp | 2 ++
|
src/gconf_file.cpp | 2 ++
|
||||||
src/inifile.cpp | 1 +
|
src/inifile.cpp | 1 +
|
||||||
src/lib/common.cpp | 2 ++
|
src/lib/common.cpp | 2 ++
|
||||||
src/lib/data.cpp | 1 +
|
src/lib/data.cpp | 2 ++
|
||||||
src/lib/http_client.cpp | 1 +
|
src/lib/http_client.cpp | 1 +
|
||||||
src/lib/pluginmanager.cpp | 2 +-
|
src/lib/pluginmanager.cpp | 2 +-
|
||||||
src/lib/stardict_client.cpp | 1 +
|
src/lib/stardict_client.cpp | 2 ++
|
||||||
src/lib/treedict.cpp | 1 +
|
src/lib/treedict.cpp | 1 +
|
||||||
src/pangoview.cpp | 2 ++
|
src/pangoview.cpp | 2 ++
|
||||||
src/prefsdlg.cpp | 1 +
|
src/prefsdlg.cpp | 1 +
|
||||||
@ -35,7 +35,7 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
|
|||||||
.../stardict_xdxf_parsedata.cpp | 1 +
|
.../stardict_xdxf_parsedata.cpp | 1 +
|
||||||
tests/t_config_file.cpp | 1 +
|
tests/t_config_file.cpp | 1 +
|
||||||
tests/t_xml.cpp | 1 +
|
tests/t_xml.cpp | 1 +
|
||||||
30 files changed, 38 insertions(+), 6 deletions(-)
|
30 files changed, 40 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
|
||||||
diff --git a/src/gconf_file.cpp b/src/gconf_file.cpp
|
diff --git a/src/gconf_file.cpp b/src/gconf_file.cpp
|
||||||
@ -77,13 +77,14 @@ index 6575ad9..29faf9e 100644
|
|||||||
|
|
||||||
static void parse_description(const char *p, long len, std::string &description)
|
static void parse_description(const char *p, long len, std::string &description)
|
||||||
diff --git a/src/lib/data.cpp b/src/lib/data.cpp
|
diff --git a/src/lib/data.cpp b/src/lib/data.cpp
|
||||||
index 45c7d1a..1b29ec3 100644
|
index 45c7d1a..a428b37 100644
|
||||||
--- a/src/lib/data.cpp
|
--- a/src/lib/data.cpp
|
||||||
+++ b/src/lib/data.cpp
|
+++ b/src/lib/data.cpp
|
||||||
@@ -22,6 +22,7 @@
|
@@ -22,6 +22,8 @@
|
||||||
# include "config.h"
|
# include "config.h"
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
+#include <cstdio>
|
||||||
+#include <cstring>
|
+#include <cstring>
|
||||||
#include "kmp.h"
|
#include "kmp.h"
|
||||||
|
|
||||||
@ -113,13 +114,14 @@ index de3e92d..28a46c4 100644
|
|||||||
StarDictPluginBaseObject::StarDictPluginBaseObject(const char *filename, GModule *module_, plugin_configure_func_t configure_func_):
|
StarDictPluginBaseObject::StarDictPluginBaseObject(const char *filename, GModule *module_, plugin_configure_func_t configure_func_):
|
||||||
plugin_filename(filename), module(module_), configure_func(configure_func_)
|
plugin_filename(filename), module(module_), configure_func(configure_func_)
|
||||||
diff --git a/src/lib/stardict_client.cpp b/src/lib/stardict_client.cpp
|
diff --git a/src/lib/stardict_client.cpp b/src/lib/stardict_client.cpp
|
||||||
index dcae5ce..c3d2511 100644
|
index dcae5ce..407a907 100644
|
||||||
--- a/src/lib/stardict_client.cpp
|
--- a/src/lib/stardict_client.cpp
|
||||||
+++ b/src/lib/stardict_client.cpp
|
+++ b/src/lib/stardict_client.cpp
|
||||||
@@ -25,6 +25,7 @@
|
@@ -25,6 +25,8 @@
|
||||||
#include <glib.h>
|
#include <glib.h>
|
||||||
#include <glib/gi18n.h>
|
#include <glib/gi18n.h>
|
||||||
|
|
||||||
|
+#include <cstdio>
|
||||||
+#include <cstdlib>
|
+#include <cstdlib>
|
||||||
#include "sockets.hpp"
|
#include "sockets.hpp"
|
||||||
#include "md5.h"
|
#include "md5.h"
|
||||||
|
@ -5,21 +5,50 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
|
|||||||
|
|
||||||
---
|
---
|
||||||
|
|
||||||
configure.in | 2
|
configure.in | 26 ++-
|
||||||
|
m4/nls.m4 | 31 ++++
|
||||||
src/class_factory.cpp | 2
|
src/class_factory.cpp | 2
|
||||||
src/conf.cpp | 6 -
|
src/conf.cpp | 6 -
|
||||||
src/stardict.cpp | 6 -
|
src/mainwin.cpp | 9 +
|
||||||
|
src/stardict.cpp | 35 +++-
|
||||||
src/x11_iskeyspressed.cpp | 351 ---------------------------------------------
|
src/x11_iskeyspressed.cpp | 351 ---------------------------------------------
|
||||||
src/x11_iskeyspressed.hpp | 65 --------
|
src/x11_iskeyspressed.hpp | 65 --------
|
||||||
6 files changed, 8 insertions(+), 424 deletions(-)
|
8 files changed, 75 insertions(+), 450 deletions(-)
|
||||||
|
create mode 100644 m4/nls.m4
|
||||||
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
diff --git a/configure.in b/configure.in
|
||||||
index 83d3d95..3676e2c 100644
|
index 83d3d95..6be40db 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -428,7 +428,7 @@ LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
|
@@ -414,21 +414,21 @@ dnl ==========================================================================
|
||||||
fi
|
|
||||||
|
# Checks for header files. need by Solaris.
|
||||||
|
AC_PATH_XTRA
|
||||||
|
-if test -n "$X_CFLAGS"; then
|
||||||
|
-CPPFLAGS="$CPPFLAGS $X_CFLAGS"
|
||||||
|
-fi
|
||||||
|
-if test -n "$X_LIBS"; then
|
||||||
|
-LDFLAGS="$LDFLAGS $X_LIBS"
|
||||||
|
-fi
|
||||||
|
-if test -n "$X_PRE_LIBS"; then
|
||||||
|
-LDFLAGS="$LDFLAGS $X_PRE_LIBS"
|
||||||
|
-fi
|
||||||
|
-if test -n "$X_EXTRA_LIBS"; then
|
||||||
|
-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
|
||||||
|
-fi
|
||||||
|
+#if test -n "$X_CFLAGS"; then
|
||||||
|
+#CPPFLAGS="$CPPFLAGS $X_CFLAGS"
|
||||||
|
+#fi
|
||||||
|
+#if test -n "$X_LIBS"; then
|
||||||
|
+#LDFLAGS="$LDFLAGS $X_LIBS"
|
||||||
|
+#fi
|
||||||
|
+#if test -n "$X_PRE_LIBS"; then
|
||||||
|
+#LDFLAGS="$LDFLAGS $X_PRE_LIBS"
|
||||||
|
+#fi
|
||||||
|
+#if test -n "$X_EXTRA_LIBS"; then
|
||||||
|
+#LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
|
||||||
|
+#fi
|
||||||
|
|
||||||
# Checks for libraries.
|
# Checks for libraries.
|
||||||
-AC_CHECK_LIB([X11], [main], , [AC_MSG_ERROR([X11 lib not found])])
|
-AC_CHECK_LIB([X11], [main], , [AC_MSG_ERROR([X11 lib not found])])
|
||||||
@ -27,6 +56,43 @@ index 83d3d95..3676e2c 100644
|
|||||||
|
|
||||||
AC_SUBST(STARDICT_LIBS)
|
AC_SUBST(STARDICT_LIBS)
|
||||||
AC_SUBST(STARDICT_CFLAGS)
|
AC_SUBST(STARDICT_CFLAGS)
|
||||||
|
diff --git a/m4/nls.m4 b/m4/nls.m4
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..7967cc2
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/m4/nls.m4
|
||||||
|
@@ -0,0 +1,31 @@
|
||||||
|
+# nls.m4 serial 3 (gettext-0.15)
|
||||||
|
+dnl Copyright (C) 1995-2003, 2005-2006 Free Software Foundation, Inc.
|
||||||
|
+dnl This file is free software; the Free Software Foundation
|
||||||
|
+dnl gives unlimited permission to copy and/or distribute it,
|
||||||
|
+dnl with or without modifications, as long as this notice is preserved.
|
||||||
|
+dnl
|
||||||
|
+dnl This file can can be used in projects which are not available under
|
||||||
|
+dnl the GNU General Public License or the GNU Library General Public
|
||||||
|
+dnl License but which still want to provide support for the GNU gettext
|
||||||
|
+dnl functionality.
|
||||||
|
+dnl Please note that the actual code of the GNU gettext library is covered
|
||||||
|
+dnl by the GNU Library General Public License, and the rest of the GNU
|
||||||
|
+dnl gettext package package is covered by the GNU General Public License.
|
||||||
|
+dnl They are *not* in the public domain.
|
||||||
|
+
|
||||||
|
+dnl Authors:
|
||||||
|
+dnl Ulrich Drepper <drepper@cygnus.com>, 1995-2000.
|
||||||
|
+dnl Bruno Haible <haible@clisp.cons.org>, 2000-2003.
|
||||||
|
+
|
||||||
|
+AC_PREREQ(2.50)
|
||||||
|
+
|
||||||
|
+AC_DEFUN([AM_NLS],
|
||||||
|
+[
|
||||||
|
+ AC_MSG_CHECKING([whether NLS is requested])
|
||||||
|
+ dnl Default is enabled NLS
|
||||||
|
+ AC_ARG_ENABLE(nls,
|
||||||
|
+ [ --disable-nls do not use Native Language Support],
|
||||||
|
+ USE_NLS=$enableval, USE_NLS=yes)
|
||||||
|
+ AC_MSG_RESULT($USE_NLS)
|
||||||
|
+ AC_SUBST(USE_NLS)
|
||||||
|
+])
|
||||||
diff --git a/src/class_factory.cpp b/src/class_factory.cpp
|
diff --git a/src/class_factory.cpp b/src/class_factory.cpp
|
||||||
index 8bff538..d1dddc2 100644
|
index 8bff538..d1dddc2 100644
|
||||||
--- a/src/class_factory.cpp
|
--- a/src/class_factory.cpp
|
||||||
@ -57,8 +123,35 @@ index 2d0f89d..a35bc5c 100644
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
std::auto_ptr<AppConf> conf;
|
std::auto_ptr<AppConf> conf;
|
||||||
|
diff --git a/src/mainwin.cpp b/src/mainwin.cpp
|
||||||
|
index 7005f7b..5bda8be 100644
|
||||||
|
--- a/src/mainwin.cpp
|
||||||
|
+++ b/src/mainwin.cpp
|
||||||
|
@@ -129,10 +129,10 @@ void TopWin::Create(GtkWidget *vbox)
|
||||||
|
gtk_box_pack_start(GTK_BOX(hbox),button,false,false,0);
|
||||||
|
gtk_widget_set_tooltip_text(button,_("Go Back - Right button: history (Alt+Left)"));
|
||||||
|
|
||||||
|
- GtkWidget *label;
|
||||||
|
- label = gtk_label_new("\t");
|
||||||
|
- gtk_widget_show(label);
|
||||||
|
- gtk_box_pack_start(GTK_BOX(hbox),label,false,false,0);
|
||||||
|
+ // GtkWidget *label;
|
||||||
|
+ // label = gtk_label_new("\t");
|
||||||
|
+ // gtk_widget_show(label);
|
||||||
|
+ // gtk_box_pack_start(GTK_BOX(hbox),label,false,false,0);
|
||||||
|
|
||||||
|
button=gtk_button_new();
|
||||||
|
gtk_container_add(GTK_CONTAINER(button),gtk_image_new_from_stock(GTK_STOCK_HOME,GTK_ICON_SIZE_BUTTON));
|
||||||
|
@@ -2665,6 +2665,7 @@ void MidWin::Create(GtkWidget *vbox)
|
||||||
|
|
||||||
|
notebook = gtk_notebook_new();
|
||||||
|
gtk_widget_show(notebook);
|
||||||
|
+ gtk_widget_set_size_request(GTK_WIDGET(notebook), 50, 20);
|
||||||
|
gtk_notebook_set_show_tabs(GTK_NOTEBOOK(notebook), false);
|
||||||
|
gtk_notebook_set_show_border(GTK_NOTEBOOK(notebook),false);
|
||||||
|
|
||||||
diff --git a/src/stardict.cpp b/src/stardict.cpp
|
diff --git a/src/stardict.cpp b/src/stardict.cpp
|
||||||
index 326ca4a..4c51d61 100644
|
index 326ca4a..0e820ed 100644
|
||||||
--- a/src/stardict.cpp
|
--- a/src/stardict.cpp
|
||||||
+++ b/src/stardict.cpp
|
+++ b/src/stardict.cpp
|
||||||
@@ -351,9 +351,9 @@ void AppCore::Create(gchar *queryword)
|
@@ -351,9 +351,9 @@ void AppCore::Create(gchar *queryword)
|
||||||
@ -74,6 +167,64 @@ index 326ca4a..4c51d61 100644
|
|||||||
oFloatWin.Create();
|
oFloatWin.Create();
|
||||||
bool scan=conf->get_bool_at("dictionary/scan_selection");
|
bool scan=conf->get_bool_at("dictionary/scan_selection");
|
||||||
oDockLet.reset(PlatformFactory::create_tray_icon(window, scan,
|
oDockLet.reset(PlatformFactory::create_tray_icon(window, scan,
|
||||||
|
@@ -2005,10 +2005,19 @@ private:
|
||||||
|
|
||||||
|
void AppCore::PopupPrefsDlg()
|
||||||
|
{
|
||||||
|
+ static std::list<std::string> posb_combs;
|
||||||
|
+ if (posb_combs.empty()) {
|
||||||
|
+ posb_combs.push_back("Win");
|
||||||
|
+ posb_combs.push_back("Shift");
|
||||||
|
+ posb_combs.push_back("Alt");
|
||||||
|
+ posb_combs.push_back("Ctrl");
|
||||||
|
+ posb_combs.push_back("Ctrl+Alt");
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (!prefs_dlg) {
|
||||||
|
prefs_dlg = new PrefsDlg(GTK_WINDOW(window),
|
||||||
|
- get_impl(oAppSkin.icon),
|
||||||
|
- unlock_keys->possible_combs());
|
||||||
|
+ get_impl(oAppSkin.icon),
|
||||||
|
+ posb_combs);
|
||||||
|
bool enbcol =
|
||||||
|
conf->get_bool_at("dictionary/enable_collation");
|
||||||
|
int colf =
|
||||||
|
@@ -2153,17 +2162,17 @@ void AppCore::Quit()
|
||||||
|
if (!conf->get_bool_at("main_window/maximized")) {
|
||||||
|
gint width, height;
|
||||||
|
gtk_window_get_size(GTK_WINDOW(window), &width, &height);
|
||||||
|
- conf->set_int_at("main_window/window_width", width);
|
||||||
|
- conf->set_int_at("main_window/window_height", height);
|
||||||
|
+ conf->set_int_at("main_window/window_width", width);
|
||||||
|
+ conf->set_int_at("main_window/window_height", height);
|
||||||
|
}
|
||||||
|
gint pos = gtk_paned_get_position(GTK_PANED(oMidWin.hpaned));
|
||||||
|
- conf->set_int_at("main_window/hpaned_pos", pos);
|
||||||
|
+ conf->set_int_at("main_window/hpaned_pos", pos);
|
||||||
|
|
||||||
|
if (conf->get_bool_at("floating_window/lock")) {
|
||||||
|
gint x, y;
|
||||||
|
gtk_window_get_position(GTK_WINDOW(oFloatWin.FloatWindow), &x, &y);
|
||||||
|
- conf->set_int_at("floating_window/lock_x", x);
|
||||||
|
- conf->set_int_at("floating_window/lock_y", y);
|
||||||
|
+ conf->set_int_at("floating_window/lock_x", x);
|
||||||
|
+ conf->set_int_at("floating_window/lock_y", y);
|
||||||
|
}
|
||||||
|
|
||||||
|
End();
|
||||||
|
@@ -2171,9 +2180,9 @@ void AppCore::Quit()
|
||||||
|
#ifdef CONFIG_GNOME
|
||||||
|
bonobo_object_unref (stardict_app_server);
|
||||||
|
#endif
|
||||||
|
- unlock_keys.reset(0);
|
||||||
|
- conf.reset(0);
|
||||||
|
- gtk_main_quit();
|
||||||
|
+ unlock_keys.reset(0);
|
||||||
|
+ conf.reset(0);
|
||||||
|
+ gtk_main_quit();
|
||||||
|
}
|
||||||
|
|
||||||
|
void AppCore::on_main_win_hide_list_changed(const baseconfval* hideval)
|
||||||
diff --git a/src/x11_iskeyspressed.cpp b/src/x11_iskeyspressed.cpp
|
diff --git a/src/x11_iskeyspressed.cpp b/src/x11_iskeyspressed.cpp
|
||||||
index 15e8fb0..8b13789 100644
|
index 15e8fb0..8b13789 100644
|
||||||
--- a/src/x11_iskeyspressed.cpp
|
--- a/src/x11_iskeyspressed.cpp
|
||||||
|
@ -5,7 +5,6 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v3.
|
# This is free software, licensed under the GNU General Public License v3.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
#http://jaist.dl.sourceforge.net/project/wqy/wqy-microhei/0.2.0-beta/wqy-microhei-0.2.0-beta.tar.gz
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
@ -15,7 +14,7 @@ PKG_RELEASE:=1
|
|||||||
PKG_VERSION:=0.2.0-beta
|
PKG_VERSION:=0.2.0-beta
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}/
|
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}/
|
||||||
PKG_SOURCE_URL:=@SF/wqy-microhei
|
PKG_SOURCE_URL:=http://jaist.dl.sourceforge.net/project/wqy/wqy-microhei/0.2.0-beta/wqy-microhei-0.2.0-beta.tar.gz
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user