mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 01:02:49 +02:00
Initial OpenWRT port of "odt2txt" conversion utility (for Open
Document Format Files). This version has disabled charset conversion (UTF-8 is assumed on output).
This commit is contained in:
parent
e4a39c1cc2
commit
dcc11f77b8
41
odt2txt/Makefile
Normal file
41
odt2txt/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=odt2txt
|
||||
PKG_VERSION:=0.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=odt2txt-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://stosberg.net/odt2txt/
|
||||
PKG_MD5SUM:=6fe3bd261ce2dde2810244bbe969bbc5
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/odt2txt-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/odt2txt
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=odt2txt
|
||||
URL:=http://stosberg.net/odt2txt/
|
||||
DEPENDS:=+libiconv +zlib
|
||||
endef
|
||||
|
||||
define Package/odt2txt/description
|
||||
Converts OpenDocument files to plain text.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="-I$(STAGING_DIR)/usr/include -O2 -DNO_ICONV" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib " \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Package/odt2txt/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/odt2txt $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,odt2txt))
|
12
odt2txt/patches/Makefile.patch
Normal file
12
odt2txt/patches/Makefile.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- odt2txt-0.4/Makefile 2008-06-23 21:32:28.000000000 +0200
|
||||
+++ odt2txt-0.4m/Makefile 2010-07-23 14:19:20.706059237 +0200
|
||||
@@ -10,9 +10,7 @@
|
||||
CFLAGS = -O2
|
||||
endif
|
||||
|
||||
-ifdef NO_ICONV
|
||||
CFLAGS += -DNO_ICONV
|
||||
-endif
|
||||
|
||||
KUNZIP_OBJS = kunzip/fileio.o kunzip/zipfile.o
|
||||
OBJ = odt2txt.o regex.o mem.o strbuf.o $(KUNZIP_OBJS)
|
Loading…
Reference in New Issue
Block a user