1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-28 22:23:51 +03:00

[sdcv] fix compile errors. thanks to jirka.

This commit is contained in:
Xiangfu Liu 2010-05-30 11:59:38 +08:00
parent 7aa1d3adeb
commit df66aa35e7
3 changed files with 37 additions and 3 deletions

View File

@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://cdnetworks-kr-1.dl.sourceforge.net/project/sdcv/sdcv/0.4.
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL:=1
PKG_INSTALL:=2
include $(INCLUDE_DIR)/package.mk
@ -24,7 +24,7 @@ define Package/sdcv
TITLE:=sdcv
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=@BROKEN +libintl
DEPENDS:=+libintl +libreadline +libiconv
URL:=http://sdcv.sourceforge.net/
endef
@ -33,7 +33,7 @@ define Package/sdcv/description
endef
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include
TARGET_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/libintl/lib
TARGET_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib
CONFIGURE_ARGS +=

View File

@ -0,0 +1,24 @@
--- sdcv-0.4.2/src/lib/lib.cpp 2006-04-24 10:17:27.000000000 +0200
+++ sdcv-0.4.2m/src/lib/lib.cpp 2010-05-28 19:03:20.000000000 +0200
@@ -5,10 +5,12 @@
#include <algorithm>
#include <cstring>
#include <cctype>
+#include <cstdlib>
#include <sys/stat.h>
#include <zlib.h>
#include <glib/gstdio.h>
+#include <stdlib.h>
#include "distance.h"
#include "file.hpp"
@@ -513,7 +515,7 @@
{
fseek(idxfile, wordoffset[page_idx], SEEK_SET);
guint32 page_size=wordoffset[page_idx+1]-wordoffset[page_idx];
- fread(wordentry_buf, std::min(sizeof(wordentry_buf), page_size), 1, idxfile); //TODO: check returned values, deal with word entry that strlen>255.
+ fread(wordentry_buf, std::min((long)sizeof(wordentry_buf), (long)page_size), 1, idxfile); //TODO: check returned values, deal with word entry that strlen>255.
return wordentry_buf;
}

View File

@ -0,0 +1,10 @@
--- sdcv-0.4.2/src/readline.cpp 2005-12-07 23:07:23.000000000 +0100
+++ sdcv-0.4.2m/src/readline.cpp 2010-05-28 19:24:28.000000000 +0200
@@ -28,6 +28,7 @@
# include <readline/history.h>
#endif
#include <glib.h>
+#include <stdlib.h>
#include "utils.hpp"