mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 08:34:39 +02:00
FbTerm, a fast FrameBuffer based TERMinal emulator for linux
This commit is contained in:
parent
d3db1719d6
commit
e0a7e26b44
49
fbterm/Makefile
Normal file
49
fbterm/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
#
|
||||
# kyak@freenode/#qi-hardware
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fbterm
|
||||
PKG_VERSION:=1.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://fbterm.googlecode.com/files/
|
||||
PKG_MD5SUM:=531ea0984836b58fd123e6a97a4228c6
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/fbterm
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=FbTerm, a fast FrameBuffer based TERMinal emulator for linux
|
||||
URL:=http://code.google.com/p/fbterm/
|
||||
SUBMENU:=terminal
|
||||
DEPENDS:=libiconv
|
||||
endef
|
||||
|
||||
define Package/fbterm/description
|
||||
FbTerm is a fast terminal emulator for linux with frame buffer device
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS+= \
|
||||
-I$(STAGING_DIR)/usr/lib/libiconv/include
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv
|
||||
|
||||
define Package/fbterm/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/bin
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/src/fbterm \
|
||||
$(1)/usr/bin/fbterm
|
||||
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fbterm))
|
12
fbterm/patches/001-invalid-conservion.patch
Normal file
12
fbterm/patches/001-invalid-conservion.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- fbterm-1.6/src/lib/io.cpp_orig 2010-06-19 19:00:18.037920330 +0400
|
||||
+++ fbterm-1.6/src/lib/io.cpp 2010-06-19 19:01:02.622595041 +0400
|
||||
@@ -188,7 +188,8 @@
|
||||
s8 outbuf[outlen];
|
||||
|
||||
size_t nconv, left, total = len;
|
||||
- s8 *outptr, *inptr = buf;
|
||||
+ s8 *outptr = buf;
|
||||
+ const char *inptr = buf;
|
||||
|
||||
while (total) {
|
||||
outptr = outbuf;
|
Loading…
Reference in New Issue
Block a user