mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 09:31:53 +02:00
Merge branch 'master' of git://projects.qi-hardware.com/openwrt-packages
This commit is contained in:
commit
e2e4bcdd71
@ -26,9 +26,18 @@ define Package/ben-wpan/Default
|
|||||||
URL:=http://en.qi-hardware.com/wiki/Ben_WPAN
|
URL:=http://en.qi-hardware.com/wiki/Ben_WPAN
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
|
||||||
|
BEN_WPAN_MAKE_ARGS=V=1 TARGET=ben_openwrt
|
||||||
|
else
|
||||||
|
# If you compile under other target please manually disable those package under 'menuconfig'
|
||||||
|
# atrf-rssi atrf-path atrf-xtal
|
||||||
|
# this need more work on DEPENDS work, like the dirtpan DEPENDS below.
|
||||||
|
BEN_WPAN_MAKE_ARGS=NOGUI=1 V=1 CC_host=$(TARGET_CC)
|
||||||
|
endif
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools TARGET=ben_openwrt; \
|
$(MAKE) -C $(PKG_BUILD_DIR)/tools $(BEN_WPAN_MAKE_ARGS) && \
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools/dirtpan TARGET=ben_openwrt CFLAGS+="-I$(STAGING_DIR)/usr/include -I../include"
|
$(MAKE) -C $(PKG_BUILD_DIR)/tools/dirtpan $(BEN_WPAN_MAKE_ARGS) CFLAGS+="-I$(STAGING_DIR)/usr/include -I../include"
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/ben-wpan-doc
|
define Package/ben-wpan-doc
|
||||||
@ -145,6 +154,7 @@ endef
|
|||||||
define Package/dirtpan
|
define Package/dirtpan
|
||||||
$(call Package/ben-wpan/Default)
|
$(call Package/ben-wpan/Default)
|
||||||
TITLE:=Quick and dirty IPv4 over 802.15.4 tunnel
|
TITLE:=Quick and dirty IPv4 over 802.15.4 tunnel
|
||||||
|
DEPENDS:=$(if $(CONFIG_TARGET_xburst_qi_lb60),,+libusb)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dirtpan/install
|
define Package/dirtpan/install
|
||||||
|
19
ben-wpan/patches/001-disable-some-gui-apps.patch
Normal file
19
ben-wpan/patches/001-disable-some-gui-apps.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
diff --git a/tools/Makefile b/tools/Makefile
|
||||||
|
index 0ebc31b..95adf51 100644
|
||||||
|
--- a/tools/Makefile
|
||||||
|
+++ b/tools/Makefile
|
||||||
|
@@ -11,8 +11,12 @@
|
||||||
|
#
|
||||||
|
|
||||||
|
|
||||||
|
-BEN_DIRS=atrf-gpio atrf-id atrf-path atrf-proxy atrf-reset \
|
||||||
|
- atrf-rssi atrf-trim atrf-txrx atrf-xmit atrf-xtal
|
||||||
|
+BEN_DIRS=atrf-gpio atrf-id atrf-proxy atrf-reset atrf-trim \
|
||||||
|
+ atrf-txrx atrf-xmit
|
||||||
|
+
|
||||||
|
+ifeq ($(NOGUI),)
|
||||||
|
+BEN_DIRS += atrf-rssi atrf-path atrf-xtal
|
||||||
|
+endif
|
||||||
|
|
||||||
|
ifneq ($(wildcard ../install/lowpan-tools-0.2.2/include/ieee802154.h),)
|
||||||
|
DIRTPAN := dirtpan
|
58
xburst-tools/Makefile
Normal file
58
xburst-tools/Makefile
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2012 Xiangfu Liu <xiangfu@openmobilefree.net>
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=xburst-tools
|
||||||
|
PKG_VERSION:=20120605
|
||||||
|
PKG_REV:=ff28d4c923a489cef1af0b761b9026e1c65a7a48
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
|
||||||
|
PKG_SOURCE_URL:=git://projects.qi-hardware.com/xburst-tools.git
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
define Package/xburst-tools
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=Xburst-Tools
|
||||||
|
URL:=http://projects.qi-hardware.com/p/xburst-tools/
|
||||||
|
DEPENDS:=+libusb +libusb-1.0 +confuse +libreadline
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xburst-tools/description
|
||||||
|
Tools for Ingenic XBurst CPU USB boot and NAND flash access
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
( cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--disable-firmware \
|
||||||
|
--prefix=/usr \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xburst-tools/install
|
||||||
|
(cd $(PKG_BUILD_DIR) && \
|
||||||
|
wget http://projects.qi-hardware.com/media/upload/xburst-tools/files/xburst-tools-firmware-201105.tar.bz2 && \
|
||||||
|
tar xvf xburst-tools-firmware-201105.tar.bz2)
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/share/xburst-tools/
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/xburst-tools-firmware/* $(1)/usr/share/xburst-tools/
|
||||||
|
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/ipkg-install/* $(1)/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,xburst-tools))
|
Loading…
Reference in New Issue
Block a user