mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:03:10 +02:00
Quickcalc (simple calculkator with history) - initial OpenWRT port.
This commit is contained in:
parent
84b1e91bc0
commit
e4a39c1cc2
41
quickcalc/Makefile
Normal file
41
quickcalc/Makefile
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=quickcalc
|
||||||
|
PKG_VERSION:=1.26
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=quickcalc-$(PKG_VERSION).tgz
|
||||||
|
PKG_SOURCE_URL:=ftp://ftp.ac-grenoble.fr/ge/mathematics/
|
||||||
|
PKG_MD5SUM:=152599c038c06ecc11e7db9dad4d4dce
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/quickcalc-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/quickcalc
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=QuickCalc
|
||||||
|
URL:=http://freshmeat.net/projects/quickcalc
|
||||||
|
DEPENDS:=+libreadline +libncurses
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/quickcalc/description
|
||||||
|
Computer algebra system.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Compile/Default, \
|
||||||
|
CFLAGS="-I$(STAGING_DIR)/usr/include -O2 " \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib " \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/quickcalc/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin/
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/qc $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,quickcalc))
|
21
quickcalc/patches/Makefile.patch
Normal file
21
quickcalc/patches/Makefile.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- quickcalc-1.26/Makefile 1999-07-25 16:33:21.000000000 +0200
|
||||||
|
+++ quickcalc-1.26m/Makefile 2010-07-23 13:13:02.888135597 +0200
|
||||||
|
@@ -3,7 +3,8 @@
|
||||||
|
#CPPFLAGS = -DC_DEBUG -g
|
||||||
|
|
||||||
|
CC = gcc
|
||||||
|
-CFLAGS = -O2 -Wall
|
||||||
|
+CFLAGS+= -O2 -Wall
|
||||||
|
+LDLIBS+=$(LDFLAGS) -lm -lreadline -lncurses
|
||||||
|
SHELL = /bin/sh
|
||||||
|
|
||||||
|
OBJS = qc.o error.o disp_ans.o text.o calc_str.o lex.yy.o
|
||||||
|
@@ -11,7 +12,7 @@
|
||||||
|
all : qc
|
||||||
|
|
||||||
|
qc : $(OBJS)
|
||||||
|
- $(CC) $(OBJS) -lm -lreadline -lncurses -o qc
|
||||||
|
+ $(CC) $(OBJS) $(LDLIBS) -o $(@)
|
||||||
|
|
||||||
|
qc.o : qc.c version.h
|
||||||
|
|
Loading…
Reference in New Issue
Block a user