1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-11-22 17:52:27 +02:00

Merge branch 'master' of git@projects.qi-hardware.com:openwrt-packages

This commit is contained in:
Xiangfu Liu 2010-02-02 16:07:29 +08:00
commit ee91d31436
6 changed files with 4 additions and 67 deletions

View File

@ -1,24 +0,0 @@
diff --git a/src/fileimpl.cpp b/src/fileimpl.cpp
index 08edcb9..db8cb7f 100644
--- a/src/fileimpl.cpp
+++ b/src/fileimpl.cpp
@@ -35,6 +35,7 @@
#include <unistd.h>
#include <errno.h>
#include <string.h>
+#include <cstdio>
namespace cxxtools {
diff --git a/src/http/messageheader.cpp b/src/http/messageheader.cpp
index 9381be7..21ee7c3 100644
--- a/src/http/messageheader.cpp
+++ b/src/http/messageheader.cpp
@@ -30,6 +30,7 @@
#include <cxxtools/clock.h>
#include <cctype>
#include <sstream>
+#include <cstdio>
namespace cxxtools {

View File

@ -19,6 +19,8 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/host-build.mk include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
PKG_BUILD_DEPENDS:=cxxtools/host
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libiconv/include TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libiconv/include
TARGET_LDFLAGS+=-liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib TARGET_LDFLAGS+=-liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib

View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=vido PKG_NAME:=vido
PKG_VERSION:=20091107 PKG_VERSION:=20100124
PKG_REV:=046bb78668ceefb0cc7f1dc9df9fe22242d3e873 PKG_REV:=5d30ead071fc7f5f38e439824e97aa5d9ccea67a
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,15 +0,0 @@
Index: configure.in
===================================================================
--- a/configure.in (revision 239)
+++ b/configure.in (working copy)
@@ -26,9 +26,9 @@
if test "$with_cxxtools" = "yes"
then
AC_DEFINE(WITH_CXXTOOLS, [1], [defined if cxxtools is used])
+ AC_CHECK_HEADER([cxxtools/condition.h], , AC_MSG_ERROR([cxxtools headers not found]))
fi
-AC_CHECK_HEADER([cxxtools/condition.h], , AC_MSG_ERROR([cxxtools headers not found]))
AM_CONDITIONAL(WITH_CXXTOOLS, test "$with_cxxtools" = yes)
# output

View File

@ -1,13 +0,0 @@
Index: Makefile.am
===================================================================
--- a/Makefile.am (revision 239)
+++ b/Makefile.am (working copy)
@@ -1,8 +1,4 @@
SUBDIRS = \
src \
include \
- test \
zimDump
-
-test: all
- test/zimlib-test

View File

@ -1,13 +0,0 @@
--- zimlib.orig/src/fileimpl.cpp 2009-08-25 01:47:04.000000000 +0200
+++ zimlib/src/fileimpl.cpp 2009-10-08 13:02:45.000000000 +0200
@@ -43,8 +43,8 @@
//
FileImpl::FileImpl(const char* fname)
: zimFile(fname, std::ios::in | std::ios::binary),
- direntCache(512),
- clusterCache(16)
+ direntCache(32),
+ clusterCache(1)
{
if (!zimFile)
throw ZenoFileFormatError(std::string("can't open zim-file \"") + fname + '"');