1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-11-22 18:57:31 +02:00

Merge branch 'master' of projects.qi-hardware.com:openwrt-packages

This commit is contained in:
David Kühling 2010-08-01 17:24:44 +02:00
commit eef6ed8ec6
11 changed files with 806 additions and 6 deletions

View File

@ -37,6 +37,21 @@ define Build/Compile
cd $(PKG_BUILD_DIR)/primes; \ cd $(PKG_BUILD_DIR)/primes; \
$(TARGET_CC) -c -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings pattern.c pr_tbl.c primes.c; \ $(TARGET_CC) -c -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings pattern.c pr_tbl.c primes.c; \
$(TARGET_CC) -lm -o primes pattern.o pr_tbl.o primes.o $(TARGET_CC) -lm -o primes pattern.o pr_tbl.o primes.o
#Building worm
cd $(PKG_BUILD_DIR)/worm; \
$(TARGET_CC) -lncurses -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings -o worm worm.c
#Building backgammon
cd $(PKG_BUILD_DIR)/backgammon; \
cd common_source; \
$(TARGET_CC) -c -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings -I$(STAGING_DIR)/usr/include -DEXEC_PATH=\"/usr/bin/backgammon\" -DTEACH_PATH=\"/usr/bin/teachgammon\" allow.c board.c check.c fancy.c init.c odds.c one.c save.c subs.c table.c; \
cd ../backgammon; \
$(TARGET_CC) -c -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)/backgammon/common_source extra.c main.c move.c text.c version.c; \
$(TARGET_CC) -lncurses -L$(STAGING_DIR)/usr/lib -o backgammon $(ECHO) ../common_source/*.o ../backgammon/*.o; \
cd ../teachgammon; \
$(TARGET_CC) -c -O2 -Wall -W -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-align -Wcast-qual -Wwrite-strings -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)/backgammon/common_source data.c teach.c ttext1.c ttext2.c tutor.c; \
$(TARGET_CC) -lncurses -L$(STAGING_DIR)/usr/lib -o teachgammon $(ECHO) ../common_source/*.o ../teachgammon/*.o
endef endef
define Package/tetris define Package/tetris
@ -69,5 +84,41 @@ define Package/primes/install
$(1)/usr/bin/primes $(1)/usr/bin/primes
endef endef
define Package/worm
$(call Package/bsd-games)
TITLE:=The growing worm game
DEPENDS:=+libncurses
endef
define Package/worm/install
$(INSTALL_DIR) \
$(1)/usr/bin
$(INSTALL_BIN) \
$(PKG_BUILD_DIR)/worm/worm \
$(1)/usr/bin/worm
endef
define Package/backgammon
$(call Package/bsd-games)
TITLE:=the game of backgammon
DEPENDS:=+libncurses
endef
define Package/backgammon/install
$(INSTALL_DIR) \
$(1)/usr/bin
$(INSTALL_BIN) \
$(PKG_BUILD_DIR)/backgammon/backgammon/backgammon \
$(1)/usr/bin/backgammon
$(INSTALL_BIN) \
$(PKG_BUILD_DIR)/backgammon/teachgammon/teachgammon \
$(1)/usr/bin/teachgammon
endef
$(eval $(call BuildPackage,tetris)) $(eval $(call BuildPackage,tetris))
$(eval $(call BuildPackage,primes)) $(eval $(call BuildPackage,primes))
$(eval $(call BuildPackage,worm))
$(eval $(call BuildPackage,backgammon))

View File

@ -0,0 +1,26 @@
diff -u bsd-games-2.17/worm/worm.c bsd-games-2.17-p/worm/worm.c
--- bsd-games-2.17/worm/worm.c 2004-01-27 23:52:07.000000000 +0300
+++ bsd-games-2.17-p/worm/worm.c 2010-07-31 21:36:08.313419076 +0400
@@ -30,18 +30,18 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
__COPYRIGHT("@(#) Copyright (c) 1980, 1993\n\
The Regents of the University of California. All rights reserved.\n");
-#endif /* not lint */
+#endif */ /* not lint */
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)worm.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: worm.c,v 1.25 2004/01/27 20:30:31 jsm Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
/*
* Worm. Written by Michael Toy

View File

@ -0,0 +1,429 @@
diff -ur bsd-games-2.17/backgammon/backgammon/extra.c bsd-games-2.17-p/backgammon/backgammon/extra.c
--- bsd-games-2.17/backgammon/backgammon/extra.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/backgammon/extra.c 2010-07-31 22:10:07.910053909 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)extra.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: extra.c,v 1.5 2003/08/07 09:36:55 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
#include "backlocal.h"
diff -ur bsd-games-2.17/backgammon/backgammon/main.c bsd-games-2.17-p/backgammon/backgammon/main.c
--- bsd-games-2.17/backgammon/backgammon/main.c 2005-02-16 09:24:50.000000000 +0300
+++ bsd-games-2.17-p/backgammon/backgammon/main.c 2010-08-01 11:08:39.969952583 +0400
@@ -30,18 +30,18 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
__COPYRIGHT("@(#) Copyright (c) 1980, 1993\n\
The Regents of the University of California. All rights reserved.\n");
-#endif /* not lint */
+#endif */ /* not lint */
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)main.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: main.c,v 1.21 2005/02/15 12:56:20 jsm Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include <time.h>
@@ -49,6 +49,7 @@
#include "backlocal.h"
#define MVPAUSE 5 /* time to sleep when stuck */
+#define OXTABS XTABS
extern const char *const instr[]; /* text of instructions */
extern const char *const message[]; /* update message */
@@ -124,7 +125,7 @@
#ifdef V7
while (*++argv != 0) /* process arguments */
#else
- while (*++argv != -1) /* process arguments */
+ while (*++argv != 0) /* process arguments */
#endif
getarg(&argv);
args[acnt] = '\0';
diff -ur bsd-games-2.17/backgammon/backgammon/move.c bsd-games-2.17-p/backgammon/backgammon/move.c
--- bsd-games-2.17/backgammon/backgammon/move.c 2004-01-27 23:52:07.000000000 +0300
+++ bsd-games-2.17-p/backgammon/backgammon/move.c 2010-07-31 22:10:41.854259314 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)move.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: move.c,v 1.8 2004/01/27 20:30:28 jsm Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
#include "backlocal.h"
diff -ur bsd-games-2.17/backgammon/backgammon/text.c bsd-games-2.17-p/backgammon/backgammon/text.c
--- bsd-games-2.17/backgammon/backgammon/text.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/backgammon/text.c 2010-07-31 22:10:52.377805941 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)text.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: text.c,v 1.7 2003/08/07 09:36:56 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/backgammon/version.c bsd-games-2.17-p/backgammon/backgammon/version.c
--- bsd-games-2.17/backgammon/backgammon/version.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/backgammon/version.c 2010-07-31 22:11:05.756426999 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)version.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: version.c,v 1.6 2003/08/07 09:36:56 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
const char *const message[] = {
"Last updated on Friday, October 10, 1997.",
diff -ur bsd-games-2.17/backgammon/common_source/allow.c bsd-games-2.17-p/backgammon/common_source/allow.c
--- bsd-games-2.17/backgammon/common_source/allow.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/allow.c 2010-07-31 22:07:44.982982743 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)allow.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: allow.c,v 1.5 2003/08/07 09:36:56 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/board.c bsd-games-2.17-p/backgammon/common_source/board.c
--- bsd-games-2.17/backgammon/common_source/board.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/board.c 2010-07-31 22:08:08.852355705 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)board.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: board.c,v 1.7 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/check.c bsd-games-2.17-p/backgammon/common_source/check.c
--- bsd-games-2.17/backgammon/common_source/check.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/check.c 2010-07-31 22:08:22.639630328 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)check.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: check.c,v 1.5 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/fancy.c bsd-games-2.17-p/backgammon/common_source/fancy.c
--- bsd-games-2.17/backgammon/common_source/fancy.c 2004-04-24 20:13:09.000000000 +0400
+++ bsd-games-2.17-p/backgammon/common_source/fancy.c 2010-07-31 22:08:35.011397017 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)fancy.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: fancy.c,v 1.12 2004/04/23 02:58:27 simonb Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/init.c bsd-games-2.17-p/backgammon/common_source/init.c
--- bsd-games-2.17/backgammon/common_source/init.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/init.c 2010-07-31 22:08:46.900301922 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)init.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: init.c,v 1.8 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include <termios.h>
diff -ur bsd-games-2.17/backgammon/common_source/odds.c bsd-games-2.17-p/backgammon/common_source/odds.c
--- bsd-games-2.17/backgammon/common_source/odds.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/odds.c 2010-07-31 22:09:03.219958336 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)odds.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: odds.c,v 1.5 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/one.c bsd-games-2.17-p/backgammon/common_source/one.c
--- bsd-games-2.17/backgammon/common_source/one.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/one.c 2010-07-31 22:09:15.025538516 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)one.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: one.c,v 1.5 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/save.c bsd-games-2.17-p/backgammon/common_source/save.c
--- bsd-games-2.17/backgammon/common_source/save.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/save.c 2010-08-01 00:38:38.876427096 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)save.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: save.c,v 1.10 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include <errno.h>
diff -ur bsd-games-2.17/backgammon/common_source/subs.c bsd-games-2.17-p/backgammon/common_source/subs.c
--- bsd-games-2.17/backgammon/common_source/subs.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/subs.c 2010-08-01 11:10:44.780266356 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)subs.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: subs.c,v 1.14 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/common_source/table.c bsd-games-2.17-p/backgammon/common_source/table.c
--- bsd-games-2.17/backgammon/common_source/table.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/common_source/table.c 2010-07-31 22:09:54.655414207 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/* #ifndef lint
#if 0
static char sccsid[] = "@(#)table.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: table.c,v 1.7 2003/08/07 09:36:57 agc Exp $");
#endif
-#endif /* not lint */
+#endif */ /* not lint */
#include "back.h"
diff -ur bsd-games-2.17/backgammon/teachgammon/data.c bsd-games-2.17-p/backgammon/teachgammon/data.c
--- bsd-games-2.17/backgammon/teachgammon/data.c 2004-01-02 21:04:51.000000000 +0300
+++ bsd-games-2.17-p/backgammon/teachgammon/data.c 2010-08-01 11:18:14.579882098 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
#if 0
static char sccsid[] = "@(#)data.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: data.c,v 1.7 2004/01/01 15:59:09 jsm Exp $");
#endif
-#endif /* not lint */
+#endif *//* not lint */
#include "tutor.h"
diff -ur bsd-games-2.17/backgammon/teachgammon/teach.c bsd-games-2.17-p/backgammon/teachgammon/teach.c
--- bsd-games-2.17/backgammon/teachgammon/teach.c 2005-02-16 09:24:50.000000000 +0300
+++ bsd-games-2.17-p/backgammon/teachgammon/teach.c 2010-08-01 11:39:32.956134539 +0400
@@ -30,18 +30,18 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
__COPYRIGHT("@(#) Copyright (c) 1980, 1993\n\
The Regents of the University of California. All rights reserved.\n");
-#endif /* not lint */
+#endif *//* not lint */
-#ifndef lint
+/*#ifndef lint
#if 0
static char sccsid[] = "@(#)teach.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: teach.c,v 1.16 2005/02/15 12:56:20 jsm Exp $");
#endif
-#endif /* not lint */
+#endif *//* not lint */
#include "back.h"
#include "tutor.h"
@@ -59,6 +59,8 @@
0
};
+#define OXTABS XTABS
+
int
main(argc, argv)
int argc __attribute__((__unused__));
@@ -81,7 +83,7 @@
#ifdef V7
while (*++argv != 0)
#else
- while (*++argv != -1)
+ while (*++argv != 0)
#endif
getarg(&argv);
if (tflag) {
diff -ur bsd-games-2.17/backgammon/teachgammon/ttext1.c bsd-games-2.17-p/backgammon/teachgammon/ttext1.c
--- bsd-games-2.17/backgammon/teachgammon/ttext1.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/teachgammon/ttext1.c 2010-08-01 11:18:57.935091377 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
#if 0
static char sccsid[] = "@(#)ttext1.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: ttext1.c,v 1.7 2003/08/07 09:36:58 agc Exp $");
#endif
-#endif /* not lint */
+#endif *//* not lint */
#include "back.h"
#include "tutor.h"
diff -ur bsd-games-2.17/backgammon/teachgammon/ttext2.c bsd-games-2.17-p/backgammon/teachgammon/ttext2.c
--- bsd-games-2.17/backgammon/teachgammon/ttext2.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/teachgammon/ttext2.c 2010-08-01 11:19:09.174691288 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
#if 0
static char sccsid[] = "@(#)ttext2.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: ttext2.c,v 1.7 2003/08/07 09:36:58 agc Exp $");
#endif
-#endif /* not lint */
+#endif *//* not lint */
#include "back.h"
#include "tutor.h"
diff -ur bsd-games-2.17/backgammon/teachgammon/tutor.c bsd-games-2.17-p/backgammon/teachgammon/tutor.c
--- bsd-games-2.17/backgammon/teachgammon/tutor.c 2003-12-17 05:47:37.000000000 +0300
+++ bsd-games-2.17-p/backgammon/teachgammon/tutor.c 2010-08-01 11:37:12.464301896 +0400
@@ -30,13 +30,13 @@
*/
#include <sys/cdefs.h>
-#ifndef lint
+/*#ifndef lint
#if 0
static char sccsid[] = "@(#)tutor.c 8.1 (Berkeley) 5/31/93";
#else
__RCSID("$NetBSD: tutor.c,v 1.6 2003/08/07 09:36:58 agc Exp $");
#endif
-#endif /* not lint */
+#endif *//* not lint */
#include "back.h"
#include "tutor.h"

View File

@ -1,6 +1,5 @@
# #
# Copyright (C) 2010 Qi Hardware Inc. # Author: Xiangfu Liu <xiangfu@sharism.cc>
# Author: Xiangfu Liu <xiangfu@sharism.com>
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.

77
freedroid/Makefile Normal file
View File

@ -0,0 +1,77 @@
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=freedroid
PKG_VERSION:=1.0.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/freedroid/freedroidClassic/FreedroidClassic-1.0.2/
PKG_CAT:=zcat
PKG_MD5SUM:=585a65f61c2cd308ab45d5c514f695dc
PKG_BUILD_DIR:=$(BUILD_DIR)/freedroid-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/freedroid
TITLE:=FreeDroid
SECTION:=games
CATEGORY:=Games
URL:=http://freedroid.sourceforge.net/
DEPENDS:=+libsdl-image +libsdl-mixer +libvorbis
endef
define Package/freedroid/description
A free clone of the C64-classic "Paradroid"
endef
CONFIGURE_VARS+=LDFLAGS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib" ac_cv_lib_vorbis_ov_open="yes"
CONFIGURE_ARGS+=--with-x="no"
define Package/freedroid/install
$(INSTALL_DIR) \
$(1)/usr/bin/ \
$(1)/usr/share/freedroid/ \
$(1)/usr/share/freedroid/graphics/ \
$(1)/usr/share/freedroid/graphics/classic_theme/ \
$(1)/usr/share/freedroid/graphics/lanzz_theme/ \
$(1)/usr/share/freedroid/map/ \
$(1)/usr/share/freedroid/sound
$(INSTALL_BIN) \
$(PKG_BUILD_DIR)/src/freedroid \
$(1)/usr/bin/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/graphics/*.png \
$(PKG_BUILD_DIR)/graphics/*.jpg \
$(1)/usr/share/freedroid/graphics/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/graphics/classic_theme/*.png \
$(PKG_BUILD_DIR)/graphics/classic_theme/config.theme \
$(1)/usr/share/freedroid/graphics/classic_theme/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/graphics/lanzz_theme/*.png \
$(PKG_BUILD_DIR)/graphics/lanzz_theme/config.theme \
$(1)/usr/share/freedroid/graphics/lanzz_theme/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/map/freedroid.ruleset \
$(PKG_BUILD_DIR)/map/Paradroid.* \
$(1)/usr/share/freedroid/map/
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/sound/*.wav \
$(PKG_BUILD_DIR)/sound/*.mod \
$(PKG_BUILD_DIR)/sound/*.ogg \
$(1)/usr/share/freedroid/sound/
endef
$(eval $(call BuildPackage,freedroid))

View File

@ -0,0 +1,86 @@
diff -u /tmp/freedroid-1.0.2/src/defs.h ./src/defs.h
--- /tmp/freedroid-1.0.2/src/defs.h 2003-08-09 22:42:08.000000000 +1200
+++ ./src/defs.h 2010-07-28 22:57:36.000000000 +1200
@@ -43,6 +43,9 @@
#define DROID_ROTATION_TIME 3.0
#define NUM_DECAL_PICS 2
+// Don't want the mouse cursor at all on the NanoNote
+#define SDL_ShowCursor( visible) 1
+
#define UserCenter_x (User_Rect.x + User_Rect.w/2)
#define UserCenter_y (User_Rect.y + User_Rect.h/2)
@@ -72,11 +75,11 @@
#define RightPressed() (KeyIsPressed(SDLK_RIGHT)||KeyIsPressed('d'))
#define EscapePressed() KeyIsPressed(SDLK_ESCAPE)
-#define SpacePressed() KeyIsPressed(SDLK_SPACE)
+#define SpacePressed() KeyIsPressed(SDLK_TAB)
#define FirePressed() (SpacePressed()||MouseLeftPressed())
#define EscapePressedR() KeyIsPressedR (SDLK_ESCAPE)
-#define SpacePressedR() KeyIsPressedR (SDLK_SPACE)
+#define SpacePressedR() KeyIsPressedR (SDLK_TAB)
#define FirePressedR() (SpacePressedR()||MouseLeftPressedR())
#define UpPressedR() (KeyIsPressedR(SDLK_UP)||KeyIsPressedR('w'))
Only in ./src/: .deps
diff -u /tmp/freedroid-1.0.2/src/init.c ./src/init.c
--- /tmp/freedroid-1.0.2/src/init.c 2003-08-10 00:19:32.000000000 +1200
+++ ./src/init.c 2010-07-28 22:13:15.000000000 +1200
@@ -912,7 +912,7 @@
GameConfig.TakeoverActivates = TRUE;
GameConfig.ShowDecals = TRUE;
GameConfig.AllMapVisible = TRUE; // classic setting: map always visible
- GameConfig.scale = 1.0; // overall scaling of _all_ graphics (e.g. for 320x200 displays)
+ GameConfig.scale = 0.5; // overall scaling of _all_ graphics (e.g. for 320x200 displays)
// now load saved options from the config-file
LoadGameConfig ();
diff -u /tmp/freedroid-1.0.2/src/main.c ./src/main.c
--- /tmp/freedroid-1.0.2/src/main.c 2003-08-09 22:30:43.000000000 +1200
+++ ./src/main.c 2010-07-28 22:55:08.000000000 +1200
@@ -47,6 +47,7 @@
extern bool show_cursor;
void UpdateCountersForThisFrame (void);
+void turn_off_cursor();
/*-----------------------------------------------------------------
* @Desc: the heart of the Game
@@ -72,6 +73,8 @@
now = SDL_GetTicks();
InitFreedroid (argc, argv); // Initialisation of global variables and arrays
+ turn_off_cursor();
+
SDL_ShowCursor (SDL_DISABLE);
#ifdef __WIN32__
@@ -246,4 +249,11 @@
} /* UpdateCountersForThisFrame() */
+void turn_off_cursor()
+{
+ #undef SDL_ShowCursor
+ SDL_ShowCursor( SDL_DISABLE);
+}
+
+
#undef _main_c
Only in ./src/: Makefile
diff -u /tmp/freedroid-1.0.2/src/sound.c ./src/sound.c
--- /tmp/freedroid-1.0.2/src/sound.c 2003-08-09 03:09:20.000000000 +1200
+++ ./src/sound.c 2010-07-29 00:16:45.000000000 +1200
@@ -347,8 +347,7 @@
if ( Tmp_MOD_File == NULL )
{
DebugPrintf (0, "\nError loading sound-file: %s\n", filename_raw);
- DebugPrintf (0, "SDL Mixer Error: %s\n Continuing with sound disabled\n", Mix_GetError());
- sound_on = FALSE;
+ DebugPrintf (0, "SDL Mixer Error: %s\n", Mix_GetError());
return;
} // if ( !Loaded_WAV...
Mix_PlayMusic (Tmp_MOD_File, -1);

View File

@ -6,6 +6,9 @@
# See /LICENSE for more information. # See /LICENSE for more information.
# #
# modified 02/05/2010
# author: jmoore@zedstar.org
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=guile PKG_NAME:=guile
@ -24,7 +27,7 @@ define Package/guile
TITLE:=guile TITLE:=guile
SECTION:=lang SECTION:=lang
CATEGORY:=Languages CATEGORY:=Languages
DEPENDS:=+libgmp +libpthread +libltdl @BROKEN DEPENDS:=+libgmp +libpthread +libltdl +libncurses +libreadline
URL:=http://savannah.gnu.org/projects/guile/ URL:=http://savannah.gnu.org/projects/guile/
endef endef
@ -34,7 +37,12 @@ endef
TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib" TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
CONFIGURE_ARGS += --without-threads # should fix issue with threads
CONFIGURE_ARGS += --without-threads --without-gettext
define Build/Compile
(cd $(PKG_BUILD_DIR); autoreconf --force --install || exit 0);
endef
define Package/guile/install define Package/guile/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin

View File

@ -21,8 +21,9 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define Package/links define Package/links
TITLE:=links TITLE:=Text and graphics WWW browser
SECTION:=network SUBMENU:=Web
SECTION:=net
CATEGORY:=Network CATEGORY:=Network
URL:=http://links.twibright.com/ URL:=http://links.twibright.com/
DEPENDS:=+libpng +libtiff DEPENDS:=+libpng +libtiff

53
plucker/Makefile Normal file
View File

@ -0,0 +1,53 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=plucker
PKG_VERSION:=1.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.plkr.org/1.8/
PKG_CAT:=bzip2 -cd
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/plucker
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Plucker files reader (PDB)
DEPENDS:=@BROKEN +zlib +libintl +libiconv +libgconf2 +libjpeg +pixman +fontconfig +libfreetype +pango +atk +libpng +DirectFB
URL=http://www.plkr.org
endef
define Package/plucker/description
Plucker can view files made by the Plucker Distiller (Project Gutenberg books, for example).
endef
TARGET_CFLAGS+= -I$(STAGING_DIR)/usr/lib/libintl/include
TARGET_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/libintl/lib
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Build/Configure
$(call Build/Configure/Default, \
--prefix=/usr \
--disable-palmosbuild \
--disable-docbuild \
--disable-java-distiller\
--enable-gtkviewer\
--enable-unplug \
--disable-explode \
--disable-desktopbuild, \
LIBS="-L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib -lgtk-directfb-2.0 -lgdk-directfb-2.0 -latk-1.0 -lgio-2.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpangoft2-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv -lfreetype -lfontconfig -ljpeg -lpng -lpixman-1 -ldirectfb -ldirect -lfusion -lexpat -lz -lm"\
)
endef
define Package/plucker/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/viewer-GTK+2-POSIX/plucker $(1)/usr/bin/
endef
$(eval $(call BuildPackage,plucker))

51
plucker/Makefile.bad Normal file
View File

@ -0,0 +1,51 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=plucker
PKG_VERSION:=1.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.plkr.org/1.8/
PKG_CAT:=bzip2 -cd
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/plucker
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Plucker files reader (PDB)
DEPENDS:=+zlib +libintl +libiconv +libgconf2 +gtk +jpeg +pixman +fontconfig +libfreetype +pango +atk +libpng +DirectFB
URL=http://www.plkr.org
endef
define Package/plucker/description
Plucker can view files made by the Plucker Distiller (Project Gutenberg books, for example).
endef
#TARGET_CFLAGS+=-"I$(STAGING_DIR)/usr/include/gtk-2.0 -I$(STAGING_DIR)/usr/include"
define Build/Configure
$(call Build/Configure/Default, \
--prefix=/usr \
--disable-palmosbuild \
--disable-docbuild \
--disable-java-distiller\
--enable-gtkviewer\
--enable-unplug \
--disable-explode \
--disable-desktopbuild, \
LIBS="-L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib" \
GTK2LIBS="-latk -lpixman -lfontconfig -lpng"\
)
endef
define Package/plucker/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/viewer-GTK+2-POSIX/plucker $(1)/usr/bin/
endef
$(eval $(call BuildPackage,plucker))

View File

@ -0,0 +1,19 @@
--- plucker-1.8/configure 2004-05-19 17:19:43.000000000 +0200
+++ plucker-1.8m/configure 2010-07-31 17:14:40.040292498 +0200
@@ -4655,6 +4655,7 @@
has_jpeg_library=no
fi
+BUILD_UNPLUCK=yes
if test "$BUILD_UNPLUCK" != "yes"; then
echo "$as_me:$LINENO: result: libunpluck will not be built, by request" >&5
@@ -4670,6 +4671,8 @@
BUILD_UNPLUCK=no
fi
+BUILD_UNPLUCK=yes
+
if test "$BUILD_EXPLODE" = "no" ; then
echo "$as_me:$LINENO: result: explode will not be built, by request" >&5
echo "${ECHO_T}explode will not be built, by request" >&6