mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 10:13:07 +02:00
add zimlib
This commit is contained in:
parent
3ff47e6f71
commit
f3c54f9039
61
zimlib/Makefile
Normal file
61
zimlib/Makefile
Normal file
@ -0,0 +1,61 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zimlib
|
||||
PKG_REV:=239
|
||||
PKG_VERSION:=r$(PKG_REV)
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://svn.openzim.org/svnroot/trunk/zimlib
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_FIXUP:=libtool-uclibxx
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
#CONFIGURE_VARS += \
|
||||
# CXX="g++-uc"
|
||||
#
|
||||
#MAKE_FLAGS += \
|
||||
# CXX="g++-uc"
|
||||
|
||||
define Package/zimlib
|
||||
TITLE:=zimlib
|
||||
SECTION:=network
|
||||
CATEGORY:=Network
|
||||
#DEPENDS:=+zlib +bzip2 +cxxtools +uclibcxx
|
||||
DEPENDS:=+zlib +bzip2 +cxxtools +libstdcpp
|
||||
URL:=http://openzim.org
|
||||
endef
|
||||
|
||||
define Package/zimlib/description
|
||||
foobar
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
( cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
define Package/zimlib/install
|
||||
$(INSTALL_DIR) $(1)
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,zimlib))
|
15
zimlib/patches/001-fix-cxxtools-option.patch
Normal file
15
zimlib/patches/001-fix-cxxtools-option.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
--- a/configure.in (revision 239)
|
||||
+++ b/configure.in (working copy)
|
||||
@@ -26,9 +26,9 @@
|
||||
if test "$with_cxxtools" = "yes"
|
||||
then
|
||||
AC_DEFINE(WITH_CXXTOOLS, [1], [defined if cxxtools is used])
|
||||
+ AC_CHECK_HEADER([cxxtools/condition.h], , AC_MSG_ERROR([cxxtools headers not found]))
|
||||
fi
|
||||
|
||||
-AC_CHECK_HEADER([cxxtools/condition.h], , AC_MSG_ERROR([cxxtools headers not found]))
|
||||
AM_CONDITIONAL(WITH_CXXTOOLS, test "$with_cxxtools" = yes)
|
||||
|
||||
# output
|
13
zimlib/patches/002-disable-tests.patch
Normal file
13
zimlib/patches/002-disable-tests.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: Makefile.am
|
||||
===================================================================
|
||||
--- a/Makefile.am (revision 239)
|
||||
+++ b/Makefile.am (working copy)
|
||||
@@ -1,8 +1,4 @@
|
||||
SUBDIRS = \
|
||||
src \
|
||||
include \
|
||||
- test \
|
||||
zimDump
|
||||
-
|
||||
-test: all
|
||||
- test/zimlib-test
|
Loading…
Reference in New Issue
Block a user