1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 04:03:17 +03:00
openwrt-packages/offrss/patches/001-fix-the-static-gcc-in-Makefile.patch
2011-01-13 14:36:18 +08:00

14 lines
437 B
Diff

diff --git a/Makefile b/Makefile
index ff2e231..8414bae 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
VERSION=$(shell if test -f manifest.uuid; then cat manifest.uuid | cut -c -10 ; else echo undefined; fi)
offrss: offrss.c server.c encoding.c util.c
- gcc -DVERSION="$(VERSION)" -g -o $@ $^ -lmrss -lcurl
+ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION="$(VERSION)" -g -o $@ $^ -lmrss -lcurl
offrss.c: offrss.h
server.c: offrss.h