mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2025-02-17 00:24:42 +02:00
76 lines
2.1 KiB
Diff
76 lines
2.1 KiB
Diff
From 2bb92ebcdc4612d218e965b8f6f6f22b6b3ff21d Mon Sep 17 00:00:00 2001
|
|
From: Xiangfu <xiangfu@openmobilefree.net>
|
|
Date: Mon, 13 Feb 2012 16:04:13 +0800
|
|
Subject: [PATCH 4/7] add Icarus support to autoreconf system
|
|
|
|
---
|
|
Makefile.am | 3 +++
|
|
configure.ac | 21 +++++++++++++++++++--
|
|
2 files changed, 22 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 4249d51..5262d52 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -70,3 +70,6 @@ if HAS_BITFORCE
|
|
cgminer_SOURCES += bitforce.c
|
|
endif
|
|
|
|
+if HAS_ICARUS
|
|
+cgminer_SOURCES += icarus.c
|
|
+endif
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d2fdbb4..ce89c6f 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -196,6 +196,17 @@ if test "x$bitforce" = xyes; then
|
|
fi
|
|
AM_CONDITIONAL([HAS_BITFORCE], [test x$bitforce = xyes])
|
|
|
|
+icarus="no"
|
|
+
|
|
+AC_ARG_ENABLE([icarus],
|
|
+ [AC_HELP_STRING([--enable-icarus],[Compile support for Icarus (default disabled)])],
|
|
+ [icarus=$enableval]
|
|
+ )
|
|
+if test "x$icarus" = xyes; then
|
|
+ AC_DEFINE([USE_ICARUS], [1], [Defined to 1 if Icarus support is wanted])
|
|
+fi
|
|
+AM_CONDITIONAL([HAS_ICARUS], [test x$icarus = xyes])
|
|
+
|
|
AC_SEARCH_LIBS(addstr, ncurses pdcurses, ,
|
|
AC_MSG_ERROR([Could not find curses library - please install libncurses-dev or pdcurses-dev]))
|
|
|
|
@@ -338,13 +349,13 @@ if test "x$opencl" != xno; then
|
|
echo " OpenCL...............: FOUND. GPU mining support enabled"
|
|
else
|
|
echo " OpenCL...............: NOT FOUND. GPU mining support DISABLED"
|
|
- if test "x$cpumining$bitforce" = xnono; then
|
|
+ if test "x$cpumining$bitforce$icarus" = xnonono; then
|
|
AC_MSG_ERROR([No mining configured in])
|
|
fi
|
|
fi
|
|
else
|
|
echo " OpenCL...............: Detection overrided. GPU mining support DISABLED"
|
|
- if test "x$cpumining$bitforce" = xnono; then
|
|
+ if test "x$cpumining$bitforce$icarus" = xnonono; then
|
|
AC_MSG_ERROR([No mining configured in])
|
|
fi
|
|
fi
|
|
@@ -366,6 +377,12 @@ else
|
|
echo " BitForce.FPGAs.......: Disabled"
|
|
fi
|
|
|
|
+if test "x$icarus" = xyes; then
|
|
+ echo " Icarus.FPGAs.........: Enabled"
|
|
+else
|
|
+ echo " Icarus.FPGAs.........: Disabled"
|
|
+fi
|
|
+
|
|
echo
|
|
if test "x$cpumining" = xyes; then
|
|
echo " CPU Mining...........: Enabled"
|
|
--
|
|
1.7.5.4
|
|
|