mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 16:36:16 +02:00
Split patches.
Use full target optimization flags (save a few KB). Do a make depend before building. Remove unneeded targets from main Makefile. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1136 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
43512102de
commit
00495d614b
@ -40,8 +40,12 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
$(PKG_BUILD_DIR)/.built:
|
$(PKG_BUILD_DIR)/.built:
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
mkdir -p $(PKG_INSTALL_DIR)
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
||||||
|
MAKEDEPPROG="$(TARGET_CC)" \
|
||||||
|
depend
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
||||||
CC="$(TARGET_CC)" \
|
CC="$(TARGET_CC)" \
|
||||||
|
CCOPTS="$(TARGET_CFLAGS) -fomit-frame-pointer" \
|
||||||
AR="$(TARGET_CROSS)ar r" \
|
AR="$(TARGET_CROSS)ar r" \
|
||||||
RANLIB="$(TARGET_CROSS)ranlib" \
|
RANLIB="$(TARGET_CROSS)ranlib" \
|
||||||
all build-shared
|
all build-shared
|
||||||
@ -49,6 +53,7 @@ $(PKG_BUILD_DIR)/.built:
|
|||||||
-rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
|
-rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
||||||
CC=$(TARGET_CC) \
|
CC=$(TARGET_CC) \
|
||||||
|
CCOPTS="$(TARGET_CFLAGS) -fomit-frame-pointer" \
|
||||||
do_linux-shared
|
do_linux-shared
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
$(MAKE) -C $(PKG_BUILD_DIR) -j1 \
|
||||||
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
||||||
@ -57,18 +62,18 @@ $(PKG_BUILD_DIR)/.built:
|
|||||||
|
|
||||||
$(IPKG_LIBOPENSSL):
|
$(IPKG_LIBOPENSSL):
|
||||||
install -d -m0755 $(IDIR_LIBOPENSSL)/usr/lib
|
install -d -m0755 $(IDIR_LIBOPENSSL)/usr/lib
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(IDIR_LIBOPENSSL)/usr/lib/
|
cp -fp $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(IDIR_LIBOPENSSL)/usr/lib/
|
||||||
chmod 0644 $(IDIR_LIBOPENSSL)/usr/lib/*
|
chmod 0644 $(IDIR_LIBOPENSSL)/usr/lib/*
|
||||||
$(RSTRIP) $(IDIR_LIBOPENSSL)
|
$(RSTRIP) $(IDIR_LIBOPENSSL)
|
||||||
$(IPKG_BUILD) $(IDIR_LIBOPENSSL) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_LIBOPENSSL) $(PACKAGE_DIR)
|
||||||
|
|
||||||
$(IPKG_OPENSSL_UTIL):
|
$(IPKG_OPENSSL_UTIL):
|
||||||
install -d -m0755 $(IDIR_OPENSSL_UTIL)/etc/ssl
|
install -d -m0755 $(IDIR_OPENSSL_UTIL)/etc/ssl
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(IDIR_OPENSSL_UTIL)/etc/ssl/
|
cp -fp $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(IDIR_OPENSSL_UTIL)/etc/ssl/
|
||||||
install -d -m0755 $(IDIR_OPENSSL_UTIL)/etc/ssl/certs
|
install -d -m0755 $(IDIR_OPENSSL_UTIL)/etc/ssl/certs
|
||||||
install -d -m0700 $(IDIR_OPENSSL_UTIL)/etc/ssl/private
|
install -d -m0700 $(IDIR_OPENSSL_UTIL)/etc/ssl/private
|
||||||
install -d -m0755 $(IDIR_OPENSSL_UTIL)/usr/bin
|
install -d -m0755 $(IDIR_OPENSSL_UTIL)/usr/bin
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/openssl $(IDIR_OPENSSL_UTIL)/usr/bin/
|
cp -fp $(PKG_INSTALL_DIR)/usr/bin/openssl $(IDIR_OPENSSL_UTIL)/usr/bin/
|
||||||
$(RSTRIP) $(IDIR_OPENSSL_UTIL)
|
$(RSTRIP) $(IDIR_OPENSSL_UTIL)
|
||||||
$(IPKG_BUILD) $(IDIR_OPENSSL_UTIL) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_OPENSSL_UTIL) $(PACKAGE_DIR)
|
||||||
|
|
||||||
@ -76,15 +81,15 @@ $(STAGING_DIR)/usr/lib/libssl.so: $(PKG_BUILD_DIR)/.built
|
|||||||
mkdir -p $(STAGING_DIR)/usr/include
|
mkdir -p $(STAGING_DIR)/usr/include
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
|
cp -fpR $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
|
||||||
mkdir -p $(STAGING_DIR)/usr/lib/
|
mkdir -p $(STAGING_DIR)/usr/lib/
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
|
cp -fp $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
install-dev: $(STAGING_DIR)/usr/lib/libssl.so
|
install-dev: $(STAGING_DIR)/usr/lib/libssl.so
|
||||||
|
|
||||||
uninstall-dev:
|
uninstall-dev:
|
||||||
rm -rf \
|
rm -rf \
|
||||||
$(STAGING_DIR)/usr/include/openssl \
|
$(STAGING_DIR)/usr/include/openssl \
|
||||||
$(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} \
|
$(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} \
|
||||||
|
|
||||||
compile: install-dev
|
compile: install-dev
|
||||||
clean: uninstall-dev
|
clean: uninstall-dev
|
||||||
|
@ -7,8 +7,8 @@ diff -Nur openssl-0.9.7g/Configure openssl-0.9.7g-Os/Configure
|
|||||||
"linux-aout", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall::(unknown):::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}",
|
"linux-aout", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall::(unknown):::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}",
|
||||||
-"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
-"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
-"linux-mips", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
-"linux-mips", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
+"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO -Os -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
+"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO \$(CCOPTS) -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
+"linux-mips", "gcc:-DB_ENDIAN -DTERMIO -Os -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
+"linux-mips", "gcc:-DB_ENDIAN -DTERMIO \$(CCOPTS) -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
"linux-ppc", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc32.o:::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
"linux-ppc", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc32.o:::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
# -bpowerpc64-linux is transient option, -m64 should be the one to use...
|
# -bpowerpc64-linux is transient option, -m64 should be the one to use...
|
||||||
"linux-ppc64", "gcc:-bpowerpc64-linux -DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc64.o:::::::::dlfcn:linux-shared:-fPIC:-bpowerpc64-linux:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
"linux-ppc64", "gcc:-bpowerpc64-linux -DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc64.o:::::::::dlfcn:linux-shared:-fPIC:-bpowerpc64-linux:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
||||||
|
22
openwrt/package/openssl/patches/120-makedepend.patch
Normal file
22
openwrt/package/openssl/patches/120-makedepend.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff -ruN openssl-0.9.7g-old/util/domd openssl-0.9.7g-new/util/domd
|
||||||
|
--- openssl-0.9.7g-old/util/domd 2004-05-11 14:46:18.000000000 +0200
|
||||||
|
+++ openssl-0.9.7g-new/util/domd 2005-05-30 20:20:04.000000000 +0200
|
||||||
|
@@ -14,7 +14,8 @@
|
||||||
|
cp Makefile Makefile.save
|
||||||
|
# fake the presence of Kerberos
|
||||||
|
touch $TOP/krb5.h
|
||||||
|
-if [ "$MAKEDEPEND" = "gcc" ]; then
|
||||||
|
+D=${MAKEDEPEND/%*gcc/gcc}
|
||||||
|
+if [ "$D" = "gcc" ]; then
|
||||||
|
args=""
|
||||||
|
while [ $# -gt 0 ]; do
|
||||||
|
if [ "$1" != "--" ]; then args="$args $1"; fi
|
||||||
|
@@ -22,7 +23,7 @@
|
||||||
|
done
|
||||||
|
sed -e '/^# DO NOT DELETE.*/,$d' < Makefile > Makefile.tmp
|
||||||
|
echo '# DO NOT DELETE THIS LINE -- make depend depends on it.' >> Makefile.tmp
|
||||||
|
- gcc -D OPENSSL_DOING_MAKEDEPEND -M $args >> Makefile.tmp
|
||||||
|
+ ${MAKEDEPEND} -D OPENSSL_DOING_MAKEDEPEND -M $args >> Makefile.tmp
|
||||||
|
${PERL} $TOP/util/clean-depend.pl < Makefile.tmp > Makefile.new
|
||||||
|
rm -f Makefile.tmp
|
||||||
|
else
|
72
openwrt/package/openssl/patches/130-perl-path.patch
Normal file
72
openwrt/package/openssl/patches/130-perl-path.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
diff -Nur openssl-0.9.7f/Configure openssl-0.9.7f.new/Configure
|
||||||
|
--- openssl-0.9.7f/Configure 2005-03-12 12:28:21.000000000 +0100
|
||||||
|
+++ openssl-0.9.7f.new/Configure 2005-04-03 20:32:00.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-:
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
eval 'exec perl -S $0 ${1+"$@"}'
|
||||||
|
if $running_under_some_shell;
|
||||||
|
##
|
||||||
|
diff -Nur openssl-0.9.7f/tools/c_rehash.in openssl-0.9.7f.new/tools/c_rehash.in
|
||||||
|
--- openssl-0.9.7f/tools/c_rehash.in 2002-10-11 22:35:45.000000000 +0200
|
||||||
|
+++ openssl-0.9.7f.new/tools/c_rehash.in 2005-04-03 20:41:17.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
|
||||||
|
|
||||||
|
# Perl c_rehash script, scan all files in a directory
|
||||||
|
diff -Nur openssl-0.9.7f/util/clean-depend.pl openssl-0.9.7f.new/util/clean-depend.pl
|
||||||
|
--- openssl-0.9.7f/util/clean-depend.pl 2001-10-10 10:27:28.000000000 +0200
|
||||||
|
+++ openssl-0.9.7f.new/util/clean-depend.pl 2005-04-03 20:41:38.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl -w
|
||||||
|
+#!/usr/bin/perl -w
|
||||||
|
# Clean the dependency list in a makefile of standard includes...
|
||||||
|
# Written by Ben Laurie <ben@algroup.co.uk> 19 Jan 1999
|
||||||
|
|
||||||
|
diff -Nur openssl-0.9.7f/util/mkdef.pl openssl-0.9.7f.new/util/mkdef.pl
|
||||||
|
--- openssl-0.9.7f/util/mkdef.pl 2005-02-05 18:19:23.000000000 +0100
|
||||||
|
+++ openssl-0.9.7f.new/util/mkdef.pl 2005-04-03 20:42:49.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl -w
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
#
|
||||||
|
# generate a .def file
|
||||||
|
#
|
||||||
|
diff -Nur openssl-0.9.7f/util/mkerr.pl openssl-0.9.7f.new/util/mkerr.pl
|
||||||
|
--- openssl-0.9.7f/util/mkerr.pl 2005-01-31 02:28:17.000000000 +0100
|
||||||
|
+++ openssl-0.9.7f.new/util/mkerr.pl 2005-04-03 20:43:02.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl -w
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
|
||||||
|
my $config = "crypto/err/openssl.ec";
|
||||||
|
my $debug = 0;
|
||||||
|
diff -Nur openssl-0.9.7f/util/mkstack.pl openssl-0.9.7f.new/util/mkstack.pl
|
||||||
|
--- openssl-0.9.7f/util/mkstack.pl 2004-10-04 18:27:36.000000000 +0200
|
||||||
|
+++ openssl-0.9.7f.new/util/mkstack.pl 2005-04-03 20:43:18.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl -w
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
|
||||||
|
# This is a utility that searches out "DECLARE_STACK_OF()"
|
||||||
|
# declarations in .h and .c files, and updates/creates/replaces
|
||||||
|
diff -Nur openssl-0.9.7f/util/pod2man.pl openssl-0.9.7f.new/util/pod2man.pl
|
||||||
|
--- openssl-0.9.7f/util/pod2man.pl 2002-05-30 17:30:21.000000000 +0200
|
||||||
|
+++ openssl-0.9.7f.new/util/pod2man.pl 2005-04-03 20:43:52.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-: #!/usr/bin/perl-5.005
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
|
||||||
|
if $running_under_some_shell;
|
||||||
|
|
||||||
|
diff -Nur openssl-0.9.7f/util/selftest.pl openssl-0.9.7f.new/util/selftest.pl
|
||||||
|
--- openssl-0.9.7f/util/selftest.pl 2004-05-11 14:46:19.000000000 +0200
|
||||||
|
+++ openssl-0.9.7f.new/util/selftest.pl 2005-04-03 20:44:10.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/local/bin/perl -w
|
||||||
|
+#!/usr/bin/perl
|
||||||
|
#
|
||||||
|
# Run the test suite and generate a report
|
||||||
|
#
|
12
openwrt/package/openssl/patches/140-makefile-dirs.patch
Normal file
12
openwrt/package/openssl/patches/140-makefile-dirs.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
|
||||||
|
--- openssl-0.9.7f/Makefile.org 2005-03-15 10:46:13.000000000 +0100
|
||||||
|
+++ openssl-0.9.7f.new/Makefile.org 2005-04-03 20:15:26.000000000 +0200
|
||||||
|
@@ -175,7 +175,7 @@
|
||||||
|
# we might set SHLIB_MARK to '$(SHARED_LIBS)'.
|
||||||
|
SHLIB_MARK=
|
||||||
|
|
||||||
|
-DIRS= crypto fips ssl $(SHLIB_MARK) sigs apps test tools
|
||||||
|
+DIRS= crypto ssl apps
|
||||||
|
SHLIBDIRS= crypto ssl
|
||||||
|
|
||||||
|
# dirs in crypto to build
|
@ -1,15 +1,6 @@
|
|||||||
diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
|
diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
|
||||||
--- openssl-0.9.7f/Makefile.org 2005-03-15 10:46:13.000000000 +0100
|
--- openssl-0.9.7f/Makefile.org 2005-03-15 10:46:13.000000000 +0100
|
||||||
+++ openssl-0.9.7f.new/Makefile.org 2005-04-03 20:15:26.000000000 +0200
|
+++ openssl-0.9.7f.new/Makefile.org 2005-04-03 20:15:26.000000000 +0200
|
||||||
@@ -175,7 +175,7 @@
|
|
||||||
# we might set SHLIB_MARK to '$(SHARED_LIBS)'.
|
|
||||||
SHLIB_MARK=
|
|
||||||
|
|
||||||
-DIRS= crypto fips ssl $(SHLIB_MARK) sigs apps test tools
|
|
||||||
+DIRS= crypto ssl $(SHLIB_MARK) sigs apps test tools
|
|
||||||
SHLIBDIRS= crypto ssl
|
|
||||||
|
|
||||||
# dirs in crypto to build
|
|
||||||
@@ -229,7 +229,6 @@
|
@@ -229,7 +229,6 @@
|
||||||
libcrypto.a.sha1: libcrypto.a
|
libcrypto.a.sha1: libcrypto.a
|
||||||
@if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
|
@if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
|
@ -1,180 +0,0 @@
|
|||||||
diff -Nur openssl-0.9.7f/Configure openssl-0.9.7f.new/Configure
|
|
||||||
--- openssl-0.9.7f/Configure 2005-03-12 12:28:21.000000000 +0100
|
|
||||||
+++ openssl-0.9.7f.new/Configure 2005-04-03 20:32:00.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-:
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
eval 'exec perl -S $0 ${1+"$@"}'
|
|
||||||
if $running_under_some_shell;
|
|
||||||
##
|
|
||||||
diff -Nur openssl-0.9.7f/include/openssl/opensslconf.h openssl-0.9.7f.new/include/openssl/opensslconf.h
|
|
||||||
--- openssl-0.9.7f/include/openssl/opensslconf.h 2005-03-22 20:18:28.000000000 +0100
|
|
||||||
+++ openssl-0.9.7f.new/include/openssl/opensslconf.h 2005-04-03 20:38:09.000000000 +0200
|
|
||||||
@@ -4,17 +4,38 @@
|
|
||||||
/* OpenSSL was configured with the following options: */
|
|
||||||
#ifndef OPENSSL_DOING_MAKEDEPEND
|
|
||||||
|
|
||||||
+#ifndef OPENSSL_NO_IDEA
|
|
||||||
+# define OPENSSL_NO_IDEA
|
|
||||||
+#endif
|
|
||||||
+#ifndef OPENSSL_NO_MDC2
|
|
||||||
+# define OPENSSL_NO_MDC2
|
|
||||||
+#endif
|
|
||||||
+#ifndef OPENSSL_NO_RC5
|
|
||||||
+# define OPENSSL_NO_RC5
|
|
||||||
+#endif
|
|
||||||
#ifndef OPENSSL_NO_KRB5
|
|
||||||
# define OPENSSL_NO_KRB5
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#endif /* OPENSSL_DOING_MAKEDEPEND */
|
|
||||||
+#ifndef OPENSSL_THREADS
|
|
||||||
+# define OPENSSL_THREADS
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/* The OPENSSL_NO_* macros are also defined as NO_* if the application
|
|
||||||
asks for it. This is a transient feature that is provided for those
|
|
||||||
who haven't had the time to do the appropriate changes in their
|
|
||||||
applications. */
|
|
||||||
#ifdef OPENSSL_ALGORITHM_DEFINES
|
|
||||||
+# if defined(OPENSSL_NO_IDEA) && !defined(NO_IDEA)
|
|
||||||
+# define NO_IDEA
|
|
||||||
+# endif
|
|
||||||
+# if defined(OPENSSL_NO_MDC2) && !defined(NO_MDC2)
|
|
||||||
+# define NO_MDC2
|
|
||||||
+# endif
|
|
||||||
+# if defined(OPENSSL_NO_RC5) && !defined(NO_RC5)
|
|
||||||
+# define NO_RC5
|
|
||||||
+# endif
|
|
||||||
# if defined(OPENSSL_NO_KRB5) && !defined(NO_KRB5)
|
|
||||||
# define NO_KRB5
|
|
||||||
# endif
|
|
||||||
@@ -27,7 +48,7 @@
|
|
||||||
|
|
||||||
#if !(defined(VMS) || defined(__VMS)) /* VMS uses logical names instead */
|
|
||||||
#if defined(HEADER_CRYPTLIB_H) && !defined(OPENSSLDIR)
|
|
||||||
-#define OPENSSLDIR "/usr/local/ssl"
|
|
||||||
+#define OPENSSLDIR "/usr/lib/ssl"
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
@@ -79,7 +100,7 @@
|
|
||||||
|
|
||||||
#if defined(HEADER_BN_H) && !defined(CONFIG_HEADER_BN_H)
|
|
||||||
#define CONFIG_HEADER_BN_H
|
|
||||||
-#undef BN_LLONG
|
|
||||||
+#defne BN_LLONG
|
|
||||||
|
|
||||||
/* Should we define BN_DIV2W here? */
|
|
||||||
|
|
||||||
@@ -98,7 +119,7 @@
|
|
||||||
#define CONFIG_HEADER_RC4_LOCL_H
|
|
||||||
/* if this is defined data[i] is used instead of *data, this is a %20
|
|
||||||
* speedup on x86 */
|
|
||||||
-#undef RC4_INDEX
|
|
||||||
+#define RC4_INDEX
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(HEADER_BF_LOCL_H) && !defined(CONFIG_HEADER_BF_LOCL_H)
|
|
||||||
@@ -112,14 +133,14 @@
|
|
||||||
/* the following is tweaked from a config script, that is why it is a
|
|
||||||
* protected undef/define */
|
|
||||||
#ifndef DES_PTR
|
|
||||||
-#undef DES_PTR
|
|
||||||
+#define DES_PTR
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* This helps C compiler generate the correct code for multiple functional
|
|
||||||
* units. It reduces register dependancies at the expense of 2 more
|
|
||||||
* registers */
|
|
||||||
#ifndef DES_RISC1
|
|
||||||
-#undef DES_RISC1
|
|
||||||
+#define DES_RISC1
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifndef DES_RISC2
|
|
||||||
@@ -133,7 +154,7 @@
|
|
||||||
/* Unroll the inner loop, this sometimes helps, sometimes hinders.
|
|
||||||
* Very mucy CPU dependant */
|
|
||||||
#ifndef DES_UNROLL
|
|
||||||
-#undef DES_UNROLL
|
|
||||||
+#define DES_UNROLL
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* These default values were supplied by
|
|
||||||
diff -Nur openssl-0.9.7f/ssl/ssl_algs.c openssl-0.9.7f.new/ssl/ssl_algs.c
|
|
||||||
--- openssl-0.9.7f/ssl/ssl_algs.c 2001-02-20 09:11:58.000000000 +0100
|
|
||||||
+++ openssl-0.9.7f.new/ssl/ssl_algs.c 2005-04-03 20:40:27.000000000 +0200
|
|
||||||
@@ -109,3 +109,9 @@
|
|
||||||
return(1);
|
|
||||||
}
|
|
||||||
|
|
||||||
+#undef SSLeay_add_ssl_algorithms
|
|
||||||
+int SSLeay_add_ssl_algorithms(void)
|
|
||||||
+ {
|
|
||||||
+ return SSL_library_init();
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
diff -Nur openssl-0.9.7f/tools/c_rehash.in openssl-0.9.7f.new/tools/c_rehash.in
|
|
||||||
--- openssl-0.9.7f/tools/c_rehash.in 2002-10-11 22:35:45.000000000 +0200
|
|
||||||
+++ openssl-0.9.7f.new/tools/c_rehash.in 2005-04-03 20:41:17.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
|
|
||||||
|
|
||||||
# Perl c_rehash script, scan all files in a directory
|
|
||||||
diff -Nur openssl-0.9.7f/util/clean-depend.pl openssl-0.9.7f.new/util/clean-depend.pl
|
|
||||||
--- openssl-0.9.7f/util/clean-depend.pl 2001-10-10 10:27:28.000000000 +0200
|
|
||||||
+++ openssl-0.9.7f.new/util/clean-depend.pl 2005-04-03 20:41:38.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl -w
|
|
||||||
+#!/usr/bin/perl -w
|
|
||||||
# Clean the dependency list in a makefile of standard includes...
|
|
||||||
# Written by Ben Laurie <ben@algroup.co.uk> 19 Jan 1999
|
|
||||||
|
|
||||||
diff -Nur openssl-0.9.7f/util/mkdef.pl openssl-0.9.7f.new/util/mkdef.pl
|
|
||||||
--- openssl-0.9.7f/util/mkdef.pl 2005-02-05 18:19:23.000000000 +0100
|
|
||||||
+++ openssl-0.9.7f.new/util/mkdef.pl 2005-04-03 20:42:49.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl -w
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
#
|
|
||||||
# generate a .def file
|
|
||||||
#
|
|
||||||
diff -Nur openssl-0.9.7f/util/mkerr.pl openssl-0.9.7f.new/util/mkerr.pl
|
|
||||||
--- openssl-0.9.7f/util/mkerr.pl 2005-01-31 02:28:17.000000000 +0100
|
|
||||||
+++ openssl-0.9.7f.new/util/mkerr.pl 2005-04-03 20:43:02.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl -w
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
|
|
||||||
my $config = "crypto/err/openssl.ec";
|
|
||||||
my $debug = 0;
|
|
||||||
diff -Nur openssl-0.9.7f/util/mkstack.pl openssl-0.9.7f.new/util/mkstack.pl
|
|
||||||
--- openssl-0.9.7f/util/mkstack.pl 2004-10-04 18:27:36.000000000 +0200
|
|
||||||
+++ openssl-0.9.7f.new/util/mkstack.pl 2005-04-03 20:43:18.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl -w
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
|
|
||||||
# This is a utility that searches out "DECLARE_STACK_OF()"
|
|
||||||
# declarations in .h and .c files, and updates/creates/replaces
|
|
||||||
diff -Nur openssl-0.9.7f/util/pod2man.pl openssl-0.9.7f.new/util/pod2man.pl
|
|
||||||
--- openssl-0.9.7f/util/pod2man.pl 2002-05-30 17:30:21.000000000 +0200
|
|
||||||
+++ openssl-0.9.7f.new/util/pod2man.pl 2005-04-03 20:43:52.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-: #!/usr/bin/perl-5.005
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
|
|
||||||
if $running_under_some_shell;
|
|
||||||
|
|
||||||
diff -Nur openssl-0.9.7f/util/selftest.pl openssl-0.9.7f.new/util/selftest.pl
|
|
||||||
--- openssl-0.9.7f/util/selftest.pl 2004-05-11 14:46:19.000000000 +0200
|
|
||||||
+++ openssl-0.9.7f.new/util/selftest.pl 2005-04-03 20:44:10.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/usr/local/bin/perl -w
|
|
||||||
+#!/usr/bin/perl
|
|
||||||
#
|
|
||||||
# Run the test suite and generate a report
|
|
||||||
#
|
|
Loading…
Reference in New Issue
Block a user