1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2025-04-04 22:57:30 +03:00

Fixup PCI compilation

git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4697 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-29 09:04:56 +00:00
parent 05f06c4c28
commit 0280901b29

View File

@ -8032,10 +8032,10 @@ diff -urN linux.old/arch/mips/mm/tlbex.c linux.dev/arch/mips/mm/tlbex.c
tlbw(p); tlbw(p);
break; break;
diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup-bcm96348.c diff -urN linux-2.6.17/arch/mips/pci/fixup-bcm96348.c linux-2.6.17-brcm63xx/arch/mips/pci/fixup-bcm96348.c
--- linux.old/arch/mips/pci/fixup-bcm96348.c 1970-01-01 01:00:00.000000000 +0100 --- linux-2.6.17/arch/mips/pci/fixup-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
+++ linux.dev/arch/mips/pci/fixup-bcm96348.c 2006-08-25 00:39:38.000000000 +0200 +++ linux-2.6.17-brcm63xx/arch/mips/pci/fixup-bcm96348.c 2006-08-29 10:25:22.000000000 +0200
@@ -0,0 +1,85 @@ @@ -0,0 +1,93 @@
+/* +/*
+<:copyright-gpl +<:copyright-gpl
+ Copyright 2002 Broadcom Corp. All Rights Reserved. + Copyright 2002 Broadcom Corp. All Rights Reserved.
@ -8117,10 +8117,18 @@ diff -urN linux.old/arch/mips/pci/fixup-bcm96348.c linux.dev/arch/mips/pci/fixup
+ } + }
+} +}
+ +
+struct pci_fixup pcibios_fixups[] = { +int pcibios_plat_dev_init(struct pci_dev *dev)
+{
+ return 0;
+}
+
+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_BROADCOM, PCI_ANY_ID,
+ bcm96348_fixup);
+
+/*struct pci_fixup pcibios_fixups[] = {
+ { PCI_FIXUP_FINAL, PCI_ANY_ID, PCI_ANY_ID, bcm96348_fixup }, + { PCI_FIXUP_FINAL, PCI_ANY_ID, PCI_ANY_ID, bcm96348_fixup },
+ {0} + {0}
+}; +};*/
diff -urN linux.old/arch/mips/pci/Makefile linux.dev/arch/mips/pci/Makefile diff -urN linux.old/arch/mips/pci/Makefile linux.dev/arch/mips/pci/Makefile
--- linux.old/arch/mips/pci/Makefile 2006-08-25 00:43:29.000000000 +0200 --- linux.old/arch/mips/pci/Makefile 2006-08-25 00:43:29.000000000 +0200
+++ linux.dev/arch/mips/pci/Makefile 2006-08-25 00:39:38.000000000 +0200 +++ linux.dev/arch/mips/pci/Makefile 2006-08-25 00:39:38.000000000 +0200
@ -8412,9 +8420,9 @@ diff -urN linux.old/arch/mips/pci/ops-bcm96348.c linux.dev/arch/mips/pci/ops-bcm
+ .read = bcm96348_pcibios_read, + .read = bcm96348_pcibios_read,
+ .write = bcm96348_pcibios_write + .write = bcm96348_pcibios_write
+}; +};
diff -urN linux.old/arch/mips/pci/pci-bcm96348.c linux.dev/arch/mips/pci/pci-bcm96348.c diff -urN linux-2.6.17/arch/mips/pci/pci-bcm96348.c linux-2.6.17-brcm63xx/arch/mips/pci/pci-bcm96348.c
--- linux.old/arch/mips/pci/pci-bcm96348.c 1970-01-01 01:00:00.000000000 +0100 --- linux-2.6.17/arch/mips/pci/pci-bcm96348.c 1970-01-01 01:00:00.000000000 +0100
+++ linux.dev/arch/mips/pci/pci-bcm96348.c 2006-08-25 00:39:38.000000000 +0200 +++ linux-2.6.17-brcm63xx/arch/mips/pci/pci-bcm96348.c 2006-08-29 10:25:13.000000000 +0200
@@ -0,0 +1,54 @@ @@ -0,0 +1,54 @@
+/* +/*
+<:copyright-gpl +<:copyright-gpl
@ -8439,7 +8447,7 @@ diff -urN linux.old/arch/mips/pci/pci-bcm96348.c linux.dev/arch/mips/pci/pci-bcm
+#include <linux/kernel.h> +#include <linux/kernel.h>
+#include <linux/init.h> +#include <linux/init.h>
+ +
+#include <asm/pci_channel.h> +//#include <asm/pci_channel.h>
+#include <bcmpci.h> +#include <bcmpci.h>
+ +
+static struct resource bcm_pci_io_resource = { +static struct resource bcm_pci_io_resource = {