1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 07:08:03 +03:00

[atheros] refresh kernel patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11197 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2008-05-19 07:16:54 +00:00
parent 2b43286d28
commit 02e216b7f2
21 changed files with 176 additions and 164 deletions

View File

@ -1,7 +1,8 @@
diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig Index: linux-2.6.23.17/arch/mips/Kconfig
--- linux.old/arch/mips/Kconfig 2007-02-02 23:55:52.912446784 +0100 ===================================================================
+++ linux.dev/arch/mips/Kconfig 2007-02-03 21:50:25.262027104 +0100 --- linux-2.6.23.17.orig/arch/mips/Kconfig
@@ -44,6 +44,16 @@ +++ linux-2.6.23.17/arch/mips/Kconfig
@@ -44,6 +44,16 @@ config BASLER_EXCITE_PROTOTYPE
note that a kernel built with this option selected will not be note that a kernel built with this option selected will not be
able to run on normal units. able to run on normal units.
@ -18,7 +19,7 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
config MIPS_COBALT config MIPS_COBALT
bool "Cobalt Server" bool "Cobalt Server"
select DMA_NONCOHERENT select DMA_NONCOHERENT
@@ -597,6 +607,7 @@ @@ -597,6 +607,7 @@ config WR_PPMC
endchoice endchoice
@ -26,10 +27,11 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
source "arch/mips/jazz/Kconfig" source "arch/mips/jazz/Kconfig"
source "arch/mips/pmc-sierra/Kconfig" source "arch/mips/pmc-sierra/Kconfig"
diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile Index: linux-2.6.23.17/arch/mips/Makefile
--- linux.old/arch/mips/Makefile 2007-02-02 23:55:52.913446632 +0100 ===================================================================
+++ linux.dev/arch/mips/Makefile 2007-02-03 17:40:29.193776000 +0100 --- linux-2.6.23.17.orig/arch/mips/Makefile
@@ -267,6 +267,13 @@ +++ linux-2.6.23.17/arch/mips/Makefile
@@ -270,6 +270,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000 load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
# #
@ -43,12 +45,13 @@ diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
# Cobalt Server # Cobalt Server
# #
core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/ core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h Index: linux-2.6.23.17/include/asm-mips/bootinfo.h
--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100 ===================================================================
+++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100 --- linux-2.6.23.17.orig/include/asm-mips/bootinfo.h
@@ -213,6 +213,18 @@ +++ linux-2.6.23.17/include/asm-mips/bootinfo.h
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */ @@ -208,6 +208,18 @@
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */ #define MACH_GROUP_WINDRIVER 28 /* Windriver boards */
#define MACH_WRPPMC 1
+/* +/*
+ * Valid machtype for group ATHEROS + * Valid machtype for group ATHEROS
@ -65,4 +68,3 @@ diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/booti
#define CL_SIZE COMMAND_LINE_SIZE #define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void); const char *get_system_type(void);

View File

@ -1,7 +1,8 @@
diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig Index: linux-2.6.23.17/drivers/mtd/devices/Kconfig
--- linux.old/drivers/mtd/devices/Kconfig 2007-02-04 04:30:26.145338240 +0100 ===================================================================
+++ linux.dev/drivers/mtd/devices/Kconfig 2007-02-02 23:48:28.748969000 +0100 --- linux-2.6.23.17.orig/drivers/mtd/devices/Kconfig
@@ -76,6 +76,10 @@ +++ linux-2.6.23.17/drivers/mtd/devices/Kconfig
@@ -76,6 +76,10 @@ config MTD_M25P80
used for program and data storage. Set up your spi devices used for program and data storage. Set up your spi devices
with the right board-specific platform data. with the right board-specific platform data.
@ -12,10 +13,11 @@ diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kc
config MTD_SLRAM config MTD_SLRAM
tristate "Uncached system RAM" tristate "Uncached system RAM"
help help
diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile Index: linux-2.6.23.17/drivers/mtd/devices/Makefile
--- linux.old/drivers/mtd/devices/Makefile 2007-02-04 04:30:26.146338088 +0100 ===================================================================
+++ linux.dev/drivers/mtd/devices/Makefile 2007-02-02 23:48:28.749969000 +0100 --- linux-2.6.23.17.orig/drivers/mtd/devices/Makefile
@@ -18,3 +18,4 @@ +++ linux-2.6.23.17/drivers/mtd/devices/Makefile
@@ -18,3 +18,4 @@ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o obj-$(CONFIG_MTD_M25P80) += m25p80.o

View File

@ -1,8 +1,8 @@
Index: linux-2.6.23/drivers/net/Kconfig Index: linux-2.6.23.17/drivers/net/Kconfig
=================================================================== ===================================================================
--- linux-2.6.23.orig/drivers/net/Kconfig 2007-10-14 00:55:22.000000000 +0200 --- linux-2.6.23.17.orig/drivers/net/Kconfig
+++ linux-2.6.23/drivers/net/Kconfig 2007-10-14 00:56:32.000000000 +0200 +++ linux-2.6.23.17/drivers/net/Kconfig
@@ -348,6 +348,12 @@ @@ -348,6 +348,12 @@ config AX88796
AX88796 driver, using platform bus to provide AX88796 driver, using platform bus to provide
chip detection and resources chip detection and resources
@ -15,11 +15,11 @@ Index: linux-2.6.23/drivers/net/Kconfig
config MACE config MACE
tristate "MACE (Power Mac ethernet) support" tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32 depends on PPC_PMAC && PPC32
Index: linux-2.6.23/drivers/net/Makefile Index: linux-2.6.23.17/drivers/net/Makefile
=================================================================== ===================================================================
--- linux-2.6.23.orig/drivers/net/Makefile 2007-10-14 00:55:22.000000000 +0200 --- linux-2.6.23.17.orig/drivers/net/Makefile
+++ linux-2.6.23/drivers/net/Makefile 2007-10-14 00:56:55.000000000 +0200 +++ linux-2.6.23.17/drivers/net/Makefile
@@ -182,6 +182,7 @@ @@ -182,6 +182,7 @@ obj-$(CONFIG_EQUALIZER) += eql.o
obj-$(CONFIG_LGUEST_NET) += lguest_net.o obj-$(CONFIG_LGUEST_NET) += lguest_net.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o

View File

@ -1,7 +1,8 @@
diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c Index: linux-2.6.23.17/drivers/mtd/redboot.c
--- linux.old/drivers/mtd/redboot.c 2006-12-14 23:53:29.000000000 +0100 ===================================================================
+++ linux.dev/drivers/mtd/redboot.c 2006-12-16 04:23:42.000000000 +0100 --- linux-2.6.23.17.orig/drivers/mtd/redboot.c
@@ -64,6 +64,7 @@ +++ linux-2.6.23.17/drivers/mtd/redboot.c
@@ -64,6 +64,7 @@ static int parse_redboot_partitions(stru
if (!buf) if (!buf)
return -ENOMEM; return -ENOMEM;
@ -9,7 +10,7 @@ diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c
if ( directory < 0 ) if ( directory < 0 )
offset = master->size + directory*master->erasesize; offset = master->size + directory*master->erasesize;
else else
@@ -140,6 +141,11 @@ @@ -140,6 +141,11 @@ static int parse_redboot_partitions(stru
} }
if (i == numslots) { if (i == numslots) {
/* Didn't find it */ /* Didn't find it */
@ -21,4 +22,3 @@ diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c
printk(KERN_NOTICE "No RedBoot partition table detected in %s\n", printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
master->name); master->name);
ret = 0; ret = 0;

View File

@ -1,6 +1,8 @@
--- linux-2.6.23.orig/net/core/dev.c 2007-10-12 23:42:06.000000000 +0200 Index: linux-2.6.23.17/net/core/dev.c
+++ linux-2.6.23/net/core/dev.c 2007-10-12 23:44:22.000000000 +0200 ===================================================================
@@ -3425,8 +3425,8 @@ --- linux-2.6.23.17.orig/net/core/dev.c
+++ linux-2.6.23.17/net/core/dev.c
@@ -3426,8 +3426,8 @@ int register_netdevice(struct net_device
/* Fix illegal SG+CSUM combinations. */ /* Fix illegal SG+CSUM combinations. */
if ((dev->features & NETIF_F_SG) && if ((dev->features & NETIF_F_SG) &&
!(dev->features & NETIF_F_ALL_CSUM)) { !(dev->features & NETIF_F_ALL_CSUM)) {
@ -11,7 +13,7 @@
dev->features &= ~NETIF_F_SG; dev->features &= ~NETIF_F_SG;
} }
@@ -3439,9 +3439,9 @@ @@ -3440,9 +3440,9 @@ int register_netdevice(struct net_device
} }
if (dev->features & NETIF_F_UFO) { if (dev->features & NETIF_F_UFO) {
if (!(dev->features & NETIF_F_HW_CSUM)) { if (!(dev->features & NETIF_F_HW_CSUM)) {

View File

@ -1,8 +1,8 @@
Index: linux-2.6.23.16/drivers/net/ar2313/ar2313.c Index: linux-2.6.23.17/drivers/net/ar2313/ar2313.c
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/drivers/net/ar2313/ar2313.c 2008-04-29 14:51:39.000000000 +0200 --- linux-2.6.23.17.orig/drivers/net/ar2313/ar2313.c
+++ linux-2.6.23.16/drivers/net/ar2313/ar2313.c 2008-04-29 14:52:14.000000000 +0200 +++ linux-2.6.23.17/drivers/net/ar2313/ar2313.c
@@ -953,9 +953,9 @@ @@ -953,9 +953,9 @@ static int ar2313_rx_int(struct net_devi
((status >> DMA_RX_LEN_SHIFT) & 0x3fff) - CRC_LEN); ((status >> DMA_RX_LEN_SHIFT) & 0x3fff) - CRC_LEN);
dev->stats.rx_bytes += skb->len; dev->stats.rx_bytes += skb->len;
@ -14,7 +14,7 @@ Index: linux-2.6.23.16/drivers/net/ar2313/ar2313.c
skb_new->dev = dev; skb_new->dev = dev;
/* 16 bit align */ /* 16 bit align */
@@ -1370,6 +1370,8 @@ @@ -1370,6 +1370,8 @@ static int mdiobus_probe (struct net_dev
return PTR_ERR(phydev); return PTR_ERR(phydev);
} }
@ -23,11 +23,11 @@ Index: linux-2.6.23.16/drivers/net/ar2313/ar2313.c
/* mask with MAC supported features */ /* mask with MAC supported features */
phydev->supported &= (SUPPORTED_10baseT_Half phydev->supported &= (SUPPORTED_10baseT_Half
| SUPPORTED_10baseT_Full | SUPPORTED_10baseT_Full
Index: linux-2.6.23.16/drivers/net/ar2313/ar2313.h Index: linux-2.6.23.17/drivers/net/ar2313/ar2313.h
=================================================================== ===================================================================
--- linux-2.6.23.16.orig/drivers/net/ar2313/ar2313.h 2008-04-29 14:51:39.000000000 +0200 --- linux-2.6.23.17.orig/drivers/net/ar2313/ar2313.h
+++ linux-2.6.23.16/drivers/net/ar2313/ar2313.h 2008-04-29 14:52:15.000000000 +0200 +++ linux-2.6.23.17/drivers/net/ar2313/ar2313.h
@@ -107,6 +107,8 @@ @@ -107,6 +107,8 @@ typedef struct {
*/ */
struct ar2313_private { struct ar2313_private {
struct net_device *dev; struct net_device *dev;

View File

@ -1,9 +1,10 @@
diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig Index: linux-2.6.24.7/arch/mips/Kconfig
--- linux.old/arch/mips/Kconfig 2007-02-02 23:55:52.912446784 +0100 ===================================================================
+++ linux.dev/arch/mips/Kconfig 2007-02-03 21:50:25.262027104 +0100 --- linux-2.6.24.7.orig/arch/mips/Kconfig
@@ -45,6 +45,18 @@ +++ linux-2.6.24.7/arch/mips/Kconfig
note that a kernel built with this option selected will not be @@ -67,6 +67,18 @@ config BCM47XX
able to run on normal units. help
Support for BCM47XX based boards
+config ATHEROS +config ATHEROS
+ bool "Atheros SoC support (EXPERIMENTAL)" + bool "Atheros SoC support (EXPERIMENTAL)"
@ -19,19 +20,20 @@ diff -urN linux.old/arch/mips/Kconfig linux.dev/arch/mips/Kconfig
+ +
config MIPS_COBALT config MIPS_COBALT
bool "Cobalt Server" bool "Cobalt Server"
select DMA_NONCOHERENT select CEVT_R4K
@@ -658,6 +668,7 @@ @@ -689,6 +701,7 @@ config WR_PPMC
endchoice endchoice
+source "arch/mips/atheros/Kconfig" +source "arch/mips/atheros/Kconfig"
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
source "arch/mips/ddb5xxx/Kconfig" source "arch/mips/jazz/Kconfig"
source "arch/mips/gt64120/ev64120/Kconfig" source "arch/mips/lasat/Kconfig"
diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile Index: linux-2.6.24.7/arch/mips/Makefile
--- linux.old/arch/mips/Makefile 2007-02-02 23:55:52.913446632 +0100 ===================================================================
+++ linux.dev/arch/mips/Makefile 2007-02-03 17:40:29.193776000 +0100 --- linux-2.6.24.7.orig/arch/mips/Makefile
@@ -267,6 +267,13 @@ +++ linux-2.6.24.7/arch/mips/Makefile
@@ -268,6 +268,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000 load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
# #
@ -45,12 +47,13 @@ diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
# Cobalt Server # Cobalt Server
# #
core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/ core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/bootinfo.h Index: linux-2.6.24.7/include/asm-mips/bootinfo.h
--- linux.old/include/asm-mips/bootinfo.h 2007-02-02 23:55:52.913446632 +0100 ===================================================================
+++ linux.dev/include/asm-mips/bootinfo.h 2007-02-03 17:51:02.531494032 +0100 --- linux-2.6.24.7.orig/include/asm-mips/bootinfo.h
@@ -213,6 +213,18 @@ +++ linux-2.6.24.7/include/asm-mips/bootinfo.h
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */ @@ -198,6 +198,18 @@
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */ #define MACH_GROUP_BRCM 23 /* Broadcom */
#define MACH_BCM47XX 1 /* Broadcom BCM47XX */
+/* +/*
+ * Valid machtype for group ATHEROS + * Valid machtype for group ATHEROS
@ -67,4 +70,3 @@ diff -urN linux.old/include/asm-mips/bootinfo.h linux.dev/include/asm-mips/booti
#define CL_SIZE COMMAND_LINE_SIZE #define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void); const char *get_system_type(void);

View File

@ -1,9 +1,10 @@
diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kconfig Index: linux-2.6.24.7/drivers/mtd/devices/Kconfig
--- linux.old/drivers/mtd/devices/Kconfig 2007-02-04 04:30:26.145338240 +0100 ===================================================================
+++ linux.dev/drivers/mtd/devices/Kconfig 2007-02-02 23:48:28.748969000 +0100 --- linux-2.6.24.7.orig/drivers/mtd/devices/Kconfig
@@ -76,6 +76,10 @@ +++ linux-2.6.24.7/drivers/mtd/devices/Kconfig
used for program and data storage. Set up your spi devices @@ -77,6 +77,10 @@ config MTD_M25P80
with the right board-specific platform data. if you want to specify device partitioning or to use a device which
doesn't support the JEDEC ID instruction.
+config MTD_SPIFLASH +config MTD_SPIFLASH
+ tristate "Atheros AR2315/6/7 SPI Flash support" + tristate "Atheros AR2315/6/7 SPI Flash support"
@ -12,11 +13,12 @@ diff -urN linux.old/drivers/mtd/devices/Kconfig linux.dev/drivers/mtd/devices/Kc
config MTD_SLRAM config MTD_SLRAM
tristate "Uncached system RAM" tristate "Uncached system RAM"
help help
diff -urN linux.old/drivers/mtd/devices/Makefile linux.dev/drivers/mtd/devices/Makefile Index: linux-2.6.24.7/drivers/mtd/devices/Makefile
--- linux.old/drivers/mtd/devices/Makefile 2007-02-04 04:30:26.146338088 +0100 ===================================================================
+++ linux.dev/drivers/mtd/devices/Makefile 2007-02-02 23:48:28.749969000 +0100 --- linux-2.6.24.7.orig/drivers/mtd/devices/Makefile
@@ -18,3 +18,4 @@ +++ linux-2.6.24.7/drivers/mtd/devices/Makefile
@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o obj-$(CONFIG_MTD_M25P80) += m25p80.o
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o +obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o

View File

@ -1,10 +1,10 @@
Index: linux-2.6.23/drivers/net/Kconfig Index: linux-2.6.24.7/drivers/net/Kconfig
=================================================================== ===================================================================
--- linux-2.6.23.orig/drivers/net/Kconfig 2007-10-14 00:55:22.000000000 +0200 --- linux-2.6.24.7.orig/drivers/net/Kconfig
+++ linux-2.6.23/drivers/net/Kconfig 2007-10-14 00:56:32.000000000 +0200 +++ linux-2.6.24.7/drivers/net/Kconfig
@@ -348,6 +348,12 @@ @@ -362,6 +362,12 @@ config AX88796_93CX6
AX88796 driver, using platform bus to provide help
chip detection and resources Select this if your platform comes with an external 93CX6 eeprom.
+config AR2313 +config AR2313
+ tristate "AR2313 Ethernet support" + tristate "AR2313 Ethernet support"
@ -15,12 +15,12 @@ Index: linux-2.6.23/drivers/net/Kconfig
config MACE config MACE
tristate "MACE (Power Mac ethernet) support" tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32 depends on PPC_PMAC && PPC32
Index: linux-2.6.23/drivers/net/Makefile Index: linux-2.6.24.7/drivers/net/Makefile
=================================================================== ===================================================================
--- linux-2.6.23.orig/drivers/net/Makefile 2007-10-14 00:55:22.000000000 +0200 --- linux-2.6.24.7.orig/drivers/net/Makefile
+++ linux-2.6.23/drivers/net/Makefile 2007-10-14 00:56:55.000000000 +0200 +++ linux-2.6.24.7/drivers/net/Makefile
@@ -182,6 +182,7 @@ @@ -190,6 +190,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7
obj-$(CONFIG_LGUEST_NET) += lguest_net.o obj-$(CONFIG_EQUALIZER) += eql.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+obj-$(CONFIG_AR2313) += ar2313/ +obj-$(CONFIG_AR2313) += ar2313/

View File

@ -1,7 +1,8 @@
diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c Index: linux-2.6.24.7/drivers/mtd/redboot.c
--- linux.old/drivers/mtd/redboot.c 2006-12-14 23:53:29.000000000 +0100 ===================================================================
+++ linux.dev/drivers/mtd/redboot.c 2006-12-16 04:23:42.000000000 +0100 --- linux-2.6.24.7.orig/drivers/mtd/redboot.c
@@ -64,6 +64,7 @@ +++ linux-2.6.24.7/drivers/mtd/redboot.c
@@ -64,6 +64,7 @@ static int parse_redboot_partitions(stru
if (!buf) if (!buf)
return -ENOMEM; return -ENOMEM;
@ -9,7 +10,7 @@ diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c
if ( directory < 0 ) if ( directory < 0 )
offset = master->size + directory*master->erasesize; offset = master->size + directory*master->erasesize;
else else
@@ -140,6 +141,11 @@ @@ -140,6 +141,11 @@ static int parse_redboot_partitions(stru
} }
if (i == numslots) { if (i == numslots) {
/* Didn't find it */ /* Didn't find it */
@ -21,4 +22,3 @@ diff -urN linux.old/drivers/mtd/redboot.c linux.dev/drivers/mtd/redboot.c
printk(KERN_NOTICE "No RedBoot partition table detected in %s\n", printk(KERN_NOTICE "No RedBoot partition table detected in %s\n",
master->name); master->name);
ret = 0; ret = 0;

View File

@ -1,6 +1,8 @@
--- linux-2.6.23.orig/net/core/dev.c 2007-10-12 23:42:06.000000000 +0200 Index: linux-2.6.24.7/net/core/dev.c
+++ linux-2.6.23/net/core/dev.c 2007-10-12 23:44:22.000000000 +0200 ===================================================================
@@ -3425,8 +3425,8 @@ --- linux-2.6.24.7.orig/net/core/dev.c
+++ linux-2.6.24.7/net/core/dev.c
@@ -3666,8 +3666,8 @@ int register_netdevice(struct net_device
/* Fix illegal SG+CSUM combinations. */ /* Fix illegal SG+CSUM combinations. */
if ((dev->features & NETIF_F_SG) && if ((dev->features & NETIF_F_SG) &&
!(dev->features & NETIF_F_ALL_CSUM)) { !(dev->features & NETIF_F_ALL_CSUM)) {
@ -11,7 +13,7 @@
dev->features &= ~NETIF_F_SG; dev->features &= ~NETIF_F_SG;
} }
@@ -3439,9 +3439,9 @@ @@ -3680,9 +3680,9 @@ int register_netdevice(struct net_device
} }
if (dev->features & NETIF_F_UFO) { if (dev->features & NETIF_F_UFO) {
if (!(dev->features & NETIF_F_HW_CSUM)) { if (!(dev->features & NETIF_F_HW_CSUM)) {

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24.2/arch/mips/kernel/cevt-r4k.c Index: linux-2.6.24.7/arch/mips/kernel/cevt-r4k.c
=================================================================== ===================================================================
--- linux-2.6.24.2.orig/arch/mips/kernel/cevt-r4k.c --- linux-2.6.24.7.orig/arch/mips/kernel/cevt-r4k.c
+++ linux-2.6.24.2/arch/mips/kernel/cevt-r4k.c +++ linux-2.6.24.7/arch/mips/kernel/cevt-r4k.c
@@ -205,6 +205,7 @@ static int c0_compare_int_usable(void) @@ -205,6 +205,7 @@ static int c0_compare_int_usable(void)
while ((int)(read_c0_count() - cnt) <= 0) while ((int)(read_c0_count() - cnt) <= 0)
; /* Wait for expiry */ ; /* Wait for expiry */

View File

@ -1,7 +1,7 @@
Index: linux-2.6.24.2/arch/mips/kernel/traps.c Index: linux-2.6.24.7/arch/mips/kernel/traps.c
=================================================================== ===================================================================
--- linux-2.6.24.2.orig/arch/mips/kernel/traps.c --- linux-2.6.24.7.orig/arch/mips/kernel/traps.c
+++ linux-2.6.24.2/arch/mips/kernel/traps.c +++ linux-2.6.24.7/arch/mips/kernel/traps.c
@@ -42,6 +42,7 @@ @@ -42,6 +42,7 @@
#include <asm/mmu_context.h> #include <asm/mmu_context.h>
#include <asm/types.h> #include <asm/types.h>
@ -19,10 +19,10 @@ Index: linux-2.6.24.2/arch/mips/kernel/traps.c
cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7; cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
if (cp0_perfcount_irq == cp0_compare_irq) if (cp0_perfcount_irq == cp0_compare_irq)
cp0_perfcount_irq = -1; cp0_perfcount_irq = -1;
Index: linux-2.6.24.2/include/asm-mips/time.h Index: linux-2.6.24.7/include/asm-mips/time.h
=================================================================== ===================================================================
--- linux-2.6.24.2.orig/include/asm-mips/time.h --- linux-2.6.24.7.orig/include/asm-mips/time.h
+++ linux-2.6.24.2/include/asm-mips/time.h +++ linux-2.6.24.7/include/asm-mips/time.h
@@ -60,6 +60,7 @@ extern int (*perf_irq)(void); @@ -60,6 +60,7 @@ extern int (*perf_irq)(void);
#ifdef CONFIG_CEVT_R4K #ifdef CONFIG_CEVT_R4K
extern int mips_clockevent_init(void); extern int mips_clockevent_init(void);
@ -31,10 +31,10 @@ Index: linux-2.6.24.2/include/asm-mips/time.h
#else #else
static inline int mips_clockevent_init(void) static inline int mips_clockevent_init(void)
{ {
Index: linux-2.6.24.2/arch/mips/atheros/board.c Index: linux-2.6.24.7/arch/mips/atheros/board.c
=================================================================== ===================================================================
--- linux-2.6.24.2.orig/arch/mips/atheros/board.c --- linux-2.6.24.7.orig/arch/mips/atheros/board.c
+++ linux-2.6.24.2/arch/mips/atheros/board.c +++ linux-2.6.24.7/arch/mips/atheros/board.c
@@ -205,6 +205,11 @@ void (*board_time_init)(void); @@ -205,6 +205,11 @@ void (*board_time_init)(void);
void __init plat_time_init(void) { void __init plat_time_init(void) {
board_time_init(); board_time_init();

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/arch/mips/Kconfig Index: linux-2.6.25.4/arch/mips/Kconfig
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/arch/mips/Kconfig --- linux-2.6.25.4.orig/arch/mips/Kconfig
+++ linux-2.6.25.1/arch/mips/Kconfig +++ linux-2.6.25.4/arch/mips/Kconfig
@@ -59,6 +59,18 @@ config BCM47XX @@ -59,6 +59,18 @@ config BCM47XX
help help
Support for BCM47XX based boards Support for BCM47XX based boards
@ -29,10 +29,10 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
source "arch/mips/au1000/Kconfig" source "arch/mips/au1000/Kconfig"
source "arch/mips/basler/excite/Kconfig" source "arch/mips/basler/excite/Kconfig"
source "arch/mips/jazz/Kconfig" source "arch/mips/jazz/Kconfig"
Index: linux-2.6.25.1/arch/mips/Makefile Index: linux-2.6.25.4/arch/mips/Makefile
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/arch/mips/Makefile --- linux-2.6.25.4.orig/arch/mips/Makefile
+++ linux-2.6.25.1/arch/mips/Makefile +++ linux-2.6.25.4/arch/mips/Makefile
@@ -276,6 +276,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips @@ -276,6 +276,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000 load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
@ -47,10 +47,10 @@ Index: linux-2.6.25.1/arch/mips/Makefile
# Cobalt Server # Cobalt Server
# #
core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/ core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
Index: linux-2.6.25.1/include/asm-mips/bootinfo.h Index: linux-2.6.25.4/include/asm-mips/bootinfo.h
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h --- linux-2.6.25.4.orig/include/asm-mips/bootinfo.h
+++ linux-2.6.25.1/include/asm-mips/bootinfo.h +++ linux-2.6.25.4/include/asm-mips/bootinfo.h
@@ -94,6 +94,18 @@ @@ -94,6 +94,18 @@
#define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */ #define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */
#define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */ #define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig Index: linux-2.6.25.4/drivers/mtd/devices/Kconfig
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/mtd/devices/Kconfig --- linux-2.6.25.4.orig/drivers/mtd/devices/Kconfig
+++ linux-2.6.25.1/drivers/mtd/devices/Kconfig +++ linux-2.6.25.4/drivers/mtd/devices/Kconfig
@@ -77,6 +77,10 @@ config MTD_M25P80 @@ -77,6 +77,10 @@ config MTD_M25P80
if you want to specify device partitioning or to use a device which if you want to specify device partitioning or to use a device which
doesn't support the JEDEC ID instruction. doesn't support the JEDEC ID instruction.
@ -13,10 +13,10 @@ Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig
config MTD_SLRAM config MTD_SLRAM
tristate "Uncached system RAM" tristate "Uncached system RAM"
help help
Index: linux-2.6.25.1/drivers/mtd/devices/Makefile Index: linux-2.6.25.4/drivers/mtd/devices/Makefile
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/mtd/devices/Makefile --- linux-2.6.25.4.orig/drivers/mtd/devices/Makefile
+++ linux-2.6.25.1/drivers/mtd/devices/Makefile +++ linux-2.6.25.4/drivers/mtd/devices/Makefile
@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o @@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/drivers/net/Kconfig Index: linux-2.6.25.4/drivers/net/Kconfig
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/net/Kconfig --- linux-2.6.25.4.orig/drivers/net/Kconfig
+++ linux-2.6.25.1/drivers/net/Kconfig +++ linux-2.6.25.4/drivers/net/Kconfig
@@ -367,6 +367,12 @@ config AX88796_93CX6 @@ -367,6 +367,12 @@ config AX88796_93CX6
help help
Select this if your platform comes with an external 93CX6 eeprom. Select this if your platform comes with an external 93CX6 eeprom.
@ -15,10 +15,10 @@ Index: linux-2.6.25.1/drivers/net/Kconfig
config MACE config MACE
tristate "MACE (Power Mac ethernet) support" tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32 depends on PPC_PMAC && PPC32
Index: linux-2.6.25.1/drivers/net/Makefile Index: linux-2.6.25.4/drivers/net/Makefile
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/net/Makefile --- linux-2.6.25.4.orig/drivers/net/Makefile
+++ linux-2.6.25.1/drivers/net/Makefile +++ linux-2.6.25.4/drivers/net/Makefile
@@ -194,6 +194,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7 @@ -194,6 +194,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7
obj-$(CONFIG_EQUALIZER) += eql.o obj-$(CONFIG_EQUALIZER) += eql.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/drivers/mtd/redboot.c Index: linux-2.6.25.4/drivers/mtd/redboot.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/mtd/redboot.c --- linux-2.6.25.4.orig/drivers/mtd/redboot.c
+++ linux-2.6.25.1/drivers/mtd/redboot.c +++ linux-2.6.25.4/drivers/mtd/redboot.c
@@ -59,31 +59,32 @@ static int parse_redboot_partitions(stru @@ -59,31 +59,32 @@ static int parse_redboot_partitions(stru
static char nullstring[] = "unallocated"; static char nullstring[] = "unallocated";
#endif #endif

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/net/core/dev.c Index: linux-2.6.25.4/net/core/dev.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/net/core/dev.c --- linux-2.6.25.4.orig/net/core/dev.c
+++ linux-2.6.25.1/net/core/dev.c +++ linux-2.6.25.4/net/core/dev.c
@@ -3755,8 +3755,8 @@ int register_netdevice(struct net_device @@ -3755,8 +3755,8 @@ int register_netdevice(struct net_device
/* Fix illegal SG+CSUM combinations. */ /* Fix illegal SG+CSUM combinations. */
if ((dev->features & NETIF_F_SG) && if ((dev->features & NETIF_F_SG) &&

View File

@ -1,8 +1,8 @@
Index: linux-2.6.25.1/drivers/net/ar2313/ar2313.c Index: linux-2.6.25.4/drivers/net/ar2313/ar2313.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/net/ar2313/ar2313.c 2008-05-13 00:49:39.000000000 +0200 --- linux-2.6.25.4.orig/drivers/net/ar2313/ar2313.c
+++ linux-2.6.25.1/drivers/net/ar2313/ar2313.c 2008-05-13 00:49:42.000000000 +0200 +++ linux-2.6.25.4/drivers/net/ar2313/ar2313.c
@@ -953,9 +953,9 @@ @@ -953,9 +953,9 @@ static int ar2313_rx_int(struct net_devi
((status >> DMA_RX_LEN_SHIFT) & 0x3fff) - CRC_LEN); ((status >> DMA_RX_LEN_SHIFT) & 0x3fff) - CRC_LEN);
dev->stats.rx_bytes += skb->len; dev->stats.rx_bytes += skb->len;
@ -14,7 +14,7 @@ Index: linux-2.6.25.1/drivers/net/ar2313/ar2313.c
skb_new->dev = dev; skb_new->dev = dev;
/* 16 bit align */ /* 16 bit align */
@@ -1370,6 +1370,8 @@ @@ -1370,6 +1370,8 @@ static int mdiobus_probe (struct net_dev
return PTR_ERR(phydev); return PTR_ERR(phydev);
} }
@ -23,11 +23,11 @@ Index: linux-2.6.25.1/drivers/net/ar2313/ar2313.c
/* mask with MAC supported features */ /* mask with MAC supported features */
phydev->supported &= (SUPPORTED_10baseT_Half phydev->supported &= (SUPPORTED_10baseT_Half
| SUPPORTED_10baseT_Full | SUPPORTED_10baseT_Full
Index: linux-2.6.25.1/drivers/net/ar2313/ar2313.h Index: linux-2.6.25.4/drivers/net/ar2313/ar2313.h
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/drivers/net/ar2313/ar2313.h 2008-05-13 00:49:39.000000000 +0200 --- linux-2.6.25.4.orig/drivers/net/ar2313/ar2313.h
+++ linux-2.6.25.1/drivers/net/ar2313/ar2313.h 2008-05-13 00:49:42.000000000 +0200 +++ linux-2.6.25.4/drivers/net/ar2313/ar2313.h
@@ -107,6 +107,8 @@ @@ -107,6 +107,8 @@ typedef struct {
*/ */
struct ar2313_private { struct ar2313_private {
struct net_device *dev; struct net_device *dev;

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/arch/mips/kernel/cevt-r4k.c Index: linux-2.6.25.4/arch/mips/kernel/cevt-r4k.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/arch/mips/kernel/cevt-r4k.c --- linux-2.6.25.4.orig/arch/mips/kernel/cevt-r4k.c
+++ linux-2.6.25.1/arch/mips/kernel/cevt-r4k.c +++ linux-2.6.25.4/arch/mips/kernel/cevt-r4k.c
@@ -205,6 +205,7 @@ static int c0_compare_int_usable(void) @@ -205,6 +205,7 @@ static int c0_compare_int_usable(void)
while ((int)(read_c0_count() - cnt) <= 0) while ((int)(read_c0_count() - cnt) <= 0)
; /* Wait for expiry */ ; /* Wait for expiry */

View File

@ -1,7 +1,7 @@
Index: linux-2.6.25.1/arch/mips/kernel/traps.c Index: linux-2.6.25.4/arch/mips/kernel/traps.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/arch/mips/kernel/traps.c --- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
+++ linux-2.6.25.1/arch/mips/kernel/traps.c +++ linux-2.6.25.4/arch/mips/kernel/traps.c
@@ -42,6 +42,7 @@ @@ -42,6 +42,7 @@
#include <asm/mmu_context.h> #include <asm/mmu_context.h>
#include <asm/types.h> #include <asm/types.h>
@ -19,10 +19,10 @@ Index: linux-2.6.25.1/arch/mips/kernel/traps.c
cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7; cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
if (cp0_perfcount_irq == cp0_compare_irq) if (cp0_perfcount_irq == cp0_compare_irq)
cp0_perfcount_irq = -1; cp0_perfcount_irq = -1;
Index: linux-2.6.25.1/include/asm-mips/time.h Index: linux-2.6.25.4/include/asm-mips/time.h
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/include/asm-mips/time.h --- linux-2.6.25.4.orig/include/asm-mips/time.h
+++ linux-2.6.25.1/include/asm-mips/time.h +++ linux-2.6.25.4/include/asm-mips/time.h
@@ -53,6 +53,7 @@ extern int (*perf_irq)(void); @@ -53,6 +53,7 @@ extern int (*perf_irq)(void);
#ifdef CONFIG_CEVT_R4K #ifdef CONFIG_CEVT_R4K
extern int mips_clockevent_init(void); extern int mips_clockevent_init(void);
@ -31,10 +31,10 @@ Index: linux-2.6.25.1/include/asm-mips/time.h
#else #else
static inline int mips_clockevent_init(void) static inline int mips_clockevent_init(void)
{ {
Index: linux-2.6.25.1/arch/mips/atheros/board.c Index: linux-2.6.25.4/arch/mips/atheros/board.c
=================================================================== ===================================================================
--- linux-2.6.25.1.orig/arch/mips/atheros/board.c --- linux-2.6.25.4.orig/arch/mips/atheros/board.c
+++ linux-2.6.25.1/arch/mips/atheros/board.c +++ linux-2.6.25.4/arch/mips/atheros/board.c
@@ -205,6 +205,11 @@ void (*board_time_init)(void); @@ -205,6 +205,11 @@ void (*board_time_init)(void);
void __init plat_time_init(void) { void __init plat_time_init(void) {
board_time_init(); board_time_init();