mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-16 17:13:10 +02:00
rename tools/lzma to tools/lzma-old (preparation for adding a new lzma version)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15595 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fce7c41b48
commit
037bb6d752
@ -12,14 +12,14 @@ curdir:=tools
|
||||
tools-y :=
|
||||
tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
|
||||
tools-y += m4 autoconf automake bison pkg-config sed
|
||||
tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage
|
||||
tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma-old mkimage
|
||||
tools-y += firmware-utils patch-cmdline quilt yaffs2
|
||||
|
||||
tools-$(CONFIG_CCACHE) += ccache
|
||||
tools-$(CONFIG_powerpc) += dtc
|
||||
|
||||
# builddir dependencies
|
||||
$(curdir)/squashfs/compile := $(curdir)/lzma/install
|
||||
$(curdir)/squashfs/compile := $(curdir)/lzma-old/install
|
||||
$(curdir)/quilt/compile := $(curdir)/sed/install
|
||||
$(curdir)/dtc/compile := $(curdir)/bison/install
|
||||
$(curdir)/autoconf/compile := $(curdir)/m4/install
|
||||
|
@ -26,13 +26,13 @@ define Host/Compile
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_DATA) $(LIB_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
|
||||
$(INSTALL_DATA) $(LIB_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/liblzma-old.a
|
||||
$(INSTALL_BIN) $(ALONE_DIR)/lzma $(STAGING_DIR_HOST)/bin/
|
||||
endef
|
||||
|
||||
define Host/Clean
|
||||
rm -f \
|
||||
$(STAGING_DIR_HOST)/lib/liblzma.a \
|
||||
$(STAGING_DIR_HOST)/lib/liblzma-old.a \
|
||||
$(STAGING_DIR_HOST)/bin/lzma
|
||||
endef
|
||||
|
@ -1,17 +1,11 @@
|
||||
--- a/squashfs-tools/Makefile
|
||||
+++ b/squashfs-tools/Makefile
|
||||
@@ -1,4 +1,5 @@
|
||||
INCLUDEDIR = .
|
||||
+#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
|
||||
|
||||
CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
|
||||
|
||||
@@ -7,6 +8,9 @@ all: mksquashfs unsquashfs
|
||||
mksquashfs: mksquashfs.o read_fs.o sort.o
|
||||
$(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
|
||||
|
||||
+mksquashfs-lzma: mksquashfs.o read_fs.o sort.o
|
||||
+ $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma -o $@
|
||||
+ $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma-old -o $@
|
||||
+
|
||||
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
|
||||
|
||||
@ -21,7 +15,7 @@
|
||||
$(CC) unsquashfs.o -lz -o $@
|
||||
|
||||
+unsquashfs-lzma: unsquashfs.o
|
||||
+ $(CXX) unsquashfs.o -L$(LZMAPATH) -llzma -o $@
|
||||
+ $(CXX) unsquashfs.o -L$(LZMAPATH) -llzma-old -o $@
|
||||
+
|
||||
unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
|
||||
+
|
||||
|
Loading…
Reference in New Issue
Block a user