mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 21:37:10 +02:00
kernel: update linux 3.7 to 3.7.1
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34760 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
dd7a2189bf
commit
0414913c35
@ -8,8 +8,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),3.6.11)
|
ifeq ($(LINUX_VERSION),3.6.11)
|
||||||
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.7)
|
ifeq ($(LINUX_VERSION),3.7.1)
|
||||||
LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
|
LINUX_KERNEL_MD5SUM:=b3f99fb945b270b503b2a0996b8b29e7
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
@ -1,5 +1,3 @@
|
|||||||
diff --git a/include/linux/netfilter/nf_conntrack_sip.h b/include/linux/netfilter/nf_conntrack_sip.h
|
|
||||||
index 387bdd0..ba7f571 100644
|
|
||||||
--- a/include/linux/netfilter/nf_conntrack_sip.h
|
--- a/include/linux/netfilter/nf_conntrack_sip.h
|
||||||
+++ b/include/linux/netfilter/nf_conntrack_sip.h
|
+++ b/include/linux/netfilter/nf_conntrack_sip.h
|
||||||
@@ -4,12 +4,15 @@
|
@@ -4,12 +4,15 @@
|
||||||
@ -18,11 +16,9 @@ index 387bdd0..ba7f571 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
enum sip_expectation_classes {
|
enum sip_expectation_classes {
|
||||||
diff --git a/net/netfilter/nf_nat_sip.c b/net/netfilter/nf_nat_sip.c
|
|
||||||
index 16303c7..552e270 100644
|
|
||||||
--- a/net/netfilter/nf_nat_sip.c
|
--- a/net/netfilter/nf_nat_sip.c
|
||||||
+++ b/net/netfilter/nf_nat_sip.c
|
+++ b/net/netfilter/nf_nat_sip.c
|
||||||
@@ -95,6 +95,7 @@ static int map_addr(struct sk_buff *skb, unsigned int protoff,
|
@@ -95,6 +95,7 @@ static int map_addr(struct sk_buff *skb,
|
||||||
enum ip_conntrack_info ctinfo;
|
enum ip_conntrack_info ctinfo;
|
||||||
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
||||||
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
||||||
@ -30,7 +26,7 @@ index 16303c7..552e270 100644
|
|||||||
char buffer[INET6_ADDRSTRLEN + sizeof("[]:nnnnn")];
|
char buffer[INET6_ADDRSTRLEN + sizeof("[]:nnnnn")];
|
||||||
unsigned int buflen;
|
unsigned int buflen;
|
||||||
union nf_inet_addr newaddr;
|
union nf_inet_addr newaddr;
|
||||||
@@ -107,7 +108,8 @@ static int map_addr(struct sk_buff *skb, unsigned int protoff,
|
@@ -107,7 +108,8 @@ static int map_addr(struct sk_buff *skb,
|
||||||
} else if (nf_inet_addr_cmp(&ct->tuplehash[dir].tuple.dst.u3, addr) &&
|
} else if (nf_inet_addr_cmp(&ct->tuplehash[dir].tuple.dst.u3, addr) &&
|
||||||
ct->tuplehash[dir].tuple.dst.u.udp.port == port) {
|
ct->tuplehash[dir].tuple.dst.u.udp.port == port) {
|
||||||
newaddr = ct->tuplehash[!dir].tuple.src.u3;
|
newaddr = ct->tuplehash[!dir].tuple.src.u3;
|
||||||
@ -40,7 +36,7 @@ index 16303c7..552e270 100644
|
|||||||
} else
|
} else
|
||||||
return 1;
|
return 1;
|
||||||
|
|
||||||
@@ -144,6 +146,7 @@ static unsigned int nf_nat_sip(struct sk_buff *skb, unsigned int protoff,
|
@@ -144,6 +146,7 @@ static unsigned int nf_nat_sip(struct sk
|
||||||
enum ip_conntrack_info ctinfo;
|
enum ip_conntrack_info ctinfo;
|
||||||
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
||||||
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
||||||
@ -69,7 +65,7 @@ index 16303c7..552e270 100644
|
|||||||
return NF_ACCEPT;
|
return NF_ACCEPT;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -311,8 +328,10 @@ static unsigned int nf_nat_sip_expect(struct sk_buff *skb, unsigned int protoff,
|
@@ -311,8 +328,10 @@ static unsigned int nf_nat_sip_expect(st
|
||||||
enum ip_conntrack_info ctinfo;
|
enum ip_conntrack_info ctinfo;
|
||||||
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
||||||
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
enum ip_conntrack_dir dir = CTINFO2DIR(ctinfo);
|
||||||
@ -80,7 +76,7 @@ index 16303c7..552e270 100644
|
|||||||
char buffer[INET6_ADDRSTRLEN + sizeof("[]:nnnnn")];
|
char buffer[INET6_ADDRSTRLEN + sizeof("[]:nnnnn")];
|
||||||
unsigned int buflen;
|
unsigned int buflen;
|
||||||
|
|
||||||
@@ -326,8 +345,9 @@ static unsigned int nf_nat_sip_expect(struct sk_buff *skb, unsigned int protoff,
|
@@ -326,8 +345,9 @@ static unsigned int nf_nat_sip_expect(st
|
||||||
/* If the signalling port matches the connection's source port in the
|
/* If the signalling port matches the connection's source port in the
|
||||||
* original direction, try to use the destination port in the opposite
|
* original direction, try to use the destination port in the opposite
|
||||||
* direction. */
|
* direction. */
|
||||||
@ -92,11 +88,9 @@ index 16303c7..552e270 100644
|
|||||||
port = ntohs(ct->tuplehash[!dir].tuple.dst.u.udp.port);
|
port = ntohs(ct->tuplehash[!dir].tuple.dst.u.udp.port);
|
||||||
else
|
else
|
||||||
port = ntohs(exp->tuple.dst.u.udp.port);
|
port = ntohs(exp->tuple.dst.u.udp.port);
|
||||||
diff --git a/net/netfilter/nf_conntrack_sip.c b/net/netfilter/nf_conntrack_sip.c
|
|
||||||
index df8f4f2..72a67bb 100644
|
|
||||||
--- a/net/netfilter/nf_conntrack_sip.c
|
--- a/net/netfilter/nf_conntrack_sip.c
|
||||||
+++ b/net/netfilter/nf_conntrack_sip.c
|
+++ b/net/netfilter/nf_conntrack_sip.c
|
||||||
@@ -1440,8 +1440,25 @@ static int process_sip_request(struct sk_buff *skb, unsigned int protoff,
|
@@ -1440,8 +1440,25 @@ static int process_sip_request(struct sk
|
||||||
{
|
{
|
||||||
enum ip_conntrack_info ctinfo;
|
enum ip_conntrack_info ctinfo;
|
||||||
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
struct nf_conn *ct = nf_ct_get(skb, &ctinfo);
|
||||||
|
@ -90,7 +90,7 @@
|
|||||||
* Entropy extraction routines
|
* Entropy extraction routines
|
||||||
--- a/fs/fcntl.c
|
--- a/fs/fcntl.c
|
||||||
+++ b/fs/fcntl.c
|
+++ b/fs/fcntl.c
|
||||||
@@ -146,6 +146,7 @@ pid_t f_getown(struct file *filp)
|
@@ -148,6 +148,7 @@ pid_t f_getown(struct file *filp)
|
||||||
read_unlock(&filp->f_owner.lock);
|
read_unlock(&filp->f_owner.lock);
|
||||||
return pid;
|
return pid;
|
||||||
}
|
}
|
||||||
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
|||||||
kmod-cpu-msr \
|
kmod-cpu-msr \
|
||||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||||
hwclock wpad flashrom tc
|
hwclock wpad flashrom tc
|
||||||
LINUX_VERSION:=3.7
|
LINUX_VERSION:=3.7.1
|
||||||
CS5535_MASK:=0x0E000048
|
CS5535_MASK:=0x0E000048
|
||||||
|
|
||||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -466,6 +466,8 @@ config X86_RDC321X
|
@@ -462,6 +462,8 @@ config X86_RDC321X
|
||||||
depends on X86_EXTENDED_PLATFORM
|
depends on X86_EXTENDED_PLATFORM
|
||||||
select M486
|
select M486
|
||||||
select X86_REBOOTFIXUPS
|
select X86_REBOOTFIXUPS
|
||||||
|
@ -72,7 +72,7 @@
|
|||||||
+
|
+
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -464,6 +464,7 @@ config X86_RDC321X
|
@@ -460,6 +460,7 @@ config X86_RDC321X
|
||||||
bool "RDC R-321x SoC"
|
bool "RDC R-321x SoC"
|
||||||
depends on X86_32
|
depends on X86_32
|
||||||
depends on X86_EXTENDED_PLATFORM
|
depends on X86_EXTENDED_PLATFORM
|
||||||
@ -82,7 +82,7 @@
|
|||||||
select EMBEDDED
|
select EMBEDDED
|
||||||
--- a/arch/x86/include/asm/processor.h
|
--- a/arch/x86/include/asm/processor.h
|
||||||
+++ b/arch/x86/include/asm/processor.h
|
+++ b/arch/x86/include/asm/processor.h
|
||||||
@@ -119,7 +119,8 @@ struct cpuinfo_x86 {
|
@@ -141,7 +141,8 @@ struct cpuinfo_x86 {
|
||||||
#define X86_VENDOR_CENTAUR 5
|
#define X86_VENDOR_CENTAUR 5
|
||||||
#define X86_VENDOR_TRANSMETA 7
|
#define X86_VENDOR_TRANSMETA 7
|
||||||
#define X86_VENDOR_NSC 8
|
#define X86_VENDOR_NSC 8
|
||||||
@ -94,7 +94,7 @@
|
|||||||
|
|
||||||
--- a/arch/x86/kernel/cpu/Makefile
|
--- a/arch/x86/kernel/cpu/Makefile
|
||||||
+++ b/arch/x86/kernel/cpu/Makefile
|
+++ b/arch/x86/kernel/cpu/Makefile
|
||||||
@@ -26,6 +26,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix
|
@@ -27,6 +27,7 @@ obj-$(CONFIG_CPU_SUP_CYRIX_32) += cyrix
|
||||||
obj-$(CONFIG_CPU_SUP_CENTAUR) += centaur.o
|
obj-$(CONFIG_CPU_SUP_CENTAUR) += centaur.o
|
||||||
obj-$(CONFIG_CPU_SUP_TRANSMETA_32) += transmeta.o
|
obj-$(CONFIG_CPU_SUP_TRANSMETA_32) += transmeta.o
|
||||||
obj-$(CONFIG_CPU_SUP_UMC_32) += umc.o
|
obj-$(CONFIG_CPU_SUP_UMC_32) += umc.o
|
||||||
|
@ -11,7 +11,7 @@
|
|||||||
struct erase_info erase;
|
struct erase_info erase;
|
||||||
--- a/include/linux/mtd/mtd.h
|
--- a/include/linux/mtd/mtd.h
|
||||||
+++ b/include/linux/mtd/mtd.h
|
+++ b/include/linux/mtd/mtd.h
|
||||||
@@ -530,6 +530,9 @@ extern void register_mtd_user (struct mt
|
@@ -396,6 +396,9 @@ extern void register_mtd_user (struct mt
|
||||||
extern int unregister_mtd_user (struct mtd_notifier *old);
|
extern int unregister_mtd_user (struct mtd_notifier *old);
|
||||||
void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);
|
void *mtd_kmalloc_up_to(const struct mtd_info *mtd, size_t *size);
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/x86/Makefile
|
--- a/arch/x86/Makefile
|
||||||
+++ b/arch/x86/Makefile
|
+++ b/arch/x86/Makefile
|
||||||
@@ -136,6 +136,9 @@ libs-y += arch/x86/lib/
|
@@ -163,6 +163,9 @@ libs-y += arch/x86/lib/
|
||||||
# See arch/x86/Kbuild for content of core part of the kernel
|
# See arch/x86/Kbuild for content of core part of the kernel
|
||||||
core-y += arch/x86/
|
core-y += arch/x86/
|
||||||
|
|
||||||
|
@ -7,5 +7,5 @@
|
|||||||
+ panic_on_unrecovered_nmi = 1;
|
+ panic_on_unrecovered_nmi = 1;
|
||||||
+
|
+
|
||||||
return mfd_add_devices(&pdev->dev, -1,
|
return mfd_add_devices(&pdev->dev, -1,
|
||||||
rdc321x_sb_cells, ARRAY_SIZE(rdc321x_sb_cells), NULL, 0);
|
rdc321x_sb_cells, ARRAY_SIZE(rdc321x_sb_cells),
|
||||||
}
|
NULL, 0, NULL);
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/linux/timex.h
|
--- a/include/linux/timex.h
|
||||||
+++ b/include/linux/timex.h
|
+++ b/include/linux/timex.h
|
||||||
@@ -274,7 +274,11 @@ extern void hardpps(const struct timespe
|
@@ -150,6 +150,10 @@ extern void hardpps(const struct timespe
|
||||||
int read_current_timer(unsigned long *timer_val);
|
int read_current_timer(unsigned long *timer_val);
|
||||||
|
|
||||||
/* The clock frequency of the i8253/i8254 PIT */
|
/* The clock frequency of the i8253/i8254 PIT */
|
||||||
@ -10,5 +10,4 @@
|
|||||||
#define PIT_TICK_RATE 1193182ul
|
#define PIT_TICK_RATE 1193182ul
|
||||||
+#endif
|
+#endif
|
||||||
|
|
||||||
#endif /* KERNEL */
|
#endif /* LINUX_TIMEX_H */
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user