mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-17 23:03:44 +02:00
dnsmasq: Set prefix on-link bit in RAs
This is fix an issue with dnsmasq's RA that does not set the "on-link" bit, making all local IPv6 traffic go to the router then to the destination host, not directly to each other. patch is from dnsmasq git git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33216 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fdbde13d03
commit
0b51351f93
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.62
|
PKG_VERSION:=2.62
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
|
@ -0,0 +1,42 @@
|
|||||||
|
From fd05f127909bbf4f6983a4de2dcb611947488dee Mon Sep 17 00:00:00 2001
|
||||||
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
||||||
|
Date: Sun, 12 Aug 2012 17:48:50 +0100
|
||||||
|
Subject: [PATCH] Set prefix on-link bit in RAs
|
||||||
|
|
||||||
|
---
|
||||||
|
CHANGELOG | 3 +++
|
||||||
|
src/radv.c | 4 ++--
|
||||||
|
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CHANGELOG b/CHANGELOG
|
||||||
|
index 8828694..e1daeef 100644
|
||||||
|
--- a/CHANGELOG
|
||||||
|
+++ b/CHANGELOG
|
||||||
|
@@ -45,6 +45,9 @@ version 2.63
|
||||||
|
uk.org.thekelleys.dnsmasq. Thanks to Mathieu
|
||||||
|
Trudel-Lapierre for the patch.
|
||||||
|
|
||||||
|
+ Set the "prefix on-link" bit in Router
|
||||||
|
+ Advertisements. Thanks to Gui Iribarren for the patch.
|
||||||
|
+
|
||||||
|
|
||||||
|
version 2.62
|
||||||
|
Update German translation. Thanks to Conrad Kostecki.
|
||||||
|
diff --git a/src/radv.c b/src/radv.c
|
||||||
|
index a3e691a..d1f5268 100644
|
||||||
|
--- a/src/radv.c
|
||||||
|
+++ b/src/radv.c
|
||||||
|
@@ -412,8 +412,8 @@ static int add_prefixes(struct in6_addr *local, int prefix,
|
||||||
|
opt->type = ICMP6_OPT_PREFIX;
|
||||||
|
opt->len = 4;
|
||||||
|
opt->prefix_len = prefix;
|
||||||
|
- /* autonomous only if we're not doing dhcp */
|
||||||
|
- opt->flags = do_slaac ? 0x40 : 0x00;
|
||||||
|
+ /* autonomous only if we're not doing dhcp, always set "on-link" */
|
||||||
|
+ opt->flags = do_slaac ? 0xC0 : 0x80;
|
||||||
|
opt->valid_lifetime = htonl(time);
|
||||||
|
opt->preferred_lifetime = htonl(deprecate ? 0 : time);
|
||||||
|
opt->reserved = 0;
|
||||||
|
--
|
||||||
|
1.7.10.GIT
|
||||||
|
|
Loading…
Reference in New Issue
Block a user