mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-19 05:04:04 +02:00
upgrade udev to v103, add kexec-tools
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5637 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8205c709b4
commit
0b834fadd8
75
package/kexec-tools/Makefile
Normal file
75
package/kexec-tools/Makefile
Normal file
@ -0,0 +1,75 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=kexec-tools
|
||||||
|
PKG_VERSION:=1.101
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://www.xmission.com/~ebiederm/files/kexec/
|
||||||
|
PKG_MD5SUM:=b4f7ffcc294d41a6a4c40d6e44b7734d
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/kexec-tools
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=@LINUX_2_6_X86
|
||||||
|
TITLE:=Kernel boots kernel
|
||||||
|
DESCRIPTION:=\
|
||||||
|
kexec is a set of systems call that allows you to load \\\
|
||||||
|
another kernel from the currently executing Linux kernel.
|
||||||
|
URL:=http://www.xmission.com/~ebiederm/files/kexec/README
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
./configure \
|
||||||
|
--target=$(GNU_TARGET_NAME) \
|
||||||
|
--host=$(GNU_TARGET_NAME) \
|
||||||
|
--build=$(GNU_HOST_NAME) \
|
||||||
|
--program-prefix="" \
|
||||||
|
--program-suffix="" \
|
||||||
|
--prefix=/usr \
|
||||||
|
--exec-prefix=/usr \
|
||||||
|
--bindir=/usr/bin \
|
||||||
|
--sbindir=/usr/sbin \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
--datadir=/usr/share \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--mandir=/usr/man \
|
||||||
|
--infodir=/usr/info \
|
||||||
|
$(DISABLE_NLS) \
|
||||||
|
$(DISABLE_LARGEFILE) \
|
||||||
|
);
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/kexec-tools/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/bin/
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,kexec-tools))
|
@ -9,7 +9,7 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=udev
|
PKG_NAME:=udev
|
||||||
PKG_VERSION:=077
|
PKG_VERSION:=103
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
@ -19,7 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
|
|||||||
http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
|
http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
|
||||||
ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
|
ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
|
||||||
http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
|
http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
|
||||||
PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
|
PKG_MD5SUM:=7360ce47b5ec3f9fa71f18071ecb8b97
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
@ -41,7 +41,7 @@ endef
|
|||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
CROSS="$(TARGET_CROSS)" \
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
STRIP="/bin/true" \
|
STRIP="/bin/true" \
|
||||||
OPTFLAGS="$(TARGET_CFLAGS)" \
|
OPTFLAGS="$(TARGET_CFLAGS)" \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
@ -54,11 +54,8 @@ define Package/udev/install
|
|||||||
$(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
|
$(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
|
||||||
install -d -m0775 $(1)/lib/udev
|
install -d -m0775 $(1)/lib/udev
|
||||||
install -d -m0775 $(1)/sbin/
|
install -d -m0775 $(1)/sbin/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
|
$(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
|
$(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
|
|
||||||
install -d -m0775 $(1)/usr/bin/
|
install -d -m0775 $(1)/usr/bin/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
|
||||||
|
@ -1,21 +1,21 @@
|
|||||||
diff -ruN udev-077-old/Makefile udev-077-new/Makefile
|
diff -Nur udev-103-old/Makefile udev-103-new/Makefile
|
||||||
--- udev-077-old/Makefile 2005-12-04 03:01:48.000000000 +0100
|
--- udev-103-old/Makefile 2006-10-20 14:43:35.000000000 +0200
|
||||||
+++ udev-077-new/Makefile 2005-12-07 16:48:11.000000000 +0100
|
+++ udev-103-new/Makefile 2006-11-24 15:44:35.000000000 +0100
|
||||||
@@ -136,7 +136,7 @@
|
@@ -113,7 +113,7 @@
|
||||||
# check if compiler option is supported
|
AR = $(CROSS_COMPILE)ar
|
||||||
cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
|
RANLIB = $(CROSS_COMPILE)ranlib
|
||||||
|
|
||||||
-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
||||||
+CFLAGS = -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
+CFLAGS = -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
||||||
WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
|
WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
|
||||||
-Wchar-subscripts -Wmissing-declarations -Wnested-externs \
|
-Wchar-subscripts -Wmissing-declarations -Wnested-externs \
|
||||||
-Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
|
-Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
|
||||||
@@ -159,7 +159,7 @@
|
@@ -130,7 +130,7 @@
|
||||||
|
|
||||||
# if DEBUG is enabled, then we do not strip
|
# if DEBUG is enabled, then we do not strip
|
||||||
ifeq ($(strip $(DEBUG)),true)
|
ifeq ($(strip $(DEBUG)),true)
|
||||||
- CFLAGS += -DDEBUG
|
- CFLAGS += -DDEBUG
|
||||||
+ CFLAGS += -g -DDEBUG
|
+ CFLAGS += -g -DDEBUG
|
||||||
STRIPCMD =
|
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifeq ($(strip $(USE_GCOV)),true)
|
||||||
|
Loading…
Reference in New Issue
Block a user