1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 08:08:04 +03:00

[kernel] refresh 2.6.27 patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17061 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-07-31 11:10:20 +00:00
parent 6c24276491
commit 0fcf0020d6
4 changed files with 18 additions and 16 deletions

View File

@ -22,7 +22,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
cpu_wait = r4k_wait; cpu_wait = r4k_wait;
break; break;
@@ -802,11 +806,28 @@ static inline void cpu_probe_broadcom(st @@ -802,11 +805,28 @@ static inline void cpu_probe_broadcom(st
decode_configs(c); decode_configs(c);
switch (c->processor_id & 0xff00) { switch (c->processor_id & 0xff00) {
case PRID_IMP_BCM3302: case PRID_IMP_BCM3302:
@ -51,7 +51,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
default: default:
c->cputype = CPU_UNKNOWN; c->cputype = CPU_UNKNOWN;
break; break;
@@ -892,6 +913,10 @@ static __cpuinit const char *cpu_to_name @@ -892,6 +912,10 @@ static __cpuinit const char *cpu_to_name
case CPU_SR71000: name = "Sandcraft SR71000"; break; case CPU_SR71000: name = "Sandcraft SR71000"; break;
case CPU_BCM3302: name = "Broadcom BCM3302"; break; case CPU_BCM3302: name = "Broadcom BCM3302"; break;
case CPU_BCM4710: name = "Broadcom BCM4710"; break; case CPU_BCM4710: name = "Broadcom BCM4710"; break;

View File

@ -45,9 +45,9 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
static inline unsigned int ehci_readl(const struct ehci_hcd *ehci, static inline unsigned int ehci_readl(const struct ehci_hcd *ehci,
__u32 __iomem * regs) __u32 __iomem * regs)
{ {
--- a/drivers/usb/host/Kconfig 2009-07-03 01:33:19.000000000 +0200 --- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig 2009-07-17 17:53:11.000000000 +0200 +++ b/drivers/usb/host/Kconfig
@@ -44,7 +44,7 @@ @@ -44,7 +44,7 @@ config USB_EHCI_HCD
config USB_EHCI_ROOT_HUB_TT config USB_EHCI_ROOT_HUB_TT
bool "Root Hub Transaction Translators" bool "Root Hub Transaction Translators"

View File

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -549,6 +549,9 @@ endif @@ -550,6 +550,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include) NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS) CHECKFLAGS += $(NOSTDINC_FLAGS)

View File

@ -27,16 +27,18 @@
RxFIFOOver | TxErr | TxOK | RxOK | RxErr, RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow, .napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI .features = RTL_FEATURE_MSI
@@ -2878,10 +2878,12 @@ static irqreturn_t rtl8169_interrupt(int @@ -2872,12 +2872,12 @@ static irqreturn_t rtl8169_interrupt(int
goto out; rtl8169_tx_timeout(dev);
} break;
}
-
+#if 0 +#if 0
if (unlikely(status & SYSErr)) { if (unlikely(status & SYSErr)) {
rtl8169_pcierr_interrupt(dev); rtl8169_pcierr_interrupt(dev);
goto out; break;
} }
-
+#endif +#endif
if (status & LinkChg)
rtl8169_check_link_status(dev, tp, ioaddr);
if (status & LinkChg)
rtl8169_check_link_status(dev, tp, ioaddr);