1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 23:22:22 +03:00

kernel: generic: refresh patches for 3.1-rc2

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28021 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jogo 2011-08-16 21:42:15 +00:00
parent 414f855ff1
commit 100f1cd12e
4 changed files with 5 additions and 14 deletions

View File

@ -238,7 +238,7 @@
obj-$(CONFIG_OMFS_FS) += omfs/
--- a/fs/ecryptfs/main.c
+++ b/fs/ecryptfs/main.c
@@ -525,6 +525,13 @@ static struct dentry *ecryptfs_mount(str
@@ -544,6 +544,13 @@ static struct dentry *ecryptfs_mount(str
s->s_maxbytes = path.dentry->d_sb->s_maxbytes;
s->s_blocksize = path.dentry->d_sb->s_blocksize;
s->s_magic = ECRYPTFS_SUPER_MAGIC;

View File

@ -28,10 +28,10 @@
depends on BROKEN || !FRV
--- a/kernel/Makefile
+++ b/kernel/Makefile
@@ -107,6 +107,7 @@ obj-$(CONFIG_PERF_EVENTS) += events/
obj-$(CONFIG_USER_RETURN_NOTIFIER) += user-return-notifier.o
@@ -108,6 +108,7 @@ obj-$(CONFIG_USER_RETURN_NOTIFIER) += us
obj-$(CONFIG_PADATA) += padata.o
obj-$(CONFIG_CRASH_DUMP) += crash_dump.o
obj-$(CONFIG_JUMP_LABEL) += jump_label.o
+obj-$(CONFIG_CRASHLOG) += crashlog.o
ifneq ($(CONFIG_SCHED_OMIT_FRAME_POINTER),y)

View File

@ -89,7 +89,7 @@
* We enter with non-exclusive mmap_sem (to exclude vma changes,
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
@@ -1231,6 +1231,7 @@ void unmap_kernel_range(unsigned long ad
@@ -1232,6 +1232,7 @@ void unmap_kernel_range(unsigned long ad
vunmap_page_range(addr, end);
flush_tlb_kernel_range(addr, end);
}
@ -97,7 +97,7 @@
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
{
@@ -1346,6 +1347,7 @@ struct vm_struct *get_vm_area(unsigned l
@@ -1347,6 +1348,7 @@ struct vm_struct *get_vm_area(unsigned l
return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
-1, GFP_KERNEL, __builtin_return_address(0));
}

View File

@ -2818,15 +2818,6 @@
bluecheese MACH_BLUECHEESE BLUECHEESE 3057
tem3x30 MACH_TEM3X30 TEM3X30 3058
harvest_desoto MACH_HARVEST_DESOTO HARVEST_DESOTO 3059
@@ -910,7 +3240,7 @@ omapl138_case_a3 MACH_OMAPL138_CASE_A3 O
uemd MACH_UEMD UEMD 3281
ccwmx51mut MACH_CCWMX51MUT CCWMX51MUT 3282
rockhopper MACH_ROCKHOPPER ROCKHOPPER 3283
-nookcolor MACH_NOOKCOLOR NOOKCOLOR 3284
+encore MACH_ENCORE ENCORE 3284
hkdkc100 MACH_HKDKC100 HKDKC100 3285
ts42xx MACH_TS42XX TS42XX 3286
aebl MACH_AEBL AEBL 3287
@@ -921,7 +3251,9 @@ isc3 MACH_ISC3 ISC3 3291
rascal MACH_RASCAL RASCAL 3292
hrefv60 MACH_HREFV60 HREFV60 3293