mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-18 11:16:16 +02:00
fixes ltq-vmmc for none falcon targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27530 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6c1e15e715
commit
1a532b3607
@ -1,6 +1,24 @@
|
|||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -986,6 +986,11 @@ AC_ARG_WITH(device,
|
@@ -956,14 +956,15 @@ AC_DEFINE([VMMC],[1],[enable VMMC suppor
|
||||||
|
AM_CONDITIONAL(DANUBE, false)
|
||||||
|
AM_CONDITIONAL(AR9, false)
|
||||||
|
AM_CONDITIONAL(VR9, false)
|
||||||
|
+AM_CONDITIONAL(FALCON, false)
|
||||||
|
AC_ARG_WITH(device,
|
||||||
|
AC_HELP_STRING(
|
||||||
|
- [--with-device=DANUBE|TWINPASS|AR9|VR9],
|
||||||
|
+ [--with-device=DANUBE|TWINPASS|AR9|VR9|FALCON],
|
||||||
|
[Set device type, default is DANUBE]
|
||||||
|
),
|
||||||
|
[
|
||||||
|
if test "$withval" = yes; then
|
||||||
|
- AC_MSG_ERROR([Set device type! Valid choices are DANUBE|TWINPASS|AR9|VR9]);
|
||||||
|
+ AC_MSG_ERROR([Set device type! Valid choices are DANUBE|TWINPASS|AR9|VR9|FALCON]);
|
||||||
|
else
|
||||||
|
case $withval in
|
||||||
|
DANUBE)
|
||||||
|
@@ -986,8 +987,13 @@ AC_ARG_WITH(device,
|
||||||
AC_DEFINE([SYSTEM_VR9],[1],[enable VR9 specific code])
|
AC_DEFINE([SYSTEM_VR9],[1],[enable VR9 specific code])
|
||||||
AM_CONDITIONAL(VR9, true)
|
AM_CONDITIONAL(VR9, true)
|
||||||
;;
|
;;
|
||||||
@ -10,8 +28,11 @@
|
|||||||
+ AM_CONDITIONAL(FALCON, true)
|
+ AM_CONDITIONAL(FALCON, true)
|
||||||
+ ;;
|
+ ;;
|
||||||
*)
|
*)
|
||||||
AC_MSG_ERROR([Set device type! Valid choices are DANUBE|TWINPASS|AR9|VR9]);
|
- AC_MSG_ERROR([Set device type! Valid choices are DANUBE|TWINPASS|AR9|VR9]);
|
||||||
|
+ AC_MSG_ERROR([Set device type! Valid choices are DANUBE|TWINPASS|AR9|VR9|FALCON]);
|
||||||
;;
|
;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
--- a/src/Makefile.am
|
--- a/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ b/src/Makefile.am
|
||||||
@@ -70,6 +70,11 @@ drv_vmmc_SOURCES +=\
|
@@ -70,6 +70,11 @@ drv_vmmc_SOURCES +=\
|
||||||
|
Loading…
Reference in New Issue
Block a user