1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2025-02-04 00:51:06 +02:00

opkg: work around a gcc warning bug related to array bounds checking

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14506 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2009-02-14 10:43:15 +00:00
parent f9e546b068
commit 1d1fd8474b

View File

@ -0,0 +1,10 @@
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -1,6 +1,6 @@
HOST_CPU=@host_cpu@
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
libopkg_includedir=$(includedir)/libopkg
libopkg_include_HEADERS= opkg.h