mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-02-20 08:14:44 +02:00
kernel: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31279 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4ad28d6429
commit
1e83690598
@ -127,10 +127,11 @@
|
|||||||
|
|
||||||
e = (struct ipt_entry *)(loc_cpu_entry + off);
|
e = (struct ipt_entry *)(loc_cpu_entry + off);
|
||||||
if (copy_to_user(userptr + off
|
if (copy_to_user(userptr + off
|
||||||
@@ -986,6 +1026,14 @@ copy_entries_to_user(unsigned int total_
|
@@ -985,6 +1025,14 @@ copy_entries_to_user(unsigned int total_
|
||||||
|
ret = -EFAULT;
|
||||||
goto free_counters;
|
goto free_counters;
|
||||||
}
|
}
|
||||||
|
+
|
||||||
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
|
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
|
||||||
+ if (copy_to_user(userptr + off
|
+ if (copy_to_user(userptr + off
|
||||||
+ + offsetof(struct ipt_entry, ip.flags),
|
+ + offsetof(struct ipt_entry, ip.flags),
|
||||||
@ -138,7 +139,6 @@
|
|||||||
+ ret = -EFAULT;
|
+ ret = -EFAULT;
|
||||||
+ goto free_counters;
|
+ goto free_counters;
|
||||||
+ }
|
+ }
|
||||||
+
|
|
||||||
for (i = sizeof(struct ipt_entry);
|
for (i = sizeof(struct ipt_entry);
|
||||||
i < e->target_offset;
|
i < e->target_offset;
|
||||||
i += m->u.match_size) {
|
|
||||||
|
@ -11038,14 +11038,14 @@
|
|||||||
+ yaffs_UnpackTags2(tags, &pt);
|
+ yaffs_UnpackTags2(tags, &pt);
|
||||||
+ }
|
+ }
|
||||||
+ }
|
+ }
|
||||||
|
+
|
||||||
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
|
||||||
- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
|
||||||
+ if (localData)
|
+ if (localData)
|
||||||
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
|
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
|
||||||
|
|
||||||
|
- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||||
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
|
||||||
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
|
||||||
|
-
|
||||||
if (retval == 0)
|
if (retval == 0)
|
||||||
return YAFFS_OK;
|
return YAFFS_OK;
|
||||||
else
|
else
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -93,6 +93,9 @@ config ADM6996_PHY
|
@@ -95,6 +95,9 @@ config ADM6996_PHY
|
||||||
---help---
|
Currently supports the ADM6996FC and ADM6996M switches.
|
||||||
Currently supports the ADM6996F switch
|
Support for FC is very limited.
|
||||||
|
|
||||||
+config MVSWITCH_PHY
|
+config MVSWITCH_PHY
|
||||||
+ tristate "Driver for Marvell 88E6060 switches"
|
+ tristate "Driver for Marvell 88E6060 switches"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -96,6 +96,10 @@ config ADM6996_PHY
|
@@ -98,6 +98,10 @@ config ADM6996_PHY
|
||||||
config MVSWITCH_PHY
|
config MVSWITCH_PHY
|
||||||
tristate "Driver for Marvell 88E6060 switches"
|
tristate "Driver for Marvell 88E6060 switches"
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -100,6 +100,10 @@ config IP17XX_PHY
|
@@ -102,6 +102,10 @@ config IP17XX_PHY
|
||||||
tristate "Driver for IC+ IP17xx switches"
|
tristate "Driver for IC+ IP17xx switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -104,6 +104,10 @@ config AR8216_PHY
|
@@ -106,6 +106,10 @@ config AR8216_PHY
|
||||||
tristate "Driver for Atheros AR8216 switches"
|
tristate "Driver for Atheros AR8216 switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -135,4 +135,29 @@ config MDIO_GPIO
|
@@ -137,4 +137,29 @@ config MDIO_GPIO
|
||||||
To compile this driver as a module, choose M here: the module
|
To compile this driver as a module, choose M here: the module
|
||||||
will be called mdio-gpio.
|
will be called mdio-gpio.
|
||||||
|
|
||||||
|
@ -8,7 +8,7 @@
|
|||||||
depends on NETFILTER_ADVANCED
|
depends on NETFILTER_ADVANCED
|
||||||
help
|
help
|
||||||
H.323 is a VoIP signalling protocol from ITU-T. As one of the most
|
H.323 is a VoIP signalling protocol from ITU-T. As one of the most
|
||||||
@@ -505,7 +504,6 @@ config NETFILTER_XT_TARGET_SECMARK
|
@@ -493,7 +492,6 @@ config NETFILTER_XT_TARGET_SECMARK
|
||||||
|
|
||||||
config NETFILTER_XT_TARGET_TCPMSS
|
config NETFILTER_XT_TARGET_TCPMSS
|
||||||
tristate '"TCPMSS" target support'
|
tristate '"TCPMSS" target support'
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/linux/skbuff.h
|
--- a/include/linux/skbuff.h
|
||||||
+++ b/include/linux/skbuff.h
|
+++ b/include/linux/skbuff.h
|
||||||
@@ -1387,11 +1387,18 @@ static inline int skb_network_offset(con
|
@@ -1369,11 +1369,18 @@ static inline int skb_network_offset(con
|
||||||
*
|
*
|
||||||
* Various parts of the networking layer expect at least 32 bytes of
|
* Various parts of the networking layer expect at least 32 bytes of
|
||||||
* headroom, you should not reduce this.
|
* headroom, you should not reduce this.
|
||||||
@ -19,7 +19,7 @@
|
|||||||
extern int ___pskb_trim(struct sk_buff *skb, unsigned int len);
|
extern int ___pskb_trim(struct sk_buff *skb, unsigned int len);
|
||||||
|
|
||||||
static inline void __skb_trim(struct sk_buff *skb, unsigned int len)
|
static inline void __skb_trim(struct sk_buff *skb, unsigned int len)
|
||||||
@@ -1481,9 +1488,9 @@ static inline void __skb_queue_purge(str
|
@@ -1463,9 +1470,9 @@ static inline void __skb_queue_purge(str
|
||||||
static inline struct sk_buff *__dev_alloc_skb(unsigned int length,
|
static inline struct sk_buff *__dev_alloc_skb(unsigned int length,
|
||||||
gfp_t gfp_mask)
|
gfp_t gfp_mask)
|
||||||
{
|
{
|
||||||
@ -31,7 +31,7 @@
|
|||||||
return skb;
|
return skb;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1556,7 +1563,7 @@ static inline int __skb_cow(struct sk_bu
|
@@ -1538,7 +1545,7 @@ static inline int __skb_cow(struct sk_bu
|
||||||
delta = headroom - skb_headroom(skb);
|
delta = headroom - skb_headroom(skb);
|
||||||
|
|
||||||
if (delta || cloned)
|
if (delta || cloned)
|
||||||
@ -42,7 +42,7 @@
|
|||||||
}
|
}
|
||||||
--- a/net/core/skbuff.c
|
--- a/net/core/skbuff.c
|
||||||
+++ b/net/core/skbuff.c
|
+++ b/net/core/skbuff.c
|
||||||
@@ -336,9 +336,9 @@ struct sk_buff *__netdev_alloc_skb(struc
|
@@ -259,9 +259,9 @@ struct sk_buff *__netdev_alloc_skb(struc
|
||||||
int node = dev->dev.parent ? dev_to_node(dev->dev.parent) : -1;
|
int node = dev->dev.parent ? dev_to_node(dev->dev.parent) : -1;
|
||||||
struct sk_buff *skb;
|
struct sk_buff *skb;
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/linux/phy.h
|
--- a/include/linux/phy.h
|
||||||
+++ b/include/linux/phy.h
|
+++ b/include/linux/phy.h
|
||||||
@@ -393,9 +393,18 @@ struct phy_driver {
|
@@ -379,9 +379,18 @@ struct phy_driver {
|
||||||
*/
|
*/
|
||||||
int (*config_aneg)(struct phy_device *phydev);
|
int (*config_aneg)(struct phy_device *phydev);
|
||||||
|
|
||||||
@ -21,7 +21,7 @@
|
|||||||
|
|
||||||
--- a/drivers/net/phy/phy_device.c
|
--- a/drivers/net/phy/phy_device.c
|
||||||
+++ b/drivers/net/phy/phy_device.c
|
+++ b/drivers/net/phy/phy_device.c
|
||||||
@@ -695,6 +695,9 @@ int genphy_update_link(struct phy_device
|
@@ -681,6 +681,9 @@ int genphy_update_link(struct phy_device
|
||||||
{
|
{
|
||||||
int status;
|
int status;
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -93,6 +93,9 @@ config ADM6996_PHY
|
@@ -95,6 +95,9 @@ config ADM6996_PHY
|
||||||
---help---
|
Currently supports the ADM6996FC and ADM6996M switches.
|
||||||
Currently supports the ADM6996F switch
|
Support for FC is very limited.
|
||||||
|
|
||||||
+config MVSWITCH_PHY
|
+config MVSWITCH_PHY
|
||||||
+ tristate "Driver for Marvell 88E6060 switches"
|
+ tristate "Driver for Marvell 88E6060 switches"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -96,6 +96,10 @@ config ADM6996_PHY
|
@@ -98,6 +98,10 @@ config ADM6996_PHY
|
||||||
config MVSWITCH_PHY
|
config MVSWITCH_PHY
|
||||||
tristate "Driver for Marvell 88E6060 switches"
|
tristate "Driver for Marvell 88E6060 switches"
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -100,6 +100,10 @@ config IP175C_PHY
|
@@ -102,6 +102,10 @@ config IP17XX_PHY
|
||||||
tristate "Driver for IC+ IP175C/IP178C switches"
|
tristate "Driver for IC+ IP17xx switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
+config AR8216_PHY
|
+config AR8216_PHY
|
||||||
@ -15,7 +15,7 @@
|
|||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
||||||
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
||||||
obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
||||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||||
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
||||||
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -104,6 +104,10 @@ config AR8216_PHY
|
@@ -106,6 +106,10 @@ config AR8216_PHY
|
||||||
tristate "Driver for Atheros AR8216 switches"
|
tristate "Driver for Atheros AR8216 switches"
|
||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
|
|
||||||
@ -14,7 +14,7 @@
|
|||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
||||||
obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
||||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||||
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
||||||
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -135,4 +135,29 @@ config MDIO_GPIO
|
@@ -137,4 +137,29 @@ config MDIO_GPIO
|
||||||
To compile this driver as a module, choose M here: the module
|
To compile this driver as a module, choose M here: the module
|
||||||
will be called mdio-gpio.
|
will be called mdio-gpio.
|
||||||
|
|
||||||
@ -32,7 +32,7 @@
|
|||||||
endif # PHYLIB
|
endif # PHYLIB
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -19,6 +19,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
@@ -19,6 +19,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
||||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||||
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
||||||
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
||||||
|
@ -11,7 +11,7 @@
|
|||||||
# define LL_MAX_HEADER 96
|
# define LL_MAX_HEADER 96
|
||||||
--- a/include/linux/skbuff.h
|
--- a/include/linux/skbuff.h
|
||||||
+++ b/include/linux/skbuff.h
|
+++ b/include/linux/skbuff.h
|
||||||
@@ -389,7 +389,7 @@ struct sk_buff {
|
@@ -380,7 +380,7 @@ struct sk_buff {
|
||||||
#ifdef CONFIG_IPV6_NDISC_NODETYPE
|
#ifdef CONFIG_IPV6_NDISC_NODETYPE
|
||||||
__u8 ndisc_nodetype:2;
|
__u8 ndisc_nodetype:2;
|
||||||
#endif
|
#endif
|
||||||
|
@ -81,7 +81,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
|
|
||||||
--- a/arch/arm/include/asm/thread_info.h
|
--- a/arch/arm/include/asm/thread_info.h
|
||||||
+++ b/arch/arm/include/asm/thread_info.h
|
+++ b/arch/arm/include/asm/thread_info.h
|
||||||
@@ -141,6 +141,7 @@
|
@@ -140,6 +140,7 @@ extern void vfp_sync_state(struct thread
|
||||||
#define TIF_USING_IWMMXT 17
|
#define TIF_USING_IWMMXT 17
|
||||||
#define TIF_MEMDIE 18
|
#define TIF_MEMDIE 18
|
||||||
#define TIF_FREEZE 19
|
#define TIF_FREEZE 19
|
||||||
@ -89,7 +89,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
|
|
||||||
#define _TIF_SIGPENDING (1 << TIF_SIGPENDING)
|
#define _TIF_SIGPENDING (1 << TIF_SIGPENDING)
|
||||||
#define _TIF_NEED_RESCHED (1 << TIF_NEED_RESCHED)
|
#define _TIF_NEED_RESCHED (1 << TIF_NEED_RESCHED)
|
||||||
@@ -148,6 +149,7 @@
|
@@ -147,6 +148,7 @@ extern void vfp_sync_state(struct thread
|
||||||
#define _TIF_POLLING_NRFLAG (1 << TIF_POLLING_NRFLAG)
|
#define _TIF_POLLING_NRFLAG (1 << TIF_POLLING_NRFLAG)
|
||||||
#define _TIF_USING_IWMMXT (1 << TIF_USING_IWMMXT)
|
#define _TIF_USING_IWMMXT (1 << TIF_USING_IWMMXT)
|
||||||
#define _TIF_FREEZE (1 << TIF_FREEZE)
|
#define _TIF_FREEZE (1 << TIF_FREEZE)
|
||||||
@ -169,7 +169,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
CALL(sys_signalfd)
|
CALL(sys_signalfd)
|
||||||
--- a/arch/arm/kernel/entry-common.S
|
--- a/arch/arm/kernel/entry-common.S
|
||||||
+++ b/arch/arm/kernel/entry-common.S
|
+++ b/arch/arm/kernel/entry-common.S
|
||||||
@@ -373,16 +373,6 @@
|
@@ -373,16 +373,6 @@ sys_clone_wrapper:
|
||||||
b sys_clone
|
b sys_clone
|
||||||
ENDPROC(sys_clone_wrapper)
|
ENDPROC(sys_clone_wrapper)
|
||||||
|
|
||||||
@ -188,7 +188,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
b sys_sigreturn
|
b sys_sigreturn
|
||||||
--- a/arch/arm/kernel/signal.c
|
--- a/arch/arm/kernel/signal.c
|
||||||
+++ b/arch/arm/kernel/signal.c
|
+++ b/arch/arm/kernel/signal.c
|
||||||
@@ -47,57 +47,22 @@
|
@@ -47,57 +47,22 @@ const unsigned long sigreturn_codes[7] =
|
||||||
MOV_R7_NR_RT_SIGRETURN, SWI_SYS_RT_SIGRETURN, SWI_THUMB_RT_SIGRETURN,
|
MOV_R7_NR_RT_SIGRETURN, SWI_SYS_RT_SIGRETURN, SWI_THUMB_RT_SIGRETURN,
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -252,7 +252,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
}
|
}
|
||||||
|
|
||||||
asmlinkage int
|
asmlinkage int
|
||||||
@@ -545,7 +510,7 @@
|
@@ -545,7 +510,7 @@ static inline void setup_syscall_restart
|
||||||
/*
|
/*
|
||||||
* OK, we're invoking a handler
|
* OK, we're invoking a handler
|
||||||
*/
|
*/
|
||||||
@ -261,7 +261,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
handle_signal(unsigned long sig, struct k_sigaction *ka,
|
handle_signal(unsigned long sig, struct k_sigaction *ka,
|
||||||
siginfo_t *info, sigset_t *oldset,
|
siginfo_t *info, sigset_t *oldset,
|
||||||
struct pt_regs * regs, int syscall)
|
struct pt_regs * regs, int syscall)
|
||||||
@@ -596,7 +561,7 @@
|
@@ -596,7 +561,7 @@ handle_signal(unsigned long sig, struct
|
||||||
|
|
||||||
if (ret != 0) {
|
if (ret != 0) {
|
||||||
force_sigsegv(sig, tsk);
|
force_sigsegv(sig, tsk);
|
||||||
@ -270,7 +270,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
}
|
}
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -610,6 +575,7 @@
|
@@ -610,6 +575,7 @@ handle_signal(unsigned long sig, struct
|
||||||
recalc_sigpending();
|
recalc_sigpending();
|
||||||
spin_unlock_irq(&tsk->sighand->siglock);
|
spin_unlock_irq(&tsk->sighand->siglock);
|
||||||
|
|
||||||
@ -278,7 +278,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
}
|
}
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -621,11 +587,12 @@
|
@@ -621,11 +587,12 @@ handle_signal(unsigned long sig, struct
|
||||||
* the kernel can handle, and then we build all the user-level signal handling
|
* the kernel can handle, and then we build all the user-level signal handling
|
||||||
* stack-frames in one go after that.
|
* stack-frames in one go after that.
|
||||||
*/
|
*/
|
||||||
@ -292,7 +292,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* We want the common case to go fast, which
|
* We want the common case to go fast, which
|
||||||
@@ -634,18 +601,32 @@
|
@@ -634,18 +601,32 @@ static int do_signal(sigset_t *oldset, s
|
||||||
* if so.
|
* if so.
|
||||||
*/
|
*/
|
||||||
if (!user_mode(regs))
|
if (!user_mode(regs))
|
||||||
@ -328,7 +328,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||||||
}
|
}
|
||||||
|
|
||||||
no_signal:
|
no_signal:
|
||||||
@@ -697,14 +678,21 @@
|
@@ -697,14 +678,21 @@ static int do_signal(sigset_t *oldset, s
|
||||||
regs->ARM_r0 == -ERESTARTNOINTR) {
|
regs->ARM_r0 == -ERESTARTNOINTR) {
|
||||||
setup_syscall_restart(regs);
|
setup_syscall_restart(regs);
|
||||||
}
|
}
|
||||||
|
@ -97,7 +97,7 @@
|
|||||||
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
||||||
--- a/mm/vmalloc.c
|
--- a/mm/vmalloc.c
|
||||||
+++ b/mm/vmalloc.c
|
+++ b/mm/vmalloc.c
|
||||||
@@ -1101,6 +1101,7 @@ void unmap_kernel_range(unsigned long ad
|
@@ -1099,6 +1099,7 @@ void unmap_kernel_range(unsigned long ad
|
||||||
vunmap_page_range(addr, end);
|
vunmap_page_range(addr, end);
|
||||||
flush_tlb_kernel_range(addr, end);
|
flush_tlb_kernel_range(addr, end);
|
||||||
}
|
}
|
||||||
@ -105,7 +105,7 @@
|
|||||||
|
|
||||||
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
|
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
|
||||||
{
|
{
|
||||||
@@ -1214,6 +1215,7 @@ struct vm_struct *get_vm_area(unsigned l
|
@@ -1212,6 +1213,7 @@ struct vm_struct *get_vm_area(unsigned l
|
||||||
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
|
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
|
||||||
-1, GFP_KERNEL, __builtin_return_address(0));
|
-1, GFP_KERNEL, __builtin_return_address(0));
|
||||||
}
|
}
|
||||||
@ -115,7 +115,7 @@
|
|||||||
void *caller)
|
void *caller)
|
||||||
--- a/include/linux/mm.h
|
--- a/include/linux/mm.h
|
||||||
+++ b/include/linux/mm.h
|
+++ b/include/linux/mm.h
|
||||||
@@ -711,6 +711,7 @@ static inline int shmem_lock(struct file
|
@@ -712,6 +712,7 @@ static inline int shmem_lock(struct file
|
||||||
#endif
|
#endif
|
||||||
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
||||||
|
|
||||||
|
@ -8,4 +8,3 @@
|
|||||||
|
|
||||||
ifeq ($(CONFIG_TUNE_CELL),y)
|
ifeq ($(CONFIG_TUNE_CELL),y)
|
||||||
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
||||||
|
|
||||||
|
@ -3,7 +3,7 @@ they still want to support gcc 3.3 -- well, we don't.
|
|||||||
|
|
||||||
--- a/arch/powerpc/Makefile
|
--- a/arch/powerpc/Makefile
|
||||||
+++ b/arch/powerpc/Makefile
|
+++ b/arch/powerpc/Makefile
|
||||||
@@ -130,7 +130,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
@@ -129,7 +129,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
||||||
KBUILD_CFLAGS += -mno-sched-epilog
|
KBUILD_CFLAGS += -mno-sched-epilog
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
@ -8,4 +8,3 @@
|
|||||||
|
|
||||||
ifeq ($(CONFIG_TUNE_CELL),y)
|
ifeq ($(CONFIG_TUNE_CELL),y)
|
||||||
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- linux-2.6.37.6.org/Makefile 2012-03-28 17:10:58.297558774 +0200
|
--- a/Makefile
|
||||||
+++ linux-2.6.37.6.mod/Makefile 2012-03-28 17:15:00.161564521 +0200
|
+++ b/Makefile
|
||||||
@@ -354,7 +354,8 @@
|
@@ -354,7 +354,8 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstric
|
||||||
-fno-strict-aliasing -fno-common \
|
-fno-strict-aliasing -fno-common \
|
||||||
-Werror-implicit-function-declaration \
|
-Werror-implicit-function-declaration \
|
||||||
-Wno-format-security \
|
-Wno-format-security \
|
||||||
|
@ -8,4 +8,3 @@
|
|||||||
|
|
||||||
ifeq ($(CONFIG_TUNE_CELL),y)
|
ifeq ($(CONFIG_TUNE_CELL),y)
|
||||||
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
KBUILD_CFLAGS += $(call cc-option,-mtune=cell)
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user