mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:14:05 +02:00
[package] busybox: fix hexdump segmentation fault with an empty leading format unit
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29156 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ccd11de0ba
commit
23bd1bd8c7
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=busybox
|
PKG_NAME:=busybox
|
||||||
PKG_VERSION:=1.19.3
|
PKG_VERSION:=1.19.3
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
PKG_FLAGS:=essential
|
PKG_FLAGS:=essential
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
@ -72,6 +72,8 @@ ifdef CONFIG_BUSYBOX_USE_LIBRPC
|
|||||||
LDLIBS += rpc
|
LDLIBS += rpc
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -ggdb3
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||||
CC="$(TARGET_CC)" \
|
CC="$(TARGET_CC)" \
|
||||||
|
11
package/busybox/patches/700-hexdump_segfault_fix.patch
Normal file
11
package/busybox/patches/700-hexdump_segfault_fix.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/libbb/dump.c
|
||||||
|
+++ b/libbb/dump.c
|
||||||
|
@@ -301,7 +301,7 @@ static NOINLINE void rewrite(priv_dumper
|
||||||
|
) {
|
||||||
|
fu->reps += (dumper->blocksize - fs->bcnt) / fu->bcnt;
|
||||||
|
}
|
||||||
|
- if (fu->reps > 1) {
|
||||||
|
+ if (fu->reps > 1 && fu->nextpr) {
|
||||||
|
for (pr = fu->nextpr;; pr = pr->nextpr)
|
||||||
|
if (!pr->nextpr)
|
||||||
|
break;
|
Loading…
Reference in New Issue
Block a user