mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 12:33:08 +02:00
add missing stuff for lzma bootloader
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@522 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
49f94a1bb2
commit
24f1812847
6
openwrt/package/loader/Config.in
Normal file
6
openwrt/package/loader/Config.in
Normal file
@ -0,0 +1,6 @@
|
|||||||
|
config BR2_PACKAGE_LOADER
|
||||||
|
bool "LZMA compressed kernel loader"
|
||||||
|
default y
|
||||||
|
help
|
||||||
|
LZMA compressed kernel loader (saves much space in the flash)
|
||||||
|
|
39
openwrt/package/loader/Makefile
Normal file
39
openwrt/package/loader/Makefile
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME := loader
|
||||||
|
PKG_VERSION := 0.03
|
||||||
|
PKG_MD5SUM := 2681e6db8e0fe6095f6a90ad9b3f2d33
|
||||||
|
|
||||||
|
PKG_SOURCE_SITE := http://wl500g.dyndns.org/loader/
|
||||||
|
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_CAT := zcat
|
||||||
|
PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
|
||||||
|
|
||||||
|
$(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||||
|
mkdir -p $(DL_DIR)
|
||||||
|
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||||
|
mkdir -p $(TOOL_BUILD_DIR)
|
||||||
|
$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||||
|
$(PATCH) $(PKG_BUILD_DIR) ./patches
|
||||||
|
touch $(PKG_BUILD_DIR)/.patched
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/loader.gz: $(PKG_BUILD_DIR)/.patched
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) CC=$(TARGET_CC) \
|
||||||
|
LD=$(TARGET_CROSS)ld CROSS_COMPILE=$(TARGET_CROSS)
|
||||||
|
|
||||||
|
$(BUILD_DIR)/lzmaldr: $(PKG_BUILD_DIR)/loader.gz
|
||||||
|
cp $< $@
|
||||||
|
|
||||||
|
source: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||||
|
prepare: $(PKG_BUILD_DIR)/.patched
|
||||||
|
compile: $(BUILD_DIR)/lzmaldr
|
||||||
|
install:
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -rf $(PKG_BUILD_DIR)
|
||||||
|
rm -f $(BUILD_DIR)/lzmaldr
|
12
openwrt/package/loader/patches/toolchain.patch
Normal file
12
openwrt/package/loader/patches/toolchain.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- loader-0.03/Makefile 2005-03-28 22:15:24.569677129 +0400
|
||||||
|
+++ loader/Makefile 2005-03-28 22:16:42.339989214 +0400
|
||||||
|
@@ -24,7 +24,8 @@
|
||||||
|
|
||||||
|
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
|
||||||
|
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
|
||||||
|
- -ffunction-sections -pipe -mcpu=r4600 -mips2 -Wa,--trap -m4710a0kern
|
||||||
|
+ -ffunction-sections -pipe -mlong-calls -fno-common \
|
||||||
|
+ -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
|
||||||
|
CFLAGS += -DLOADADDR=$(TEXT_START) -D_LZMA_IN_CB
|
||||||
|
|
||||||
|
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DBZ_TEXT_START=$(BZ_TEXT_START)
|
51
openwrt/target/lzma/Makefile
Normal file
51
openwrt/target/lzma/Makefile
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
#############################################################
|
||||||
|
#
|
||||||
|
# lzma target
|
||||||
|
#
|
||||||
|
#############################################################
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
LZMA_DIR=$(BUILD_DIR)/lzma
|
||||||
|
LZMA_SOURCE=lzma406.zip
|
||||||
|
LZMA_SITE=http://www.7-zip.org/dl
|
||||||
|
|
||||||
|
LZMA_LIB_DIR=$(LZMA_DIR)/SRC/7zip/Compress/LZMA_Lib
|
||||||
|
LZMA_ALONE_DIR=$(LZMA_DIR)/SRC/7zip/Compress/LZMA_Alone
|
||||||
|
|
||||||
|
TARGETS=$(LZMA_LIB_DIR)/liblzma.a $(LZMA_ALONE_DIR)/lzma
|
||||||
|
|
||||||
|
$(DL_DIR)/$(LZMA_SOURCE):
|
||||||
|
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(LZMA_SOURCE) x $(LZMA_SITE)
|
||||||
|
|
||||||
|
$(LZMA_DIR)/.unpacked: $(DL_DIR)/$(LZMA_SOURCE)
|
||||||
|
@rm -rf $(LZMA_DIR) && mkdir -p $(LZMA_DIR)
|
||||||
|
unzip -q $^ -d $(LZMA_DIR)
|
||||||
|
patch -d $(LZMA_DIR) -p1 < lzma-406-zlib-stream.patch
|
||||||
|
touch $(LZMA_DIR)/.unpacked
|
||||||
|
|
||||||
|
$(LZMA_LIB_DIR)/liblzma.a: $(LZMA_DIR)/.unpacked
|
||||||
|
$(MAKE) -C $(LZMA_LIB_DIR)
|
||||||
|
|
||||||
|
$(LZMA_ALONE_DIR)/lzma: $(LZMA_DIR)/.unpacked
|
||||||
|
$(MAKE) -C $(LZMA_ALONE_DIR)
|
||||||
|
|
||||||
|
lzma: $(TARGETS)
|
||||||
|
cp -f $^ $(LZMA_DIR)
|
||||||
|
|
||||||
|
lzma-source: $(DL_DIR)/$(LZMA_SOURCE)
|
||||||
|
|
||||||
|
lzma-clean:
|
||||||
|
-$(MAKE) -C $(LZMA_LIB_DIR) clean
|
||||||
|
-$(MAKE) -C $(LZMA_ALONE_DIR) clean
|
||||||
|
rm -f $(LZMA_DIR)/liblzma.a $(LZMA_DIR)/lzma
|
||||||
|
|
||||||
|
lzma-dirclean:
|
||||||
|
rm -rf $(LZMA_DIR)
|
||||||
|
|
||||||
|
#############################################################
|
||||||
|
|
||||||
|
prepare: $(LZMA_DIR)/.unpacked
|
||||||
|
compile: lzma
|
||||||
|
install: lzma
|
||||||
|
clean: lzma-dirclean
|
405
openwrt/target/lzma/lzma-406-zlib-stream.patch
Normal file
405
openwrt/target/lzma/lzma-406-zlib-stream.patch
Normal file
@ -0,0 +1,405 @@
|
|||||||
|
diff -BurN lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.cpp lzma/SRC/7zip/Compress/LZMA/LZMADecoder.cpp
|
||||||
|
--- lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.cpp 2004-08-25 01:40:48.000000000 +0400
|
||||||
|
+++ lzma/SRC/7zip/Compress/LZMA/LZMADecoder.cpp 2005-01-20 14:47:45.789801629 +0300
|
||||||
|
@@ -288,12 +288,17 @@
|
||||||
|
Byte remainder = (Byte)(properties[0] / 9);
|
||||||
|
int lp = remainder % 5;
|
||||||
|
int pb = remainder / 5;
|
||||||
|
- if (pb > NLength::kNumPosStatesBitsMax)
|
||||||
|
- return E_INVALIDARG;
|
||||||
|
- _posStateMask = (1 << pb) - 1;
|
||||||
|
UInt32 dictionarySize = 0;
|
||||||
|
for (int i = 0; i < 4; i++)
|
||||||
|
dictionarySize += ((UInt32)(properties[1 + i])) << (i * 8);
|
||||||
|
+ return SetDecoderPropertiesRaw(lc, lp, pb, dictionarySize);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+STDMETHODIMP CDecoder::SetDecoderPropertiesRaw(int lc, int lp, int pb, UInt32 dictionarySize)
|
||||||
|
+{
|
||||||
|
+ if (pb > NLength::kNumPosStatesBitsMax)
|
||||||
|
+ return E_INVALIDARG;
|
||||||
|
+ _posStateMask = (1 << pb) - 1;
|
||||||
|
_dictionarySizeCheck = MyMax(dictionarySize, UInt32(1));
|
||||||
|
UInt32 blockSize = MyMax(_dictionarySizeCheck, UInt32(1 << 12));
|
||||||
|
if (!_outWindowStream.Create(blockSize))
|
||||||
|
diff -BurN lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.h lzma/SRC/7zip/Compress/LZMA/LZMADecoder.h
|
||||||
|
--- lzma406/SRC/7zip/Compress/LZMA/LZMADecoder.h 2004-08-25 01:40:08.000000000 +0400
|
||||||
|
+++ lzma/SRC/7zip/Compress/LZMA/LZMADecoder.h 2005-01-20 13:06:59.081297916 +0300
|
||||||
|
@@ -234,6 +234,8 @@
|
||||||
|
STDMETHOD(Read)(void *data, UInt32 size, UInt32 *processedSize);
|
||||||
|
STDMETHOD(ReadPart)(void *data, UInt32 size, UInt32 *processedSize);
|
||||||
|
|
||||||
|
+ STDMETHOD(SetDecoderPropertiesRaw)(int lc, int lp, int pb, UInt32 dictionarySize);
|
||||||
|
+
|
||||||
|
virtual ~CDecoder() {}
|
||||||
|
};
|
||||||
|
|
||||||
|
diff -BurN lzma406/SRC/7zip/Compress/LZMA_Lib/makefile lzma/SRC/7zip/Compress/LZMA_Lib/makefile
|
||||||
|
--- lzma406/SRC/7zip/Compress/LZMA_Lib/makefile 1970-01-01 03:00:00.000000000 +0300
|
||||||
|
+++ lzma/SRC/7zip/Compress/LZMA_Lib/makefile 2005-01-19 13:49:20.000000000 +0300
|
||||||
|
@@ -0,0 +1,88 @@
|
||||||
|
+PROG = liblzma.a
|
||||||
|
+CXX = g++ -O3 -Wall
|
||||||
|
+AR = ar
|
||||||
|
+RM = rm -f
|
||||||
|
+CFLAGS = -c
|
||||||
|
+
|
||||||
|
+OBJS = \
|
||||||
|
+ ZLib.o \
|
||||||
|
+ LZMADecoder.o \
|
||||||
|
+ LZMAEncoder.o \
|
||||||
|
+ LZInWindow.o \
|
||||||
|
+ LZOutWindow.o \
|
||||||
|
+ RangeCoderBit.o \
|
||||||
|
+ InBuffer.o \
|
||||||
|
+ OutBuffer.o \
|
||||||
|
+ FileStreams.o \
|
||||||
|
+ Alloc.o \
|
||||||
|
+ C_FileIO.o \
|
||||||
|
+ CommandLineParser.o \
|
||||||
|
+ CRC.o \
|
||||||
|
+ String.o \
|
||||||
|
+ StringConvert.o \
|
||||||
|
+ StringToInt.o \
|
||||||
|
+ Vector.o \
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+all: $(PROG)
|
||||||
|
+
|
||||||
|
+$(PROG): $(OBJS)
|
||||||
|
+ $(AR) r $(PROG) $(OBJS)
|
||||||
|
+
|
||||||
|
+ZLib.o: ZLib.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ZLib.cpp
|
||||||
|
+
|
||||||
|
+LZMADecoder.o: ../LZMA/LZMADecoder.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../LZMA/LZMADecoder.cpp
|
||||||
|
+
|
||||||
|
+LZMAEncoder.o: ../LZMA/LZMAEncoder.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../LZMA/LZMAEncoder.cpp
|
||||||
|
+
|
||||||
|
+LZInWindow.o: ../LZ/LZInWindow.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../LZ/LZInWindow.cpp
|
||||||
|
+
|
||||||
|
+LZOutWindow.o: ../LZ/LZOutWindow.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../LZ/LZOutWindow.cpp
|
||||||
|
+
|
||||||
|
+RangeCoderBit.o: ../RangeCoder/RangeCoderBit.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../RangeCoder/RangeCoderBit.cpp
|
||||||
|
+
|
||||||
|
+InBuffer.o: ../../Common/InBuffer.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../Common/InBuffer.cpp
|
||||||
|
+
|
||||||
|
+OutBuffer.o: ../../Common/OutBuffer.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../Common/OutBuffer.cpp
|
||||||
|
+
|
||||||
|
+FileStreams.o: ../../Common/FileStreams.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../Common/FileStreams.cpp
|
||||||
|
+
|
||||||
|
+Alloc.o: ../../../Common/Alloc.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/Alloc.cpp
|
||||||
|
+
|
||||||
|
+C_FileIO.o: ../../../Common/C_FileIO.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/C_FileIO.cpp
|
||||||
|
+
|
||||||
|
+CommandLineParser.o: ../../../Common/CommandLineParser.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/CommandLineParser.cpp
|
||||||
|
+
|
||||||
|
+CRC.o: ../../../Common/CRC.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/CRC.cpp
|
||||||
|
+
|
||||||
|
+MyWindows.o: ../../../Common/MyWindows.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/MyWindows.cpp
|
||||||
|
+
|
||||||
|
+String.o: ../../../Common/String.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/String.cpp
|
||||||
|
+
|
||||||
|
+StringConvert.o: ../../../Common/StringConvert.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/StringConvert.cpp
|
||||||
|
+
|
||||||
|
+StringToInt.o: ../../../Common/StringToInt.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/StringToInt.cpp
|
||||||
|
+
|
||||||
|
+Vector.o: ../../../Common/Vector.cpp
|
||||||
|
+ $(CXX) $(CFLAGS) ../../../Common/Vector.cpp
|
||||||
|
+
|
||||||
|
+clean:
|
||||||
|
+ -$(RM) $(PROG) $(OBJS)
|
||||||
|
+
|
||||||
|
diff -BurN lzma406/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp lzma/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp
|
||||||
|
--- lzma406/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp 1970-01-01 03:00:00.000000000 +0300
|
||||||
|
+++ lzma/SRC/7zip/Compress/LZMA_Lib/ZLib.cpp 2005-01-20 15:01:18.439221129 +0300
|
||||||
|
@@ -0,0 +1,273 @@
|
||||||
|
+/*
|
||||||
|
+ * lzma zlib simplified wrapper
|
||||||
|
+ *
|
||||||
|
+ * Copyright (c) 2005 Oleg I. Vdovikin <oleg@cs.msu.su>
|
||||||
|
+ *
|
||||||
|
+ * This library is free software; you can redistribute
|
||||||
|
+ * it and/or modify it under the terms of the GNU Lesser
|
||||||
|
+ * General Public License as published by the Free Software
|
||||||
|
+ * Foundation; either version 2.1 of the License, or
|
||||||
|
+ * (at your option) any later version.
|
||||||
|
+ *
|
||||||
|
+ * This library is distributed in the hope that it will be
|
||||||
|
+ * useful, but WITHOUT ANY WARRANTY; without even the implied
|
||||||
|
+ * warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
|
||||||
|
+ * PURPOSE. See the GNU Lesser General Public License
|
||||||
|
+ * for more details.
|
||||||
|
+ *
|
||||||
|
+ * You should have received a copy of the GNU Lesser General
|
||||||
|
+ * Public License along with this library; if not, write to
|
||||||
|
+ * the Free Software Foundation, Inc., 59 Temple Place,
|
||||||
|
+ * Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * default values for encoder/decoder used by wrapper
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include <zlib.h>
|
||||||
|
+
|
||||||
|
+#define ZLIB_LC 3
|
||||||
|
+#define ZLIB_LP 0
|
||||||
|
+#define ZLIB_PB 2
|
||||||
|
+
|
||||||
|
+#ifdef WIN32
|
||||||
|
+#include <initguid.h>
|
||||||
|
+#else
|
||||||
|
+#define INITGUID
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#include "../../../Common/MyWindows.h"
|
||||||
|
+#include "../LZMA/LZMADecoder.h"
|
||||||
|
+#include "../LZMA/LZMAEncoder.h"
|
||||||
|
+
|
||||||
|
+#define STG_E_SEEKERROR ((HRESULT)0x80030019L)
|
||||||
|
+#define STG_E_MEDIUMFULL ((HRESULT)0x80030070L)
|
||||||
|
+
|
||||||
|
+class CInMemoryStream:
|
||||||
|
+ public IInStream,
|
||||||
|
+ public IStreamGetSize,
|
||||||
|
+ public CMyUnknownImp
|
||||||
|
+{
|
||||||
|
+public:
|
||||||
|
+ CInMemoryStream(const Bytef *data, UInt64 size) :
|
||||||
|
+ m_data(data), m_size(size), m_offset(0) {}
|
||||||
|
+
|
||||||
|
+ virtual ~CInMemoryStream() {}
|
||||||
|
+
|
||||||
|
+ MY_UNKNOWN_IMP2(IInStream, IStreamGetSize)
|
||||||
|
+
|
||||||
|
+ STDMETHOD(Read)(void *data, UInt32 size, UInt32 *processedSize)
|
||||||
|
+ {
|
||||||
|
+ if (size > m_size - m_offset)
|
||||||
|
+ size = m_size - m_offset;
|
||||||
|
+
|
||||||
|
+ if (size) {
|
||||||
|
+ memcpy(data, m_data + m_offset, size);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ m_offset += size;
|
||||||
|
+
|
||||||
|
+ if (processedSize)
|
||||||
|
+ *processedSize = size;
|
||||||
|
+
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(ReadPart)(void *data, UInt32 size, UInt32 *processedSize)
|
||||||
|
+ {
|
||||||
|
+ return Read(data, size, processedSize);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(Seek)(Int64 offset, UInt32 seekOrigin, UInt64 *newPosition)
|
||||||
|
+ {
|
||||||
|
+ UInt64 _offset;
|
||||||
|
+
|
||||||
|
+ if (seekOrigin == STREAM_SEEK_SET) _offset = offset;
|
||||||
|
+ else if (seekOrigin == STREAM_SEEK_CUR) _offset = m_offset + offset;
|
||||||
|
+ else if (seekOrigin == STREAM_SEEK_END) _offset = m_size;
|
||||||
|
+ else return STG_E_INVALIDFUNCTION;
|
||||||
|
+
|
||||||
|
+ if (_offset < 0 || _offset > m_size)
|
||||||
|
+ return STG_E_SEEKERROR;
|
||||||
|
+
|
||||||
|
+ m_offset = _offset;
|
||||||
|
+
|
||||||
|
+ if (newPosition)
|
||||||
|
+ *newPosition = m_offset;
|
||||||
|
+
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(GetSize)(UInt64 *size)
|
||||||
|
+ {
|
||||||
|
+ *size = m_size;
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+protected:
|
||||||
|
+ const Bytef *m_data;
|
||||||
|
+ UInt64 m_size;
|
||||||
|
+ UInt64 m_offset;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+class COutMemoryStream:
|
||||||
|
+ public IOutStream,
|
||||||
|
+ public CMyUnknownImp
|
||||||
|
+{
|
||||||
|
+public:
|
||||||
|
+ COutMemoryStream(Bytef *data, UInt64 maxsize) :
|
||||||
|
+ m_data(data), m_size(0), m_maxsize(maxsize), m_offset(0) {}
|
||||||
|
+ virtual ~COutMemoryStream() {}
|
||||||
|
+
|
||||||
|
+ MY_UNKNOWN_IMP1(IOutStream)
|
||||||
|
+
|
||||||
|
+ STDMETHOD(Write)(const void *data, UInt32 size, UInt32 *processedSize)
|
||||||
|
+ {
|
||||||
|
+ if (size > m_maxsize - m_offset)
|
||||||
|
+ size = m_maxsize - m_offset;
|
||||||
|
+
|
||||||
|
+ if (size) {
|
||||||
|
+ memcpy(m_data + m_offset, data, size);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ m_offset += size;
|
||||||
|
+
|
||||||
|
+ if (m_offset > m_size)
|
||||||
|
+ m_size = m_offset;
|
||||||
|
+
|
||||||
|
+ if (processedSize)
|
||||||
|
+ *processedSize = size;
|
||||||
|
+
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(WritePart)(const void *data, UInt32 size, UInt32 *processedSize)
|
||||||
|
+ {
|
||||||
|
+ return Write(data, size, processedSize);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(Seek)(Int64 offset, UInt32 seekOrigin, UInt64 *newPosition)
|
||||||
|
+ {
|
||||||
|
+ UInt64 _offset;
|
||||||
|
+
|
||||||
|
+ if (seekOrigin == STREAM_SEEK_SET) _offset = offset;
|
||||||
|
+ else if (seekOrigin == STREAM_SEEK_CUR) _offset = m_offset + offset;
|
||||||
|
+ else if (seekOrigin == STREAM_SEEK_END) _offset = m_size;
|
||||||
|
+ else return STG_E_INVALIDFUNCTION;
|
||||||
|
+
|
||||||
|
+ if (_offset < 0 || _offset > m_maxsize)
|
||||||
|
+ return STG_E_SEEKERROR;
|
||||||
|
+
|
||||||
|
+ m_offset = _offset;
|
||||||
|
+
|
||||||
|
+ if (newPosition)
|
||||||
|
+ *newPosition = m_offset;
|
||||||
|
+
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ STDMETHOD(SetSize)(Int64 newSize)
|
||||||
|
+ {
|
||||||
|
+ if ((UInt64)newSize > m_maxsize)
|
||||||
|
+ return STG_E_MEDIUMFULL;
|
||||||
|
+
|
||||||
|
+ return S_OK;
|
||||||
|
+ }
|
||||||
|
+protected:
|
||||||
|
+ Bytef *m_data;
|
||||||
|
+ UInt64 m_size;
|
||||||
|
+ UInt64 m_maxsize;
|
||||||
|
+ UInt64 m_offset;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+ZEXTERN int ZEXPORT compress2 OF((Bytef *dest, uLongf *destLen,
|
||||||
|
+ const Bytef *source, uLong sourceLen,
|
||||||
|
+ int level))
|
||||||
|
+{
|
||||||
|
+ CInMemoryStream *inStreamSpec = new CInMemoryStream(source, sourceLen);
|
||||||
|
+ CMyComPtr<ISequentialInStream> inStream = inStreamSpec;
|
||||||
|
+
|
||||||
|
+ COutMemoryStream *outStreamSpec = new COutMemoryStream(dest, *destLen);
|
||||||
|
+ CMyComPtr<ISequentialOutStream> outStream = outStreamSpec;
|
||||||
|
+
|
||||||
|
+ NCompress::NLZMA::CEncoder *encoderSpec =
|
||||||
|
+ new NCompress::NLZMA::CEncoder;
|
||||||
|
+ CMyComPtr<ICompressCoder> encoder = encoderSpec;
|
||||||
|
+
|
||||||
|
+ PROPID propIDs[] =
|
||||||
|
+ {
|
||||||
|
+ NCoderPropID::kDictionarySize,
|
||||||
|
+ NCoderPropID::kPosStateBits,
|
||||||
|
+ NCoderPropID::kLitContextBits,
|
||||||
|
+ NCoderPropID::kLitPosBits,
|
||||||
|
+ NCoderPropID::kAlgorithm,
|
||||||
|
+ NCoderPropID::kNumFastBytes,
|
||||||
|
+ NCoderPropID::kMatchFinder,
|
||||||
|
+ NCoderPropID::kEndMarker
|
||||||
|
+ };
|
||||||
|
+ const int kNumProps = sizeof(propIDs) / sizeof(propIDs[0]);
|
||||||
|
+
|
||||||
|
+ PROPVARIANT properties[kNumProps];
|
||||||
|
+ for (int p = 0; p < 6; p++)
|
||||||
|
+ properties[p].vt = VT_UI4;
|
||||||
|
+ properties[0].ulVal = UInt32(1 << (level + 14));
|
||||||
|
+ properties[1].ulVal = UInt32(ZLIB_PB);
|
||||||
|
+ properties[2].ulVal = UInt32(ZLIB_LC); // for normal files
|
||||||
|
+ properties[3].ulVal = UInt32(ZLIB_LP); // for normal files
|
||||||
|
+ properties[4].ulVal = UInt32(2);
|
||||||
|
+ properties[5].ulVal = UInt32(128);
|
||||||
|
+
|
||||||
|
+ properties[6].vt = VT_BSTR;
|
||||||
|
+ properties[6].bstrVal = (BSTR)(const wchar_t *)L"BT4";
|
||||||
|
+
|
||||||
|
+ properties[7].vt = VT_BOOL;
|
||||||
|
+ properties[7].boolVal = VARIANT_TRUE;
|
||||||
|
+
|
||||||
|
+ if (encoderSpec->SetCoderProperties(propIDs, properties, kNumProps) != S_OK)
|
||||||
|
+ return Z_MEM_ERROR; // should not happen
|
||||||
|
+
|
||||||
|
+ HRESULT result = encoder->Code(inStream, outStream, 0, 0, 0);
|
||||||
|
+ if (result == E_OUTOFMEMORY)
|
||||||
|
+ {
|
||||||
|
+ return Z_MEM_ERROR;
|
||||||
|
+ }
|
||||||
|
+ else if (result != S_OK)
|
||||||
|
+ {
|
||||||
|
+ return Z_BUF_ERROR; // should not happen
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ UInt64 fileSize;
|
||||||
|
+ outStreamSpec->Seek(0, STREAM_SEEK_END, &fileSize);
|
||||||
|
+ *destLen = fileSize;
|
||||||
|
+
|
||||||
|
+ return Z_OK;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+ZEXTERN int ZEXPORT uncompress OF((Bytef *dest, uLongf *destLen,
|
||||||
|
+ const Bytef *source, uLong sourceLen))
|
||||||
|
+{
|
||||||
|
+ CInMemoryStream *inStreamSpec = new CInMemoryStream(source, sourceLen);
|
||||||
|
+ CMyComPtr<ISequentialInStream> inStream = inStreamSpec;
|
||||||
|
+
|
||||||
|
+ COutMemoryStream *outStreamSpec = new COutMemoryStream(dest, *destLen);
|
||||||
|
+ CMyComPtr<ISequentialOutStream> outStream = outStreamSpec;
|
||||||
|
+
|
||||||
|
+ NCompress::NLZMA::CDecoder *decoderSpec =
|
||||||
|
+ new NCompress::NLZMA::CDecoder;
|
||||||
|
+ CMyComPtr<ICompressCoder> decoder = decoderSpec;
|
||||||
|
+
|
||||||
|
+ if (decoderSpec->SetDecoderPropertiesRaw(ZLIB_LC,
|
||||||
|
+ ZLIB_LP, ZLIB_PB, (1 << 23)) != S_OK) return Z_DATA_ERROR;
|
||||||
|
+
|
||||||
|
+ UInt64 fileSize = *destLen;
|
||||||
|
+
|
||||||
|
+ if (decoder->Code(inStream, outStream, 0, &fileSize, 0) != S_OK)
|
||||||
|
+ {
|
||||||
|
+ return Z_DATA_ERROR;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ outStreamSpec->Seek(0, STREAM_SEEK_END, &fileSize);
|
||||||
|
+ *destLen = fileSize;
|
||||||
|
+
|
||||||
|
+ return Z_OK;
|
||||||
|
+}
|
Loading…
Reference in New Issue
Block a user