mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:14:05 +02:00
fix gdb compile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14015 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2c3b9b3e1c
commit
24f85d414b
@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
gdb_cv_func_sigsetjmp=yes \
|
||||
CFLAGS="-O2" \
|
||||
$(PKG_BUILD_DIR)/configure \
|
||||
--prefix=$(TOOLCHAIN_DIR)/usr \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
@ -48,8 +49,8 @@ endef
|
||||
|
||||
define Build/Clean
|
||||
rm -rf \
|
||||
$(PKG_BUILD_DIR)
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb
|
||||
$(PKG_BUILD_DIR) \
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb \
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
|
||||
endef
|
||||
|
||||
|
11
toolchain/gdb/patches/910-missing_header.patch
Normal file
11
toolchain/gdb/patches/910-missing_header.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/gdb/inferior.h
|
||||
+++ b/gdb/inferior.h
|
||||
@@ -21,6 +21,8 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
Boston, MA 02111-1307, USA. */
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#if !defined (INFERIOR_H)
|
||||
#define INFERIOR_H 1
|
||||
|
Loading…
Reference in New Issue
Block a user