1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-25 06:36:15 +02:00

fix the kernel compile error in openwrt

the patch folder is not correct
This commit is contained in:
Xiangfu Liu 2009-09-05 01:07:56 +08:00 committed by Xiangfu Liu
parent 1976b23d08
commit 281d29e9b7
5 changed files with 44 additions and 104 deletions

View File

@ -16,7 +16,6 @@ obj-$(CONFIG_JZ4740_LEO) += board-leo.o
obj-$(CONFIG_JZ4740_LYRA) += board-lyra.o obj-$(CONFIG_JZ4740_LYRA) += board-lyra.o
obj-$(CONFIG_JZ4725_DIPPER) += board-dipper.o obj-$(CONFIG_JZ4725_DIPPER) += board-dipper.o
obj-$(CONFIG_JZ4720_VIRGO) += board-virgo.o obj-$(CONFIG_JZ4720_VIRGO) += board-virgo.o
obj-$(CONFIG_JZ4740_QI_LB60) += board-qi_lb60.o
# PM support # PM support

View File

@ -1,27 +1,3 @@
From 3558f77fbc178030cf2991dddd678847a35ef98e Mon Sep 17 00:00:00 2001
From: Xiangfu Liu <xiangfu.z@gmail.com>
Date: Thu, 20 Aug 2009 18:35:54 +0800
Subject: [PATCH] nand
---
arch/mips/jz4740/platform.c | 1 +
drivers/mtd/nand/Kconfig | 6 ++++++
drivers/mtd/nand/Makefile | 1 +
drivers/mtd/nand/nand_base.c | 19 +++++++------------
4 files changed, 15 insertions(+), 12 deletions(-)
diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c
index a02aec1..bac37ee 100644
--- a/arch/mips/jz4740/platform.c
+++ b/arch/mips/jz4740/platform.c
@@ -15,6 +15,7 @@
#include <linux/resource.h>
#include <linux/mtd/jz4740_nand.h>
#include <linux/input/matrix_keypad.h>
+#include <linux/mtd/jz4740_nand.h>
#include <asm/jzsoc.h>
diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
index ce96c09..818bce0 100644 index ce96c09..818bce0 100644
--- a/drivers/mtd/nand/Kconfig --- a/drivers/mtd/nand/Kconfig
@ -96,6 +72,3 @@ index 8c21b89..1749f31 100644
chip->cmdfunc(mtd, NAND_CMD_READ0, 0x00, page); chip->cmdfunc(mtd, NAND_CMD_READ0, 0x00, page);
sndcmd = 0; sndcmd = 0;
} }
--
1.6.0.4

View File

@ -1,16 +1,8 @@
--- /opt/Projects/linux-2.6/drivers/video/backlight/Makefile 2009-09-02 16:48:24.000000000 +0200 diff --git a/drivers/video/backlight/Kconfig b/drivers/video/backlight/Kconfig
+++ ./Makefile 2009-08-24 13:51:57.000000000 +0200 index f9d19be..4299648 100644
@@ -9,6 +9,7 @@ --- a/drivers/video/backlight/Kconfig
obj-$(CONFIG_LCD_VGG2432A4) += vgg2432a4.o +++ b/drivers/video/backlight/Kconfig
obj-$(CONFIG_LCD_TDO24M) += tdo24m.o @@ -93,6 +93,13 @@ config LCD_HP700
obj-$(CONFIG_LCD_TOSA) += tosa_lcd.o
+obj-$(CONFIG_LCD_GPM940B0) += gpm940b0.o
obj-$(CONFIG_BACKLIGHT_CLASS_DEVICE) += backlight.o
obj-$(CONFIG_BACKLIGHT_ATMEL_PWM) += atmel-pwm-bl.o
--- /opt/Projects/linux-2.6/drivers/video/backlight/Kconfig 2009-09-02 16:48:24.000000000 +0200
+++ ./Kconfig 2009-08-24 13:49:46.000000000 +0200
@@ -93,6 +93,13 @@
If you have an HP Jornada 700 series handheld (710/720/728) If you have an HP Jornada 700 series handheld (710/720/728)
say Y to enable LCD control driver. say Y to enable LCD control driver.
@ -24,3 +16,15 @@
# #
# Backlight # Backlight
# #
diff --git a/drivers/video/backlight/Makefile b/drivers/video/backlight/Makefile
index 4eb178c..c2fd42c 100644
--- a/drivers/video/backlight/Makefile
+++ b/drivers/video/backlight/Makefile
@@ -9,6 +9,7 @@ obj-$(CONFIG_LCD_PLATFORM) += platform_lcd.o
obj-$(CONFIG_LCD_VGG2432A4) += vgg2432a4.o
obj-$(CONFIG_LCD_TDO24M) += tdo24m.o
obj-$(CONFIG_LCD_TOSA) += tosa_lcd.o
+obj-$(CONFIG_LCD_GPM940B0) += gpm940b0.o
obj-$(CONFIG_BACKLIGHT_CLASS_DEVICE) += backlight.o
obj-$(CONFIG_BACKLIGHT_ATMEL_PWM) += atmel-pwm-bl.o

View File

@ -1,16 +1,17 @@
diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c diff --git a/arch/mips/jz4740/platform.c b/arch/mips/jz4740/platform.c
index 6a129e7..b870583 100644 index 62409ed..c435df5 100644
--- a/arch/mips/jz4740/platform.c --- a/arch/mips/jz4740/platform.c
+++ b/arch/mips/jz4740/platform.c +++ b/arch/mips/jz4740/platform.c
@@ -164,6 +164,7 @@ static struct resource jz_nand_resources[] = { @@ -167,6 +167,8 @@ static struct resource jz_nand_resources[] = {
}, },
}; };
+
+#ifdef QI_LB60_1GB_NAND +#ifdef QI_LB60_1GB_NAND
static struct nand_ecclayout qi_lb60_ecclayout = { static struct nand_ecclayout qi_lb60_ecclayout = {
.eccbytes = 36, .eccbytes = 36,
.eccpos = { .eccpos = {
@@ -180,29 +181,68 @@ static struct nand_ecclayout qi_lb60_ecclayout = { @@ -183,23 +185,62 @@ static struct nand_ecclayout qi_lb60_ecclayout = {
}; };
static struct mtd_partition qi_lb60_partitions[] = { static struct mtd_partition qi_lb60_partitions[] = {
@ -89,14 +90,7 @@ index 6a129e7..b870583 100644
static struct jz_nand_platform_data jz_nand_platform_data = { static struct jz_nand_platform_data jz_nand_platform_data = {
.num_partitions = ARRAY_SIZE(qi_lb60_partitions), .num_partitions = ARRAY_SIZE(qi_lb60_partitions),
.partitions = qi_lb60_partitions, @@ -216,7 +257,9 @@ static struct platform_device jz_nand_device = {
.ecc_layout = &qi_lb60_ecclayout,
- .busy_gpio = 94,
+ .busy_gpio = 94,
};
static struct platform_device jz_nand_device = {
@@ -213,7 +253,9 @@ static struct platform_device jz_nand_device = {
.platform_data = &jz_nand_platform_data, .platform_data = &jz_nand_platform_data,
} }
}; };
@ -107,55 +101,11 @@ index 6a129e7..b870583 100644
#define KEY_QI_QI KEY_F13 #define KEY_QI_QI KEY_F13
#define KEY_QI_UPRED KEY_F14 #define KEY_QI_UPRED KEY_F14
@@ -286,8 +328,8 @@ static const uint32_t qi_lb60_keymap[] = {
};
static const struct matrix_keymap_data qi_lb60_keymap_data = {
- .keymap = qi_lb60_keymap,
- .keymap_size = ARRAY_SIZE(qi_lb60_keymap),
+ .keymap = qi_lb60_keymap,
+ .keymap_size = ARRAY_SIZE(qi_lb60_keymap),
};
static const unsigned int qi_lb60_keypad_cols[] = {
@@ -297,12 +339,12 @@ static const unsigned int qi_lb60_keypad_cols[] = {
static const unsigned int qi_lb60_keypad_rows[] = {
114, 115, 116, 117, 118, 119, 120,
#ifndef KEEP_UART_ALIVE
- 122,
+ 122,
#endif
};
static struct matrix_keypad_platform_data qi_lb60_pdata = {
- .keymap_data = &qi_lb60_keymap_data,
+ .keymap_data = &qi_lb60_keymap_data,
.col_gpios = qi_lb60_keypad_cols,
.row_gpios = qi_lb60_keypad_rows,
.num_col_gpios = ARRAY_SIZE(qi_lb60_keypad_cols),
@@ -310,7 +352,7 @@ static struct matrix_keypad_platform_data qi_lb60_pdata = {
.col_scan_delay_us = 10,
.debounce_ms = 10,
.wakeup = 1,
- .active_low = 1,
+ .active_low = 1,
};
static struct platform_device qi_lb60_keypad = {
@@ -375,7 +417,7 @@ static struct platform_device *jz_platform_devices[] __initdata = {
&jz_mmc_device,
&jz_nand_device,
&jz_i2c_device,
- &qi_lb60_keypad,
+ &qi_lb60_keypad,
&qi_lb60_fb,
};
diff --git a/include/mtd/mtd-abi.h b/include/mtd/mtd-abi.h diff --git a/include/mtd/mtd-abi.h b/include/mtd/mtd-abi.h
index f86db5a..b19fffa 100644 index be51ae2..cf90168 100644
--- a/include/mtd/mtd-abi.h --- a/include/mtd/mtd-abi.h
+++ b/include/mtd/mtd-abi.h +++ b/include/mtd/mtd-abi.h
@@ -135,7 +135,7 @@ struct nand_oobfree { @@ -134,7 +134,7 @@ struct nand_oobfree {
*/ */
struct nand_ecclayout { struct nand_ecclayout {
__u32 eccbytes; __u32 eccbytes;

View File

@ -1,6 +1,17 @@
--- /opt/Projects/linux-2.6/drivers/spi/spi_gpio.c 2009-09-03 11:56:54.000000000 +0200 From 1f49cf395395acc36efd3b408b6d22b7d9aef831 Mon Sep 17 00:00:00 2001
+++ ./spi_gpio.c 2009-08-24 17:00:21.000000000 +0200 From: xiangfu <xiangfu@openmobilefree.net>
@@ -254,9 +254,11 @@ Date: Fri, 4 Sep 2009 11:43:18 -0400
Subject: [PATCH] 400-spi-gpio-3wire.patch
---
drivers/spi/spi_gpio.c | 14 +++++++++-----
1 files changed, 9 insertions(+), 5 deletions(-)
diff --git a/drivers/spi/spi_gpio.c b/drivers/spi/spi_gpio.c
index 26bd03e..5f89c21 100644
--- a/drivers/spi/spi_gpio.c
+++ b/drivers/spi/spi_gpio.c
@@ -243,9 +243,11 @@ spi_gpio_request(struct spi_gpio_platform_data *pdata, const char *label)
if (value) if (value)
goto done; goto done;
@ -15,7 +26,7 @@
value = spi_gpio_alloc(SPI_SCK_GPIO, label, false); value = spi_gpio_alloc(SPI_SCK_GPIO, label, false);
if (value) if (value)
@@ -319,7 +321,8 @@ @@ -308,7 +310,8 @@ static int __init spi_gpio_probe(struct platform_device *pdev)
if (status < 0) { if (status < 0) {
spi_master_put(spi_gpio->bitbang.master); spi_master_put(spi_gpio->bitbang.master);
gpio_free: gpio_free:
@ -25,7 +36,7 @@
gpio_free(SPI_MOSI_GPIO); gpio_free(SPI_MOSI_GPIO);
gpio_free(SPI_SCK_GPIO); gpio_free(SPI_SCK_GPIO);
spi_master_put(master); spi_master_put(master);
@@ -343,7 +346,8 @@ @@ -332,7 +335,8 @@ static int __exit spi_gpio_remove(struct platform_device *pdev)
platform_set_drvdata(pdev, NULL); platform_set_drvdata(pdev, NULL);
@ -35,3 +46,6 @@
gpio_free(SPI_MOSI_GPIO); gpio_free(SPI_MOSI_GPIO);
gpio_free(SPI_SCK_GPIO); gpio_free(SPI_SCK_GPIO);
--
1.5.6.3