mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-01-27 14:01:05 +02:00
upgrade to 2.6.24.5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10959 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
56de1b407c
commit
294a4bb95f
@ -22,8 +22,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),2.6.23.16)
|
ifeq ($(LINUX_VERSION),2.6.23.16)
|
||||||
LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
|
LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.24.2)
|
ifeq ($(LINUX_VERSION),2.6.24.5)
|
||||||
LINUX_KERNEL_MD5SUM:=dd573a2fae55624ed92fa49c17583964
|
LINUX_KERNEL_MD5SUM:=26500f8f92895bd33e391088b5edd4ad
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.25)
|
ifeq ($(LINUX_VERSION),2.6.25)
|
||||||
LINUX_KERNEL_MD5SUM:=db95a49a656a3247d4995a797d333153
|
LINUX_KERNEL_MD5SUM:=db95a49a656a3247d4995a797d333153
|
||||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
BOARD:=adm5120
|
BOARD:=adm5120
|
||||||
BOARDNAME:=Infineon ADM5120
|
BOARDNAME:=Infineon ADM5120
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
SUBTARGETS:=router_le router_be
|
SUBTARGETS:=router_le router_be
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=ar7
|
|||||||
BOARDNAME:=TI AR7
|
BOARDNAME:=TI AR7
|
||||||
FEATURES:=squashfs jffs2 atm
|
FEATURES:=squashfs jffs2 atm
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=au1000
|
|||||||
BOARDNAME:=AMD Alchemy AU1x00
|
BOARDNAME:=AMD Alchemy AU1x00
|
||||||
FEATURES:=jffs2 usb pci
|
FEATURES:=jffs2 usb pci
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += yamonenv
|
DEFAULT_PACKAGES += yamonenv
|
||||||
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||||||
BOARD:=avr32
|
BOARD:=avr32
|
||||||
BOARDNAME:=Atmel AVR32
|
BOARDNAME:=Atmel AVR32
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||||||
BOARD:=brcm63xx
|
BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM963xx
|
BOARDNAME:=Broadcom BCM963xx
|
||||||
FEATURES:=squashfs jffs2 broken usb atm
|
FEATURES:=squashfs jffs2 broken usb atm
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -49955,21 +49955,6 @@ diff -x .git -x .gitignore -Nur linux-2.6.24/arch/powerpc/platforms/chrp/pci.c p
|
|||||||
/* keep the reference to the root node */
|
/* keep the reference to the root node */
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -354,7 +354,7 @@
|
|
||||||
* mode as well. The same fixup must be done to the class-code property in
|
|
||||||
* the IDE node /pci@80000000/ide@C,1
|
|
||||||
*/
|
|
||||||
-static void __devinit chrp_pci_fixup_vt8231_ata(struct pci_dev *viaide)
|
|
||||||
+static void chrp_pci_fixup_vt8231_ata(struct pci_dev *viaide)
|
|
||||||
{
|
|
||||||
u8 progif;
|
|
||||||
struct pci_dev *viaisa;
|
|
||||||
@@ -375,4 +375,4 @@
|
|
||||||
|
|
||||||
pci_dev_put(viaisa);
|
|
||||||
}
|
|
||||||
-DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_VIA, PCI_DEVICE_ID_VIA_82C586_1, chrp_pci_fixup_vt8231_ata);
|
|
||||||
+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_VIA, PCI_DEVICE_ID_VIA_82C586_1, chrp_pci_fixup_vt8231_ata);
|
|
||||||
diff -x .git -x .gitignore -Nur linux-2.6.24/arch/powerpc/platforms/chrp/setup.c powerpc.git/arch/powerpc/platforms/chrp/setup.c
|
diff -x .git -x .gitignore -Nur linux-2.6.24/arch/powerpc/platforms/chrp/setup.c powerpc.git/arch/powerpc/platforms/chrp/setup.c
|
||||||
--- linux-2.6.24/arch/powerpc/platforms/chrp/setup.c 2008-01-24 23:58:37.000000000 +0100
|
--- linux-2.6.24/arch/powerpc/platforms/chrp/setup.c 2008-01-24 23:58:37.000000000 +0100
|
||||||
+++ powerpc.git/arch/powerpc/platforms/chrp/setup.c 2008-01-28 20:25:49.000000000 +0100
|
+++ powerpc.git/arch/powerpc/platforms/chrp/setup.c 2008-01-28 20:25:49.000000000 +0100
|
||||||
@ -64602,7 +64587,7 @@ diff -x .git -x .gitignore -Nur linux-2.6.24/drivers/macintosh/via-pmu.c powerpc
|
|||||||
EXPORT_SYMBOL(pmu_suspend);
|
EXPORT_SYMBOL(pmu_suspend);
|
||||||
EXPORT_SYMBOL(pmu_resume);
|
EXPORT_SYMBOL(pmu_resume);
|
||||||
EXPORT_SYMBOL(pmu_unlock);
|
EXPORT_SYMBOL(pmu_unlock);
|
||||||
-#if defined(CONFIG_PM_SLEEP) && defined(CONFIG_PPC32)
|
-#if defined(CONFIG_PPC32)
|
||||||
+#if defined(CONFIG_SUSPEND) && defined(CONFIG_PPC32)
|
+#if defined(CONFIG_SUSPEND) && defined(CONFIG_PPC32)
|
||||||
EXPORT_SYMBOL(pmu_enable_irled);
|
EXPORT_SYMBOL(pmu_enable_irled);
|
||||||
EXPORT_SYMBOL(pmu_battery_count);
|
EXPORT_SYMBOL(pmu_battery_count);
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=iop32x
|
|||||||
BOARDNAME:=Intel XScale IOP32x
|
BOARDNAME:=Intel XScale IOP32x
|
||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Intel XScale IXP4xx
|
|||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
SUBTARGETS=generic harddisk
|
SUBTARGETS=generic harddisk
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=magicbox
|
|||||||
BOARDNAME:=Magicbox
|
BOARDNAME:=Magicbox
|
||||||
FEATURES:=squashfs pci
|
FEATURES:=squashfs pci
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
LINUX_KARCH:=ppc
|
LINUX_KARCH:=ppc
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=ppc40x
|
|||||||
BOARDNAME:=AMCC Kilauea
|
BOARDNAME:=AMCC Kilauea
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
LINUX_KARCH:=powerpc
|
LINUX_KARCH:=powerpc
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=ppc44x
|
|||||||
BOARDNAME:=AMCC Taishan
|
BOARDNAME:=AMCC Taishan
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
LINUX_KARCH:=powerpc
|
LINUX_KARCH:=powerpc
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=rdc
|
|||||||
BOARDNAME:=RDC321x x86
|
BOARDNAME:=RDC321x x86
|
||||||
FEATURES:=squashfs jffs2 pci
|
FEATURES:=squashfs jffs2 pci
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=sibyte
|
|||||||
BOARDNAME:=Broadcom/SiByte SB-1
|
BOARDNAME:=Broadcom/SiByte SB-1
|
||||||
FEATURES:=broken
|
FEATURES:=broken
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||||||
FEATURES:=broken ext2
|
FEATURES:=broken ext2
|
||||||
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=x86
|
|||||||
FEATURES:=squashfs jffs2 ext2
|
FEATURES:=squashfs jffs2 ext2
|
||||||
SUBTARGETS=generic mediacenter
|
SUBTARGETS=generic mediacenter
|
||||||
|
|
||||||
LINUX_VERSION:=2.6.24.2
|
LINUX_VERSION:=2.6.24.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
|
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
|
||||||
|
Loading…
x
Reference in New Issue
Block a user