mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 15:47:11 +02:00
add ipkg/conffiles, add Id tag to the Makefile, standardize.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2738 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
887e582eee
commit
2a42f1add1
4
openwrt/package/ipcad/Config.in
Executable file → Normal file
4
openwrt/package/ipcad/Config.in
Executable file → Normal file
@ -1,5 +1,6 @@
|
|||||||
config BR2_PACKAGE_IPCAD
|
config BR2_PACKAGE_IPCAD
|
||||||
tristate "ipcad............................. listens for traffic on the specified interfaces"
|
prompt "ipcad............................. listens for traffic on the specified interfaces"
|
||||||
|
tristate
|
||||||
default m if CONFIG_DEVEL
|
default m if CONFIG_DEVEL
|
||||||
select BR2_PACKAGE_LIBPCAP
|
select BR2_PACKAGE_LIBPCAP
|
||||||
help
|
help
|
||||||
@ -8,3 +9,4 @@ config BR2_PACKAGE_IPCAD
|
|||||||
the accounting data the same way as Cisco routers do.
|
the accounting data the same way as Cisco routers do.
|
||||||
|
|
||||||
http://lionet.info/ipcad/
|
http://lionet.info/ipcad/
|
||||||
|
|
||||||
|
45
openwrt/package/ipcad/Makefile
Executable file → Normal file
45
openwrt/package/ipcad/Makefile
Executable file → Normal file
@ -1,14 +1,17 @@
|
|||||||
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=ipcad
|
PKG_NAME:=ipcad
|
||||||
PKG_VERSION:=3.7
|
PKG_VERSION:=3.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
|
PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@SF/ipcad
|
PKG_SOURCE_URL:=@SF/ipcad
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
@ -17,37 +20,51 @@ $(eval $(call PKG_template,IPCAD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
|
|||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
$(PKG_BUILD_DIR)/.configured:
|
||||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
|
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
|
||||||
|
touch cfglex.c cslex.c; \
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib" \
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
./configure \
|
./configure \
|
||||||
--target=$(GNU_TARGET_NAME) \
|
--target=$(GNU_TARGET_NAME) \
|
||||||
--host=$(GNU_TARGET_NAME) \
|
--host=$(GNU_TARGET_NAME) \
|
||||||
--build=$(GNU_HOST_NAME) \
|
--build=$(GNU_HOST_NAME) \
|
||||||
|
--program-prefix="" \
|
||||||
|
--program-suffix="" \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--exec-prefix=/usr \
|
--exec-prefix=/usr \
|
||||||
--bindir=/usr/bin \
|
--bindir=/usr/bin \
|
||||||
--sbindir=/usr/sbin \
|
|
||||||
--libexecdir=/usr/lib \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
--datadir=/usr/share \
|
--datadir=/usr/share \
|
||||||
|
--includedir=/usr/include \
|
||||||
|
--infodir=/usr/share/info \
|
||||||
|
--libdir=/usr/lib \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
--mandir=/usr/man \
|
--mandir=/usr/share/man \
|
||||||
--mandir=/usr/man \
|
--sbindir=/usr/sbin \
|
||||||
--infodir=/usr/info \
|
--sysconfdir=/etc \
|
||||||
--program-prefix="" \
|
$(DISABLE_LARGEFILE) \
|
||||||
|
$(DISABLE_NLS) \
|
||||||
|
--enable-shared \
|
||||||
|
--disable-static \
|
||||||
|
--disable-rpath \
|
||||||
--with-gnu-ld \
|
--with-gnu-ld \
|
||||||
--with-psrc=pcap \
|
--with-psrc=pcap \
|
||||||
--with-pcap-include=$(STAGING_DIR)/usr/include \
|
--with-pcap-include="$(STAGING_DIR)/usr/include" \
|
||||||
--with-pcap-libraries=$(STAGING_DIR)/usr/lib \
|
--with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
|
||||||
);
|
);
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
$(PKG_BUILD_DIR)/.built:
|
||||||
$(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
DESTDIR=$(PKG_INSTALL_DIR) \
|
||||||
|
all install
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(IPKG_IPCAD):
|
$(IPKG_IPCAD):
|
||||||
mkdir -p $(IDIR_IPCAD)
|
install -d -m0755 $(IDIR_IPCAD)/etc
|
||||||
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_IPCAD)/
|
cp -fpR $(PKG_INSTALL_DIR)/etc/ipcad.conf $(IDIR_IPCAD)/etc/
|
||||||
|
install -d -m0755 $(IDIR_IPCAD)/usr/bin
|
||||||
|
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/ipcad $(IDIR_IPCAD)/usr/bin/
|
||||||
$(RSTRIP) $(IDIR_IPCAD)
|
$(RSTRIP) $(IDIR_IPCAD)
|
||||||
$(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
|
||||||
|
1
openwrt/package/ipcad/ipkg/ipcad.conffiles
Normal file
1
openwrt/package/ipcad/ipkg/ipcad.conffiles
Normal file
@ -0,0 +1 @@
|
|||||||
|
/etc/ipcad.conf
|
0
openwrt/package/ipcad/ipkg/ipcad.control
Executable file → Normal file
0
openwrt/package/ipcad/ipkg/ipcad.control
Executable file → Normal file
11
openwrt/package/ipcad/patches/01-honor_cppflags.patch
Normal file
11
openwrt/package/ipcad/patches/01-honor_cppflags.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -ruN ipcad-3.7-old/Makefile.in ipcad-3.7-new/Makefile.in
|
||||||
|
--- ipcad-3.7-old/Makefile.in 2005-11-21 05:41:07.000000000 +0100
|
||||||
|
+++ ipcad-3.7-new/Makefile.in 2005-12-20 10:27:07.000000000 +0100
|
||||||
|
@@ -9,6 +9,7 @@
|
||||||
|
LDFLAGS+= @LDFLAGS@
|
||||||
|
LIBS+= @LIBS@
|
||||||
|
CFLAGS+= @CFLAGS@ @DEFS@ -W -Wall
|
||||||
|
+CPPFLAGS+= @CPPFLAGS@
|
||||||
|
CPPFLAGS+=-DIPCAD_VERSION=\"@IPCAD_VERSION@\"
|
||||||
|
CPPFLAGS+=-DCONFIG_FILE=\"${sysconfdir}/ipcad.conf\"
|
||||||
|
CPPFLAGS+=@DEFS@ -D_REENTRANT -D_THREAD_SAFE
|
Loading…
Reference in New Issue
Block a user