mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 21:44:04 +02:00
kernel: the usb pci quirks removal patch was a bit overzealous, leave in some functions referenced from other modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25785 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b1ba030093
commit
2d0a8e16f9
@ -1,12 +1,18 @@
|
|||||||
--- a/drivers/usb/host/Makefile
|
|
||||||
+++ b/drivers/usb/host/Makefile
|
|
||||||
@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
|
|
||||||
|
|
||||||
obj-$(CONFIG_USB_WHCI_HCD) += whci/
|
--- a/drivers/usb/host/pci-quirks.c
|
||||||
|
+++ b/drivers/usb/host/pci-quirks.c
|
||||||
|
@@ -134,6 +134,8 @@ reset_needed:
|
||||||
|
}
|
||||||
|
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
||||||
|
|
||||||
+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
|
+#ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
|
||||||
obj-$(CONFIG_PCI) += pci-quirks.o
|
+
|
||||||
+endif
|
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||||
|
{
|
||||||
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
|
u16 cmd;
|
||||||
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
|
@@ -478,3 +480,5 @@ static void __devinit quirk_usb_early_ha
|
||||||
|
quirk_usb_handoff_xhci(pdev);
|
||||||
|
}
|
||||||
|
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
@ -1,12 +1,18 @@
|
|||||||
--- a/drivers/usb/host/Makefile
|
|
||||||
+++ b/drivers/usb/host/Makefile
|
|
||||||
@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
|
|
||||||
|
|
||||||
obj-$(CONFIG_USB_WHCI_HCD) += whci/
|
--- a/drivers/usb/host/pci-quirks.c
|
||||||
|
+++ b/drivers/usb/host/pci-quirks.c
|
||||||
|
@@ -134,6 +134,8 @@ reset_needed:
|
||||||
|
}
|
||||||
|
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
||||||
|
|
||||||
+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
|
+#ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
|
||||||
obj-$(CONFIG_PCI) += pci-quirks.o
|
+
|
||||||
+endif
|
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||||
|
{
|
||||||
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
|
u16 cmd;
|
||||||
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
|
@@ -478,3 +480,5 @@ static void __devinit quirk_usb_early_ha
|
||||||
|
quirk_usb_handoff_xhci(pdev);
|
||||||
|
}
|
||||||
|
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
Loading…
Reference in New Issue
Block a user