mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:16:16 +02:00
[package] dropbear:
- split port argument at the rightmost colon, allows binding to specific IPv6 addresses - don't use uci ipaddr var but resolve ifname and get addresses from it (#9853) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27843 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
aafcea0542
commit
2ee6d3729b
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=dropbear
|
PKG_NAME:=dropbear
|
||||||
PKG_VERSION:=0.53.1
|
PKG_VERSION:=0.53.1
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
|
@ -12,6 +12,27 @@ EXTRA_HELP=" killclients Kill ${NAME} processes except servers and yourself"
|
|||||||
|
|
||||||
dropbear_start()
|
dropbear_start()
|
||||||
{
|
{
|
||||||
|
append_ports()
|
||||||
|
{
|
||||||
|
local ifname="$1"
|
||||||
|
local port="$2"
|
||||||
|
|
||||||
|
grep -qs "^ *$ifname:" /proc/net/dev || {
|
||||||
|
append args "-p $port"
|
||||||
|
return
|
||||||
|
}
|
||||||
|
|
||||||
|
for addr in $(
|
||||||
|
ifconfig "$ifname" | sed -ne '
|
||||||
|
/addr: *fe[89ab][0-9a-f]:/d
|
||||||
|
s/.* addr: *\([0-9a-f:\.]*\).*/\1/p
|
||||||
|
'
|
||||||
|
); do
|
||||||
|
append args "-p $addr:$port"
|
||||||
|
done
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
local section="$1"
|
local section="$1"
|
||||||
|
|
||||||
# check if section is enabled (default)
|
# check if section is enabled (default)
|
||||||
@ -33,13 +54,12 @@ dropbear_start()
|
|||||||
config_get_bool val "${section}" PasswordAuth 1
|
config_get_bool val "${section}" PasswordAuth 1
|
||||||
[ "${val}" -eq 0 ] && append args "-s"
|
[ "${val}" -eq 0 ] && append args "-s"
|
||||||
# B) listen interface and port
|
# B) listen interface and port
|
||||||
|
local port
|
||||||
local interface
|
local interface
|
||||||
local address
|
|
||||||
config_get interface "${section}" Interface
|
config_get interface "${section}" Interface
|
||||||
config_get address "${interface}" ipaddr
|
config_get interface "${interface}" ifname "$interface"
|
||||||
config_get val "${section}" Port
|
config_get port "${section}" Port 22
|
||||||
val="${address:+${address}:}${val}"
|
append_ports "$interface" "$port"
|
||||||
[ -n "${val}" ] && append args "-p ${val}"
|
|
||||||
# C) banner file
|
# C) banner file
|
||||||
config_get val "${section}" BannerFile
|
config_get val "${section}" BannerFile
|
||||||
[ -f "${val}" ] && append args "-b ${val}"
|
[ -f "${val}" ] && append args "-b ${val}"
|
||||||
|
11
package/dropbear/patches/300-ipv6_addr_port_split.patch
Normal file
11
package/dropbear/patches/300-ipv6_addr_port_split.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/svr-runopts.c
|
||||||
|
+++ b/svr-runopts.c
|
||||||
|
@@ -325,7 +325,7 @@ static void addportandaddress(char* spec
|
||||||
|
myspec = m_strdup(spec);
|
||||||
|
|
||||||
|
/* search for ':', that separates address and port */
|
||||||
|
- svr_opts.ports[svr_opts.portcount] = strchr(myspec, ':');
|
||||||
|
+ svr_opts.ports[svr_opts.portcount] = strrchr(myspec, ':');
|
||||||
|
|
||||||
|
if (svr_opts.ports[svr_opts.portcount] == NULL) {
|
||||||
|
/* no ':' -> the whole string specifies just a port */
|
Loading…
Reference in New Issue
Block a user