mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 04:35:19 +02:00
[ar7] update acx-mac80211 to 20101030 snapshot, patch from sn9
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24137 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d053fa7af0
commit
3aa1f0e741
@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=acx-mac80211
|
||||
PKG_REV:=6130cd9c7c07e1a5babf53f7f89e70e5844c2d08
|
||||
PKG_VERSION:=20100830
|
||||
PKG_REV:=06f0acf66d53ea422e9c1bd6b475f13818d94f20
|
||||
PKG_VERSION:=20101030
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
@ -72,7 +72,7 @@ define Build/Compile
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
SUBDIRS="$(PKG_BUILD_DIR)" \
|
||||
$(PKG_EXTRA_KCONFIG) \
|
||||
EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(2,6,34)\"" \
|
||||
EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(2,6,37)\"" \
|
||||
LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211 -I$(LINUX_DIR)/include \
|
||||
-Iarch/$(LINUX_KARCH)/include \
|
||||
-include $(LINUX_AUTOCONF_FILE) \
|
||||
|
@ -1,33 +0,0 @@
|
||||
diff --git a/common.c b/common.c
|
||||
index 69cdf5b..28b3750 100644
|
||||
--- a/common.c
|
||||
+++ b/common.c
|
||||
@@ -5765,8 +5765,9 @@ int acx_e_op_set_key(struct ieee80211_hw *hw, enum set_key_cmd cmd,
|
||||
* TODO WEP hw support can still be added later, if required.
|
||||
*/
|
||||
|
||||
- switch (key->alg) {
|
||||
- case ALG_WEP:
|
||||
+ switch (key->cipher) {
|
||||
+ case WLAN_CIPHER_SUITE_WEP40:
|
||||
+ case WLAN_CIPHER_SUITE_WEP104:
|
||||
if (key->keylen == 5) {
|
||||
algorithm = ACX_SEC_ALGO_WEP;
|
||||
log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_WEP");
|
||||
@@ -5778,14 +5779,14 @@ int acx_e_op_set_key(struct ieee80211_hw *hw, enum set_key_cmd cmd,
|
||||
err = -EOPNOTSUPP;
|
||||
break;
|
||||
|
||||
- case ALG_TKIP:
|
||||
+ case WLAN_CIPHER_SUITE_TKIP:
|
||||
algorithm = ACX_SEC_ALGO_TKIP;
|
||||
log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_TKIP");
|
||||
err = -EOPNOTSUPP;
|
||||
break;
|
||||
|
||||
break;
|
||||
- case ALG_CCMP:
|
||||
+ case WLAN_CIPHER_SUITE_CCMP:
|
||||
algorithm = ACX_SEC_ALGO_AES;
|
||||
log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_AES");
|
||||
err = -EOPNOTSUPP;
|
Loading…
Reference in New Issue
Block a user