1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-30 02:16:21 +03:00

Make ltq-dsl-app compile with an eglibc-based toolchain

Signed-Off-By: Frank Meerkötter <frank@meerkoetter.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34468 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2012-12-03 12:46:57 +00:00
parent fcd5fe3ec3
commit 3abfc82ebe
2 changed files with 25 additions and 0 deletions

View File

@ -17,6 +17,8 @@ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_FIXUP:=autoreconf
PKG_CONFIG_DEPENDS:=\
CONFIG_LTQ_DSL_ENABLE_SOAP \
CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING

View File

@ -0,0 +1,23 @@
--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,8 @@ AC_C_VOLATILE
#AC_FUNC_STRTOD
#AC_CHECK_FUNCS([ftime gethostbyname gettimeofday localtime_r memset select socket strchr strerror strstr strtoull])
+AC_SEARCH_LIBS([clock_gettime],[rt])
+
#
# save the configure arguments
#
--- a/src/dsl_cpe_linux.h
+++ b/src/dsl_cpe_linux.h
@@ -45,7 +45,8 @@
#include <arpa/inet.h>
#include <sys/socket.h> /* socket */
#include <sys/sem.h> /* semget */
-#include <semaphore.h> /* sem_t */
+#include <semaphore.h> /* sem_t */
+#include <limits.h>
#ifdef DSL_DEBUG_TOOL_INTERFACE
#include <sys/socket.h>