mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:46:16 +02:00
[tools] port lzmp that is packaged by debian, build it, but do not install it yet
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16282 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d3e75a7644
commit
40733ccb97
@ -18,9 +18,11 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
|
||||
ALONE_DIR=$(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone
|
||||
|
||||
define Host/Compile
|
||||
$(MAKE) -C $(UTIL_DIR) -f makefile.gcc
|
||||
$(MAKE) -C $(ALONE_DIR) -f makefile.gcc
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
|
13
tools/lzma/patches/001-large_files.patch
Normal file
13
tools/lzma/patches/001-large_files.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
|
||||
===================================================================
|
||||
--- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-05-15 23:33:51.000000000 +0200
|
||||
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:00:54.000000000 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
CXX_C = gcc -O2 -Wall
|
||||
LIB = -lm
|
||||
RM = rm -f
|
||||
-CFLAGS = -c
|
||||
+CFLAGS = -c -D_FILE_OFFSET_BITS=64
|
||||
|
||||
ifdef SystemDrive
|
||||
IS_MINGW = 1
|
1059
tools/lzma/patches/002-lzmp.patch
Normal file
1059
tools/lzma/patches/002-lzmp.patch
Normal file
File diff suppressed because it is too large
Load Diff
26
tools/lzma/patches/003-compile_fixes.patch
Normal file
26
tools/lzma/patches/003-compile_fixes.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/FileStreams.h
|
||||
--- lzma-4.65/CPP/7zip/Common/FileStreams.h 2009-05-15 23:33:51.000000000 +0200
|
||||
+++ lzma-4.65.new/CPP/7zip/Common/FileStreams.h 2009-06-01 22:30:01.000000000 +0200
|
||||
@@ -72,6 +72,7 @@
|
||||
public IOutStream,
|
||||
public CMyUnknownImp
|
||||
{
|
||||
+public:
|
||||
#ifdef USE_WIN_FILE
|
||||
NWindows::NFile::NIO::COutFile File;
|
||||
#else
|
||||
diff -urN lzma-4.65/CPP/Common/MyWindows.h lzma-4.65.new/CPP/Common/MyWindows.h
|
||||
--- lzma-4.65/CPP/Common/MyWindows.h 2009-05-15 23:33:51.000000000 +0200
|
||||
+++ lzma-4.65.new/CPP/Common/MyWindows.h 2009-06-01 22:29:26.000000000 +0200
|
||||
@@ -101,8 +101,11 @@
|
||||
|
||||
#ifdef __cplusplus
|
||||
|
||||
+#ifndef INITGUID
|
||||
+#define INITGUID
|
||||
DEFINE_GUID(IID_IUnknown,
|
||||
0x00000000, 0x0000, 0x0000, 0xC0, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x46);
|
||||
+#endif
|
||||
struct IUnknown
|
||||
{
|
||||
STDMETHOD(QueryInterface) (REFIID iid, void **outObject) PURE;
|
Loading…
Reference in New Issue
Block a user