mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 05:35:19 +02:00
add deco (thanks to dipa)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2056 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3fbba28a36
commit
4145788270
@ -11,6 +11,7 @@ source "package/iptables/Config.in"
|
|||||||
source "package/mtd/Config.in"
|
source "package/mtd/Config.in"
|
||||||
|
|
||||||
comment "Applications"
|
comment "Applications"
|
||||||
|
source "package/deco/Config.in"
|
||||||
source "package/haserl/Config.in"
|
source "package/haserl/Config.in"
|
||||||
source "package/lcd4linux/Config.in"
|
source "package/lcd4linux/Config.in"
|
||||||
source "package/less/Config.in"
|
source "package/less/Config.in"
|
||||||
|
@ -23,6 +23,7 @@ package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
|
|||||||
package-$(BR2_PACKAGE_CUPS) += cups
|
package-$(BR2_PACKAGE_CUPS) += cups
|
||||||
package-$(BR2_COMPILE_CURL) += curl
|
package-$(BR2_COMPILE_CURL) += curl
|
||||||
package-$(BR2_PACKAGE_CYRUS_SASL) += cyrus-sasl
|
package-$(BR2_PACKAGE_CYRUS_SASL) += cyrus-sasl
|
||||||
|
package-$(BR2_PACKAGE_DECO) += deco
|
||||||
package-$(BR2_PACKAGE_DHCP) += dhcp
|
package-$(BR2_PACKAGE_DHCP) += dhcp
|
||||||
package-$(BR2_PACKAGE_DHCP_FORWARDER) += dhcp-forwarder
|
package-$(BR2_PACKAGE_DHCP_FORWARDER) += dhcp-forwarder
|
||||||
package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
|
package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
|
||||||
@ -210,6 +211,7 @@ avahi-compile: libdaemon-compile expat-compile
|
|||||||
bind-compile: openssl-compile
|
bind-compile: openssl-compile
|
||||||
curl-compile: openssl-compile zlib-compile
|
curl-compile: openssl-compile zlib-compile
|
||||||
cyrus-sasl-compile: openssl-compile
|
cyrus-sasl-compile: openssl-compile
|
||||||
|
deco-compile: ncurses-compile
|
||||||
dropbear-compile: zlib-compile
|
dropbear-compile: zlib-compile
|
||||||
dsniff-compile: libnids-compile openssl-compile libgdbm-compile
|
dsniff-compile: libnids-compile openssl-compile libgdbm-compile
|
||||||
freetype-compile: zlib-compile
|
freetype-compile: zlib-compile
|
||||||
|
11
package/deco/Config.in
Normal file
11
package/deco/Config.in
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
config BR2_PACKAGE_DECO
|
||||||
|
tristate "deco - Text-based full featured file manager"
|
||||||
|
default m if CONFIG_DEVEL
|
||||||
|
select BR2_PACKAGE_LIBNCURSES
|
||||||
|
help
|
||||||
|
A clone of Norton Commander for Unix. Text-based, full featured
|
||||||
|
file manager.
|
||||||
|
|
||||||
|
http://deco.sourceforge.net/
|
||||||
|
|
||||||
|
|
59
package/deco/Makefile
Normal file
59
package/deco/Makefile
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=deco
|
||||||
|
PKG_VERSION:=39
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_MD5SUM:=f77f60e8be0cae1f814cba1ef61bf4d0
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=@SF/deco
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tgz
|
||||||
|
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
|
$(eval $(call PKG_template,DECO,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||||
|
(cd $(PKG_BUILD_DIR); \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
|
./configure \
|
||||||
|
--target=$(GNU_TARGET_NAME) \
|
||||||
|
--host=$(GNU_TARGET_NAME) \
|
||||||
|
--build=$(GNU_HOST_NAME) \
|
||||||
|
--program-prefix="" \
|
||||||
|
--program-suffix="" \
|
||||||
|
--prefix=/usr \
|
||||||
|
--exec-prefix=/usr \
|
||||||
|
--bindir=/usr/bin \
|
||||||
|
--datadir=/usr/share \
|
||||||
|
--includedir=/usr/include \
|
||||||
|
--infodir=/usr/share/info \
|
||||||
|
--libdir=/usr/lib \
|
||||||
|
--libexecdir=/usr/lib \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--sbindir=/usr/sbin \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
$(DISABLE_LARGEFILE) \
|
||||||
|
$(DISABLE_NLS) \
|
||||||
|
);
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(PKG_BUILD_DIR)/.built:
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
$(IPKG_DECO):
|
||||||
|
install -m0755 -d $(IDIR_DECO)/usr/bin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/deco $(IDIR_DECO)/usr/bin/deco
|
||||||
|
install -m0755 -d $(IDIR_DECO)/usr/lib/deco
|
||||||
|
install -m0644 $(PKG_BUILD_DIR)/profile $(IDIR_DECO)/usr/lib/deco/profile
|
||||||
|
install -m0644 $(PKG_BUILD_DIR)/menu $(IDIR_DECO)/usr/lib/deco/menu
|
||||||
|
$(RSTRIP) $(IDIR_DECO)
|
||||||
|
$(IPKG_BUILD) $(IDIR_DECO) $(PACKAGE_DIR)
|
||||||
|
|
7
package/deco/ipkg/deco.control
Normal file
7
package/deco/ipkg/deco.control
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
Package: deco
|
||||||
|
Priority: optional
|
||||||
|
Section: misc
|
||||||
|
Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org
|
||||||
|
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/deco/
|
||||||
|
Depends: libncurses
|
||||||
|
Description: Text-based, full featured file manager
|
11
package/deco/patches/100-tty.c.patch
Normal file
11
package/deco/patches/100-tty.c.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- src/tty.c 2005-09-25 00:23:41.671022039 -0700
|
||||||
|
+++ str_new/tty.c 2005-09-25 01:09:37.189119615 -0700
|
||||||
|
@@ -14,7 +14,7 @@
|
||||||
|
#if HAVE_TERMIOS_H
|
||||||
|
# include <sys/termios.h>
|
||||||
|
# if HAVE_SYS_IOCTL_H
|
||||||
|
-# include <sys/ioctl.h>
|
||||||
|
+/*# include <sys/ioctl.h>*/
|
||||||
|
# endif
|
||||||
|
# define HAVE_TERMIO_H 1
|
||||||
|
# define termio termios
|
Loading…
Reference in New Issue
Block a user