mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:14:05 +02:00
[backfire] merge r23058, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23712 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c9daff6ff2
commit
460d95817f
@ -65,7 +65,7 @@ Signed-off-by: Phillip Lougher <phillip@lougher.demon.co.uk>
|
||||
+#endif
|
||||
--- a/include/linux/decompress/mm.h
|
||||
+++ b/include/linux/decompress/mm.h
|
||||
@@ -53,8 +53,6 @@ static void free(void *where)
|
||||
@@ -63,8 +63,6 @@ static void free(void *where)
|
||||
|
||||
#define set_error_fn(x)
|
||||
|
||||
@ -74,7 +74,7 @@ Signed-off-by: Phillip Lougher <phillip@lougher.demon.co.uk>
|
||||
#else /* STATIC */
|
||||
|
||||
/* Code active when compiled standalone for use when loading ramdisk: */
|
||||
@@ -77,7 +75,6 @@ static void free(void *where)
|
||||
@@ -87,7 +85,6 @@ static void free(void *where)
|
||||
static void(*error)(char *m);
|
||||
#define set_error_fn(x) error = x;
|
||||
|
||||
|
@ -23,7 +23,7 @@
|
||||
/* The Mellanox Tavor device gives false positive parity errors
|
||||
* Mark this device with a broken_parity_status, to allow
|
||||
* PCI scanning code to "skip" this now blacklisted device.
|
||||
@@ -1884,7 +1885,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
@@ -1887,7 +1888,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
}
|
||||
}
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||
@ -33,8 +33,8 @@
|
||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||
{
|
||||
@@ -2515,6 +2518,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150d, quirk_i82576_sriov);
|
||||
@@ -2522,6 +2525,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
|
||||
|
||||
#endif /* CONFIG_PCI_IOV */
|
||||
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
||||
|
@ -0,0 +1,12 @@
|
||||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -626,7 +626,8 @@ static struct flash_info __devinitdata m
|
||||
{ "mx25l12805d", 0xc22018, 0, 64 * 1024, 256, },
|
||||
{ "mx25l12855e", 0xc22618, 0, 64 * 1024, 256, },
|
||||
|
||||
- /* EON -- en25pxx */
|
||||
+ /* EON -- en25xxx */
|
||||
+ { "en25f32", 0x1c3116, 0, 64 * 1024, 64, SECT_4K },
|
||||
{ "en25p32", 0x1c2016, 0, 64 * 1024, 64, },
|
||||
{ "en25p64", 0x1c2017, 0, 64 * 1024, 128, },
|
||||
|
@ -14,7 +14,7 @@
|
||||
--- a/drivers/net/phy/Makefile
|
||||
+++ b/drivers/net/phy/Makefile
|
||||
@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
||||
obj-$(CONFIG_IP17XX) += ip17xx.o
|
||||
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
||||
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -812,7 +812,7 @@ static noinline int init_post(void)
|
||||
@@ -807,7 +807,7 @@ static noinline int init_post(void)
|
||||
numa_default_policy();
|
||||
|
||||
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
|
||||
|
@ -68,7 +68,7 @@
|
||||
* macro override instead of weak attribute alias, to workaround
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -6105,6 +6105,7 @@ int can_nice(const struct task_struct *p
|
||||
@@ -6113,6 +6113,7 @@ int can_nice(const struct task_struct *p
|
||||
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
|
||||
capable(CAP_SYS_NICE));
|
||||
}
|
||||
@ -124,7 +124,7 @@
|
||||
#ifndef CONFIG_MMU
|
||||
--- a/kernel/signal.c
|
||||
+++ b/kernel/signal.c
|
||||
@@ -1070,6 +1070,7 @@ struct sighand_struct *lock_task_sighand
|
||||
@@ -1072,6 +1072,7 @@ struct sighand_struct *lock_task_sighand
|
||||
|
||||
return sighand;
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -836,10 +836,7 @@ static noinline int init_post(void)
|
||||
@@ -831,10 +831,7 @@ static noinline int init_post(void)
|
||||
printk(KERN_WARNING "Failed to execute %s. Attempting "
|
||||
"defaults...\n", execute_command);
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user