mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-19 04:49:42 +02:00
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4185 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
de95ef402f
commit
4be6c77dba
23
toolchain/ipkg-utils/patches/130-tar_wildcards.patch
Normal file
23
toolchain/ipkg-utils/patches/130-tar_wildcards.patch
Normal file
@ -0,0 +1,23 @@
|
||||
--- ipkg-utils-1.7/ipkg.py.orig 2006-06-29 14:16:00.000000000 +0200
|
||||
+++ ipkg-utils-1.7/ipkg.py 2006-06-29 14:36:01.000000000 +0200
|
||||
@@ -93,9 +93,9 @@
|
||||
self.filename = os.path.basename(fn)
|
||||
## sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
|
||||
if self.isdeb:
|
||||
- control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - '*control'","r")
|
||||
+ control = os.popen("ar p "+fn+" control.tar.gz | tar xzO --wildcards -f - '*control'","r")
|
||||
else:
|
||||
- control = os.popen("tar xfzO "+fn+" '*control.tar.gz' | tar xfzO - '*control'","r")
|
||||
+ control = os.popen("tar xzO --wildcards -f "+fn+" '*control.tar.gz' | tar xzO --wildcards -f - '*control'","r")
|
||||
line = control.readline()
|
||||
while 1:
|
||||
if not line: break
|
||||
@@ -122,7 +122,7 @@
|
||||
if self.isdeb:
|
||||
data = os.popen("ar p "+fn+" data.tar.gz | tar tfz -","r")
|
||||
else:
|
||||
- data = os.popen("tar xfzO "+fn+" '*data.tar.gz' | tar tfz -","r")
|
||||
+ data = os.popen("tar xzO --wildcards -f "+fn+" '*data.tar.gz' | tar tfz -","r")
|
||||
while 1:
|
||||
line = data.readline()
|
||||
if not line: break
|
@ -31,7 +31,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
|
||||
|
||||
define Build/Prepare
|
||||
mkdir -p $(TOOL_BUILD_DIR)
|
||||
bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
|
||||
bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
|
||||
linux-$(PKG_VERSION)/include \
|
||||
linux-$(PKG_VERSION)/Makefile \
|
||||
linux-$(PKG_VERSION)/Rules.make \
|
||||
|
Loading…
Reference in New Issue
Block a user