mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 18:03:43 +02:00
port l2tpd fixes from changeset:2696 to trunk.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2697 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
64017a106d
commit
4fbbef031b
@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=l2tpd
|
PKG_NAME:=l2tpd
|
||||||
PKG_VERSION:=0.70pre
|
PKG_VERSION:=0.70pre
|
||||||
PKG_UPSTREAM_VERSION:=0.70-pre20031121
|
PKG_UPSTREAM_VERSION:=0.70-pre20031121
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2.1
|
||||||
PKG_MD5SUM:=3f2707b6e16a8cb72e7bf64f574202fa
|
PKG_MD5SUM:=3f2707b6e16a8cb72e7bf64f574202fa
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/l2tpd
|
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/l2tpd
|
||||||
@ -30,6 +30,12 @@ $(PKG_BUILD_DIR)/.built:
|
|||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(IPKG_L2TPD):
|
$(IPKG_L2TPD):
|
||||||
|
install -d -m0755 $(IDIR_L2TPD)/etc/l2tpd
|
||||||
|
install -m0644 ./files/l2tpd.conf $(IDIR_L2TPD)/etc/l2tpd/
|
||||||
|
install -d -m0755 $(IDIR_L2TPD)/etc/ppp
|
||||||
|
install -m0644 ./files/options.l2tpd $(IDIR_L2TPD)/etc/ppp/
|
||||||
|
install -d -m0755 $(IDIR_L2TPD)/etc/init.d
|
||||||
|
install -m0755 ./files/l2tpd.init $(IDIR_L2TPD)/etc/init.d/l2tpd
|
||||||
install -d -m0755 $(IDIR_L2TPD)/usr/sbin
|
install -d -m0755 $(IDIR_L2TPD)/usr/sbin
|
||||||
install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_L2TPD)/usr/sbin/
|
install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_L2TPD)/usr/sbin/
|
||||||
$(RSTRIP) $(IDIR_L2TPD)
|
$(RSTRIP) $(IDIR_L2TPD)
|
||||||
|
29
openwrt/package/l2tpd/files/l2tpd.conf
Normal file
29
openwrt/package/l2tpd/files/l2tpd.conf
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
;
|
||||||
|
; This is a minimal sample l2tpd configuration file for use
|
||||||
|
; with L2TP over IPsec.
|
||||||
|
;
|
||||||
|
; The idea is to provide an L2TP daemon to which remote Windows L2TP/IPsec
|
||||||
|
; clients connect. In this example, the internal (protected) network
|
||||||
|
; is 192.168.1.0/24. A special IP range within this network is reserved
|
||||||
|
; for the remote clients: 192.168.1.128/25
|
||||||
|
; (i.e. 192.168.1.128 ... 192.168.1.254)
|
||||||
|
;
|
||||||
|
; The listen-addr parameter can be used if you want to bind the L2TP daemon
|
||||||
|
; to a specific IP address instead of to all interfaces. For instance,
|
||||||
|
; you could bind it to the interface of the internal LAN (e.g. 192.168.1.98
|
||||||
|
; in the example below). Yet another IP address (local ip, e.g. 192.168.1.99)
|
||||||
|
; will be used by l2tpd as its address on pppX interfaces.
|
||||||
|
|
||||||
|
[global]
|
||||||
|
; listen-addr = 192.168.1.98
|
||||||
|
|
||||||
|
[lns default]
|
||||||
|
ip range = 192.168.1.128-192.168.1.254
|
||||||
|
local ip = 192.168.1.99
|
||||||
|
require chap = yes
|
||||||
|
refuse pap = yes
|
||||||
|
require authentication = yes
|
||||||
|
name = LinuxVPNserver
|
||||||
|
ppp debug = yes
|
||||||
|
pppoptfile = /etc/ppp/options.l2tpd
|
||||||
|
length bit = yes
|
21
openwrt/package/l2tpd/files/l2tpd.init
Normal file
21
openwrt/package/l2tpd/files/l2tpd.init
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
BIN=l2tpd
|
||||||
|
DEFAULT=/etc/default/$BIN
|
||||||
|
RUN_D=/var/run
|
||||||
|
PID_F=$RUN_D/$BIN.pid
|
||||||
|
[ -f $DEFAULT ] && . $DEFAULT
|
||||||
|
|
||||||
|
case $1 in
|
||||||
|
start)
|
||||||
|
$BIN $OPTIONS
|
||||||
|
;;
|
||||||
|
stop)
|
||||||
|
[ -f $PID_F ] && kill $(cat $PID_F)
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
echo "usage: $0 (start|stop)"
|
||||||
|
exit 1
|
||||||
|
esac
|
||||||
|
|
||||||
|
exit $?
|
17
openwrt/package/l2tpd/files/options.l2tpd
Normal file
17
openwrt/package/l2tpd/files/options.l2tpd
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
ipcp-accept-local
|
||||||
|
ipcp-accept-remote
|
||||||
|
ms-dns 192.168.1.1
|
||||||
|
ms-dns 192.168.1.3
|
||||||
|
ms-wins 192.168.1.2
|
||||||
|
ms-wins 192.168.1.4
|
||||||
|
noccp
|
||||||
|
auth
|
||||||
|
crtscts
|
||||||
|
idle 1800
|
||||||
|
mtu 1410
|
||||||
|
mru 1410
|
||||||
|
nodefaultroute
|
||||||
|
debug
|
||||||
|
lock
|
||||||
|
proxyarp
|
||||||
|
connect-delay 5000
|
2
openwrt/package/l2tpd/ipkg/l2tpd.conffiles
Normal file
2
openwrt/package/l2tpd/ipkg/l2tpd.conffiles
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
/etc/l2tpd/l2tpd.conf
|
||||||
|
/etc/ppp/options.l2tpd
|
21
openwrt/package/l2tpd/patches/02-debian-2-pty-rev.patch
Normal file
21
openwrt/package/l2tpd/patches/02-debian-2-pty-rev.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -ruN l2tpd-0.70pre-old/l2tpd.c l2tpd-0.70pre-new/l2tpd.c
|
||||||
|
--- l2tpd-0.70pre-old/l2tpd.c 2005-12-16 12:02:02.000000000 +0100
|
||||||
|
+++ l2tpd-0.70pre-new/l2tpd.c 2005-12-16 12:14:24.000000000 +0100
|
||||||
|
@@ -336,17 +336,10 @@
|
||||||
|
tcgetattr (c->fd, &ptyconf);
|
||||||
|
*(c->oldptyconf) = ptyconf;
|
||||||
|
ptyconf.c_cflag &= ~(ICANON | ECHO);
|
||||||
|
- ptyconf.c_lflag &= ~ECHO;
|
||||||
|
tcsetattr (c->fd, TCSANOW, &ptyconf);
|
||||||
|
|
||||||
|
snprintf (tty, sizeof (tty), "/dev/tty%c%c", a, b);
|
||||||
|
fd2 = open (tty, O_RDWR);
|
||||||
|
- if(!fd2)
|
||||||
|
- log(LOG_WARN, "unable to open tty %s", tty);
|
||||||
|
-
|
||||||
|
- /* XXX JEF: CHECK ME */
|
||||||
|
- stropt[pos++] = strdup(tty);
|
||||||
|
- stropt[pos] = NULL;
|
||||||
|
|
||||||
|
#ifdef USE_KERNEL
|
||||||
|
}
|
1194
openwrt/package/l2tpd/patches/03-jacco-pty.patch
Normal file
1194
openwrt/package/l2tpd/patches/03-jacco-pty.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user