mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:01:52 +02:00
package/zlib: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20480 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
20d8feaac4
commit
513371154d
@ -1,8 +1,6 @@
|
|||||||
Index: zlib-1.2.3/Makefile.in
|
--- a/Makefile.in
|
||||||
===================================================================
|
+++ b/Makefile.in
|
||||||
--- zlib-1.2.3.orig/Makefile.in 2005-07-18 04:25:21.000000000 +0200
|
@@ -25,20 +25,23 @@ CFLAGS=-O
|
||||||
+++ zlib-1.2.3/Makefile.in 2008-07-27 14:57:32.000000000 +0200
|
|
||||||
@@ -25,20 +25,23 @@
|
|
||||||
# -Wstrict-prototypes -Wmissing-prototypes
|
# -Wstrict-prototypes -Wmissing-prototypes
|
||||||
|
|
||||||
LDFLAGS=libz.a
|
LDFLAGS=libz.a
|
||||||
@ -29,7 +27,7 @@ Index: zlib-1.2.3/Makefile.in
|
|||||||
prefix = /usr/local
|
prefix = /usr/local
|
||||||
exec_prefix = ${prefix}
|
exec_prefix = ${prefix}
|
||||||
libdir = ${exec_prefix}/lib
|
libdir = ${exec_prefix}/lib
|
||||||
@@ -67,8 +70,8 @@
|
@@ -67,8 +70,8 @@ test: all
|
||||||
echo ' *** zlib test FAILED ***'; \
|
echo ' *** zlib test FAILED ***'; \
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -40,7 +38,7 @@ Index: zlib-1.2.3/Makefile.in
|
|||||||
-@ ($(RANLIB) $@ || true) >/dev/null 2>&1
|
-@ ($(RANLIB) $@ || true) >/dev/null 2>&1
|
||||||
|
|
||||||
match.o: match.S
|
match.o: match.S
|
||||||
@@ -77,8 +80,10 @@
|
@@ -77,8 +80,10 @@ match.o: match.S
|
||||||
mv _match.o match.o
|
mv _match.o match.o
|
||||||
rm -f _match.s
|
rm -f _match.s
|
||||||
|
|
||||||
@ -52,7 +50,7 @@ Index: zlib-1.2.3/Makefile.in
|
|||||||
rm -f $(SHAREDLIB) $(SHAREDLIBM)
|
rm -f $(SHAREDLIB) $(SHAREDLIBM)
|
||||||
ln -s $@ $(SHAREDLIB)
|
ln -s $@ $(SHAREDLIB)
|
||||||
ln -s $@ $(SHAREDLIBM)
|
ln -s $@ $(SHAREDLIBM)
|
||||||
@@ -90,23 +95,22 @@
|
@@ -90,23 +95,22 @@ minigzip$(EXE): minigzip.o $(LIBS)
|
||||||
$(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
|
$(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
|
||||||
|
|
||||||
install: $(LIBS)
|
install: $(LIBS)
|
||||||
@ -88,11 +86,9 @@ Index: zlib-1.2.3/Makefile.in
|
|||||||
# The ranlib in install is needed on NeXTSTEP which checks file times
|
# The ranlib in install is needed on NeXTSTEP which checks file times
|
||||||
# ldconfig is for Linux
|
# ldconfig is for Linux
|
||||||
|
|
||||||
Index: zlib-1.2.3/configure
|
--- a/configure
|
||||||
===================================================================
|
+++ b/configure
|
||||||
--- zlib-1.2.3.orig/configure 2005-07-11 22:11:57.000000000 +0200
|
@@ -23,7 +23,7 @@ LDFLAGS="-L. ${LIBS}"
|
||||||
+++ zlib-1.2.3/configure 2008-07-27 14:57:24.000000000 +0200
|
|
||||||
@@ -23,7 +23,7 @@
|
|
||||||
VER=`sed -n -e '/VERSION "/s/.*"\(.*\)".*/\1/p' < zlib.h`
|
VER=`sed -n -e '/VERSION "/s/.*"\(.*\)".*/\1/p' < zlib.h`
|
||||||
VER2=`sed -n -e '/VERSION "/s/.*"\([0-9]*\\.[0-9]*\)\\..*/\1/p' < zlib.h`
|
VER2=`sed -n -e '/VERSION "/s/.*"\([0-9]*\\.[0-9]*\)\\..*/\1/p' < zlib.h`
|
||||||
VER1=`sed -n -e '/VERSION "/s/.*"\([0-9]*\)\\..*/\1/p' < zlib.h`
|
VER1=`sed -n -e '/VERSION "/s/.*"\([0-9]*\)\\..*/\1/p' < zlib.h`
|
||||||
@ -101,7 +97,7 @@ Index: zlib-1.2.3/configure
|
|||||||
RANLIB=${RANLIB-"ranlib"}
|
RANLIB=${RANLIB-"ranlib"}
|
||||||
prefix=${prefix-/usr/local}
|
prefix=${prefix-/usr/local}
|
||||||
exec_prefix=${exec_prefix-'${prefix}'}
|
exec_prefix=${exec_prefix-'${prefix}'}
|
||||||
@@ -73,32 +73,9 @@
|
@@ -73,32 +73,9 @@ esac
|
||||||
|
|
||||||
if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
|
if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
|
||||||
CC="$cc"
|
CC="$cc"
|
||||||
@ -136,7 +132,7 @@ Index: zlib-1.2.3/configure
|
|||||||
else
|
else
|
||||||
# find system name and corresponding cc options
|
# find system name and corresponding cc options
|
||||||
CC=${CC-cc}
|
CC=${CC-cc}
|
||||||
@@ -424,6 +401,29 @@
|
@@ -424,6 +401,29 @@ else
|
||||||
echo Checking for mmap support... No.
|
echo Checking for mmap support... No.
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -166,7 +162,7 @@ Index: zlib-1.2.3/configure
|
|||||||
CPP=${CPP-"$CC -E"}
|
CPP=${CPP-"$CC -E"}
|
||||||
case $CFLAGS in
|
case $CFLAGS in
|
||||||
*ASMV*)
|
*ASMV*)
|
||||||
@@ -440,20 +440,21 @@
|
@@ -440,20 +440,21 @@ rm -f $test.[co] $test $test$shared_ext
|
||||||
# udpate Makefile
|
# udpate Makefile
|
||||||
sed < Makefile.in "
|
sed < Makefile.in "
|
||||||
/^CC *=/s#=.*#=$CC#
|
/^CC *=/s#=.*#=$CC#
|
||||||
@ -204,10 +200,8 @@ Index: zlib-1.2.3/configure
|
|||||||
+/^mandir *=/s%=.*%= $mandir%
|
+/^mandir *=/s%=.*%= $mandir%
|
||||||
+/^LDFLAGS *=/s%=.*%= $LDFLAGS%
|
+/^LDFLAGS *=/s%=.*%= $LDFLAGS%
|
||||||
" > Makefile
|
" > Makefile
|
||||||
Index: zlib-1.2.3/contrib/minizip/Makefile
|
--- a/contrib/minizip/Makefile
|
||||||
===================================================================
|
+++ b/contrib/minizip/Makefile
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/Makefile 2005-07-12 20:08:40.000000000 +0200
|
|
||||||
+++ zlib-1.2.3/contrib/minizip/Makefile 2008-07-27 14:57:24.000000000 +0200
|
|
||||||
@@ -1,8 +1,8 @@
|
@@ -1,8 +1,8 @@
|
||||||
CC=cc
|
CC=cc
|
||||||
-CFLAGS=-O -I../..
|
-CFLAGS=-O -I../..
|
||||||
@ -220,7 +214,7 @@ Index: zlib-1.2.3/contrib/minizip/Makefile
|
|||||||
|
|
||||||
.c.o:
|
.c.o:
|
||||||
$(CC) -c $(CFLAGS) $*.c
|
$(CC) -c $(CFLAGS) $*.c
|
||||||
@@ -10,10 +10,10 @@
|
@@ -10,10 +10,10 @@ ZIP_OBJS = minizip.o zip.o ioapi.o ../
|
||||||
all: miniunz minizip
|
all: miniunz minizip
|
||||||
|
|
||||||
miniunz: $(UNZ_OBJS)
|
miniunz: $(UNZ_OBJS)
|
||||||
|
Loading…
Reference in New Issue
Block a user