1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-27 17:55:55 +02:00

kernel: remove wrong chunks from the 2.6.37 and 2.6.38 version of the mips oprofile fix

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26297 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2011-03-25 22:18:17 +00:00
parent 8236d49861
commit 5278b87b26
2 changed files with 0 additions and 24 deletions

View File

@ -1,15 +1,3 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
endif
endif
+ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
+endif
ifdef CONFIG_FUNCTION_GRAPH_TRACER
ifndef KBUILD_MCOUNT_RA_ADDRESS
ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)

View File

@ -1,15 +1,3 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
endif
endif
+ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
+endif
ifdef CONFIG_FUNCTION_GRAPH_TRACER
ifndef KBUILD_MCOUNT_RA_ADDRESS
ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)