1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 20:55:27 +03:00

add udev package

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2596 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-12-07 17:03:23 +00:00
parent 85a65c36f1
commit 53ac868559
7 changed files with 98 additions and 0 deletions

View File

@ -227,6 +227,7 @@ source "package/madwifi-tools/Config.in"
source "package/pcmcia-cs/Config.in" # pcmcia-utils
source "package/usbutils/Config.in" # lsusb
source "package/strace/Config.in"
source "package/udev/Config.in"
comment "FileSystems related"
source "package/dosfstools/Config.in"

View File

@ -200,6 +200,7 @@ package-$(BR2_PACKAGE_ULOGD) += ulogd
package-$(BR2_PACKAGE_UPDATEDD) += updatedd
package-$(BR2_COMPILE_USBUTILS) += usbutils
package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
package-$(BR2_PACKAGE_UDEV) += udev
package-$(BR2_PACKAGE_VTUN) += vtun
package-$(BR2_PACKAGE_VSFTPD) += vsftpd
package-$(BR2_PACKAGE_WIFICONF) += wificonf

11
package/udev/Config.in Normal file
View File

@ -0,0 +1,11 @@
config BR2_PACKAGE_UDEV
prompt "udev.............................. Dynamic device management subsystem"
tristate
default m if CONFIG_DEVEL
select BR2_COMPILE_UTIL_LINUX
help
udev provides a dynamic device directory containing only the files for
actually present devices. It creates or removes device node files in
the /dev directory, or it renames network interfaces.
http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html

59
package/udev/Makefile Normal file
View File

@ -0,0 +1,59 @@
# $Id: Makefile 2567 2005-11-29 11:13:32Z nico $
include $(TOPDIR)/rules.mk
PKG_NAME:=udev
PKG_VERSION:=077
PKG_RELEASE:=1
PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
http://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
ftp://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,UDEV,udev,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
CROSS="$(TARGET_CROSS)" \
STRIP="/bin/true" \
OPTFLAGS="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@
$(IPKG_UDEV):
install -d -m0775 $(IDIR_UDEV)/etc/udev
cp -fpR $(PKG_INSTALL_DIR)/etc/udev/* $(IDIR_UDEV)/etc/udev/
install -d -m0775 $(IDIR_UDEV)/lib/udev
install -d -m0775 $(IDIR_UDEV)/sbin/
cp -fpR $(PKG_INSTALL_DIR)/sbin/udev $(IDIR_UDEV)/sbin/
cp -fpR $(PKG_INSTALL_DIR)/sbin/udevcontrol $(IDIR_UDEV)/sbin/
cp -fpR $(PKG_INSTALL_DIR)/sbin/udevd $(IDIR_UDEV)/sbin/
cp -fpR $(PKG_INSTALL_DIR)/sbin/udevsend $(IDIR_UDEV)/sbin/
cp -fpR $(PKG_INSTALL_DIR)/sbin/udevstart $(IDIR_UDEV)/sbin/
install -d -m0775 $(IDIR_UDEV)/usr/bin/
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(IDIR_UDEV)/usr/bin/
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/udevtest $(IDIR_UDEV)/usr/bin/
install -d -m0775 $(IDIR_UDEV)/usr/sbin/
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(IDIR_UDEV)/usr/sbin/
$(RSTRIP) $(IDIR_UDEV)
$(IPKG_BUILD) $(IDIR_UDEV) $(PACKAGE_DIR)
mostlyclean:
-$(MAKE) -C $(PKG_BUILD_DIR) clean
rm -f $(PKG_BUILD_DIR)/.built

View File

@ -0,0 +1 @@
/etc/udev/udev.conf

View File

@ -0,0 +1,4 @@
Package: udev
Priority: optional
Section: base
Description: Dynamic device management subsystem

View File

@ -0,0 +1,21 @@
diff -ruN udev-077-old/Makefile udev-077-new/Makefile
--- udev-077-old/Makefile 2005-12-04 03:01:48.000000000 +0100
+++ udev-077-new/Makefile 2005-12-07 16:48:11.000000000 +0100
@@ -136,7 +136,7 @@
# check if compiler option is supported
cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+CFLAGS = -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
-Wchar-subscripts -Wmissing-declarations -Wnested-externs \
-Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
@@ -159,7 +159,7 @@
# if DEBUG is enabled, then we do not strip
ifeq ($(strip $(DEBUG)),true)
- CFLAGS += -DDEBUG
+ CFLAGS += -g -DDEBUG
STRIPCMD =
endif