mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 07:38:04 +02:00
upgrade a few packages to newer versions (includes patch by kaloz) - preparation for 2.6.22
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7507 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
035104fa52
commit
546d769c67
12
package/acx/patches/003-2.6.22_compat.patch
Normal file
12
package/acx/patches/003-2.6.22_compat.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nur acx-20070101/common.c acx-20070101-owrt/common.c
|
||||
--- acx-20070101/common.c 2007-01-10 22:15:27.000000000 +0100
|
||||
+++ acx-20070101-owrt/common.c 2007-06-02 18:02:39.000000000 +0200
|
||||
@@ -2754,7 +2754,7 @@
|
||||
skb->dev = adev->ndev;
|
||||
skb->dev->last_rx = jiffies;
|
||||
|
||||
- skb->mac.raw = skb->data;
|
||||
+// skb->mac.raw = skb->data;
|
||||
skb->ip_summed = CHECKSUM_NONE;
|
||||
skb->pkt_type = PACKET_OTHERHOST;
|
||||
skb->protocol = htons(ETH_P_80211_RAW);
|
11
package/fuse/patches/210-posix_test_lock.patch
Normal file
11
package/fuse/patches/210-posix_test_lock.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- fuse.old/kernel/file.c 2007-01-28 21:25:02.000000000 +0000
|
||||
+++ fuse.dev/kernel/file.c 2007-05-29 00:10:29.000000000 +0100
|
||||
@@ -782,7 +782,7 @@
|
||||
if (cmd == F_GETLK) {
|
||||
if (fc->no_lock) {
|
||||
#ifdef KERNEL_2_6_17_PLUS
|
||||
- if (!posix_test_lock(file, fl, fl))
|
||||
+ if (!posix_test_lock(file, fl))
|
||||
fl->fl_type = F_UNLCK;
|
||||
#else
|
||||
struct file_lock *cfl = posix_test_lock(file, fl);
|
56
package/fuse/patches/220-kmem_cache.patch
Normal file
56
package/fuse/patches/220-kmem_cache.patch
Normal file
@ -0,0 +1,56 @@
|
||||
--- fuse.old/kernel/dev.c 2007-01-28 21:26:41.000000000 +0000
|
||||
+++ fuse.dev/kernel/dev.c 2007-05-29 00:28:47.000000000 +0100
|
||||
@@ -21,7 +21,11 @@
|
||||
MODULE_ALIAS_MISCDEV(FUSE_MINOR);
|
||||
#endif
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
|
||||
+static struct kmem_cache *fuse_req_cachep;
|
||||
+#else
|
||||
static kmem_cache_t *fuse_req_cachep;
|
||||
+#endif
|
||||
|
||||
static struct fuse_conn *fuse_get_conn(struct file *file)
|
||||
{
|
||||
@@ -1093,9 +1093,13 @@
|
||||
int __init fuse_dev_init(void)
|
||||
{
|
||||
int err = -ENOMEM;
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
|
||||
+ fuse_req_cachep = KMEM_CACHE(fuse_req, 0);
|
||||
+#else
|
||||
fuse_req_cachep = kmem_cache_create("fuse_request",
|
||||
sizeof(struct fuse_req),
|
||||
0, 0, NULL, NULL);
|
||||
+#endif
|
||||
if (!fuse_req_cachep)
|
||||
goto out;
|
||||
|
||||
--- fuse.old/kernel/inode.c 2007-02-04 13:34:51.000000000 +0000
|
||||
+++ fuse.dev/kernel/inode.c 2007-05-29 00:26:12.000000000 +0100
|
||||
@@ -24,7 +24,7 @@
|
||||
MODULE_LICENSE("GPL");
|
||||
#endif
|
||||
|
||||
-static kmem_cache_t *fuse_inode_cachep;
|
||||
+static struct kmem_cache *fuse_inode_cachep;
|
||||
struct list_head fuse_conn_list;
|
||||
DEFINE_MUTEX(fuse_mutex);
|
||||
|
||||
@@ -804,14 +804,12 @@
|
||||
static decl_subsys(fuse, NULL, NULL);
|
||||
static decl_subsys(connections, NULL, NULL);
|
||||
|
||||
-static void fuse_inode_init_once(void *foo, kmem_cache_t *cachep,
|
||||
+static void fuse_inode_init_once(void *foo, struct kmem_cache *cachep,
|
||||
unsigned long flags)
|
||||
{
|
||||
struct inode * inode = foo;
|
||||
|
||||
- if ((flags & (SLAB_CTOR_VERIFY|SLAB_CTOR_CONSTRUCTOR)) ==
|
||||
- SLAB_CTOR_CONSTRUCTOR)
|
||||
- inode_init_once(inode);
|
||||
+ inode_init_once(inode);
|
||||
}
|
||||
|
||||
static int __init fuse_fs_init(void)
|
17
package/fuse/patches/230-kobj.patch
Normal file
17
package/fuse/patches/230-kobj.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- fuse.old/kernel/inode.c 2007-05-29 07:31:43.000000000 +0100
|
||||
+++ fuse.dev/kernel/inode.c 2007-05-29 07:29:42.000000000 +0100
|
||||
@@ -858,12 +858,12 @@
|
||||
if (err)
|
||||
return err;
|
||||
#endif
|
||||
- kset_set_kset_s(&fuse_subsys, fs_subsys);
|
||||
+ kobj_set_kset_s(&fuse_subsys, fs_subsys);
|
||||
err = subsystem_register(&fuse_subsys);
|
||||
if (err)
|
||||
goto out_err;
|
||||
|
||||
- kset_set_kset_s(&connections_subsys, fuse_subsys);
|
||||
+ kobj_set_kset_s(&connections_subsys, fuse_subsys);
|
||||
err = subsystem_register(&connections_subsys);
|
||||
if (err)
|
||||
goto out_fuse_unregister;
|
8854
package/iptables/patches/100-svn_r6848.patch
Normal file
8854
package/iptables/patches/100-svn_r6848.patch
Normal file
File diff suppressed because it is too large
Load Diff
12
package/iptables/patches/110-2.6.22_compatibility.patch
Normal file
12
package/iptables/patches/110-2.6.22_compatibility.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nur iptables-svn/extensions/libipt_conntrack.c iptables-22/extensions/libipt_conntrack.c
|
||||
--- iptables-svn/extensions/libipt_conntrack.c 2007-05-31 12:46:30.000000000 +0200
|
||||
+++ iptables-22/extensions/libipt_conntrack.c 2007-05-31 13:06:09.000000000 +0200
|
||||
@@ -10,7 +10,7 @@
|
||||
#include <ctype.h>
|
||||
#include <iptables.h>
|
||||
#include <linux/netfilter/nf_conntrack_common.h>
|
||||
-#include <linux/netfilter_ipv4/ip_conntrack_tuple.h>
|
||||
+#include <linux/netfilter/nf_conntrack_tuple_common.h>
|
||||
/* For 64bit kernel / 32bit userspace */
|
||||
#include "../include/linux/netfilter_ipv4/ipt_conntrack.h"
|
||||
|
@ -8,6 +8,12 @@
|
||||
|
||||
USBMENU:=USB Support
|
||||
|
||||
ifeq ($(KERNEL),2.4)
|
||||
USBNET_DIR=usb/net
|
||||
else
|
||||
USBNET_DIR=net/usb
|
||||
endif
|
||||
|
||||
define KernelPackage/usb-core
|
||||
TITLE:=Support for USB
|
||||
DESCRIPTION:=Kernel support for USB
|
||||
@ -325,7 +331,7 @@ define KernelPackage/usb-net/2.4
|
||||
endef
|
||||
|
||||
define KernelPackage/usb-net/2.6
|
||||
FILES:=$(LINUX_DIR)/drivers/usb/net/usbnet.$(LINUX_KMOD_SUFFIX)
|
||||
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/usbnet.$(LINUX_KMOD_SUFFIX)
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,usb-net))
|
||||
@ -344,7 +350,7 @@ define KernelPackage/usb-net-asix/2.4
|
||||
endef
|
||||
|
||||
define KernelPackage/usb-net-asix/2.6
|
||||
FILES:=$(LINUX_DIR)/drivers/usb/net/asix.$(LINUX_KMOD_SUFFIX)
|
||||
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/asix.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call Autoload,61,asix)
|
||||
endef
|
||||
|
||||
@ -356,7 +362,7 @@ define KernelPackage/usb-net-kaweth
|
||||
DESCRIPTION:=Kernel module for USB-to-Ethernet Kaweth convertors
|
||||
DEPENDS:=kmod-usb-net
|
||||
KCONFIG:=$(CONFIG_USB_KAWETH)
|
||||
FILES:=$(LINUX_DIR)/drivers/usb/net/kaweth.$(LINUX_KMOD_SUFFIX)
|
||||
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/kaweth.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call Autoload,61,kaweth)
|
||||
endef
|
||||
|
||||
@ -368,7 +374,7 @@ define KernelPackage/usb-net-pegasus
|
||||
DESCRIPTION:=Kernel module for USB-to-Ethernet Pegasus convertors
|
||||
DEPENDS:=kmod-usb-net
|
||||
KCONFIG:=$(CONFIG_USB_PEGASUS)
|
||||
FILES:=$(LINUX_DIR)/drivers/usb/net/pegasus.$(LINUX_KMOD_SUFFIX)
|
||||
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/pegasus.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call Autoload,61,pegasus)
|
||||
endef
|
||||
|
||||
|
@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=rt61
|
||||
PKG_VERSION:=cvs-2007041709
|
||||
PKG_VERSION:=cvs-2007060307
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@openwrt/
|
||||
PKG_MD5SUM:=3e2675fc0bdb1cfe85fefc5bce9f0ae0
|
||||
PKG_MD5SUM:=8d71fee47bdaac4c7d79180a4ea33649
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
12
package/rt61/patches/001-2.6.22_compat.patch
Normal file
12
package/rt61/patches/001-2.6.22_compat.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nur rt61-cvs-2007060307/Module/rtmp_data.c rt61-cvs-2007060307-owrt/Module/rtmp_data.c
|
||||
--- rt61-cvs-2007060307/Module/rtmp_data.c 2007-05-12 19:49:42.000000000 +0200
|
||||
+++ rt61-cvs-2007060307-owrt/Module/rtmp_data.c 2007-06-03 14:41:28.000000000 +0200
|
||||
@@ -669,7 +669,7 @@
|
||||
}
|
||||
|
||||
skb->dev = pAd->net_dev;
|
||||
- skb->mac.raw = skb->data;
|
||||
+// skb->mac.raw = skb->data;
|
||||
skb->pkt_type = PACKET_OTHERHOST;
|
||||
skb->protocol = htons(ETH_P_802_2);
|
||||
skb->ip_summed = CHECKSUM_NONE;
|
Loading…
Reference in New Issue
Block a user