mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-02-20 09:54:43 +02:00
[ifx-tapi] add .33 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21197 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
64eda22d9b
commit
5577999135
@ -16,6 +16,8 @@ PKG_SOURCE:=drv_tapi-$(PKG_VERSION).tar.gz
|
|||||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||||
PKG_MD5SUM:=1ffee83ce69f55915468c309d8ae2138
|
PKG_MD5SUM:=1ffee83ce69f55915468c309d8ae2138
|
||||||
|
|
||||||
|
PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define KernelPackage/ifx-tapi
|
define KernelPackage/ifx-tapi
|
||||||
|
94
package/ifx-tapi/patches-2.6.33/001-portability.patch
Normal file
94
package/ifx-tapi/patches-2.6.33/001-portability.patch
Normal file
@ -0,0 +1,94 @@
|
|||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -149,7 +149,7 @@ if KERNEL_2_6
|
||||||
|
drv_tapi_OBJS = "$(subst .c,.o, $(drv_tapi_SOURCES))"
|
||||||
|
|
||||||
|
drv_tapi.ko: $(drv_tapi_SOURCES) $(EXTRA_DIST)
|
||||||
|
- @echo -e "Making Linux 2.6.x kernel object"
|
||||||
|
+ @echo "Making Linux 2.6.x kernel object"
|
||||||
|
@for f in $(drv_tapi_SOURCES) ; do \
|
||||||
|
if test ! -e $(PWD)/$$f; then \
|
||||||
|
echo " LN $$f" ; \
|
||||||
|
@@ -157,10 +157,10 @@ drv_tapi.ko: $(drv_tapi_SOURCES) $(EXTRA
|
||||||
|
ln -s @abs_srcdir@/$$f $(PWD)/$$f; \
|
||||||
|
fi; \
|
||||||
|
done;
|
||||||
|
- @echo -e "# drv_tapi: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||||
|
- @echo -e "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||||
|
- @echo -e "$(subst .ko,,$@)-y := $(drv_tapi_OBJS)" >> $(PWD)/Kbuild
|
||||||
|
- @echo -e "EXTRA_CFLAGS := -DHAVE_CONFIG_H $(CFLAGS) $(drv_tapi_CFLAGS) $(INCLUDES)" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "# drv_tapi: Generated to build Linux 2.6.x kernel object" > $(PWD)/Kbuild
|
||||||
|
+ @echo "obj-m := $(subst .ko,.o,$@)" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "$(subst .ko,,$@)-y := $(drv_tapi_OBJS)" >> $(PWD)/Kbuild
|
||||||
|
+ @echo "EXTRA_CFLAGS := -DHAVE_CONFIG_H $(CFLAGS) $(drv_tapi_CFLAGS) $(INCLUDES)" >> $(PWD)/Kbuild
|
||||||
|
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
||||||
|
|
||||||
|
clean-generic:
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -128,7 +128,7 @@ dnl Set kernel build path
|
||||||
|
AC_ARG_ENABLE(kernelbuild,
|
||||||
|
AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path),
|
||||||
|
[
|
||||||
|
- if test -r $enableval/include/linux/autoconf.h; then
|
||||||
|
+ if test -e $enableval/include/linux/autoconf.h -o -e $enableval/include/generated/autoconf.h; then
|
||||||
|
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
|
||||||
|
else
|
||||||
|
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
|
||||||
|
--- a/src/drv_tapi_linux.h
|
||||||
|
+++ b/src/drv_tapi_linux.h
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include <linux/version.h>
|
||||||
|
#include <linux/interrupt.h> /* in_interrupt() */
|
||||||
|
#include <linux/delay.h> /* mdelay - udelay */
|
||||||
|
+#include <linux/workqueue.h> /* work_struct */
|
||||||
|
#include <asm/poll.h> /* POLLIN, POLLOUT */
|
||||||
|
|
||||||
|
#include "ifx_types.h" /* ifx type definitions */
|
||||||
|
--- a/src/drv_tapi_linux.c
|
||||||
|
+++ b/src/drv_tapi_linux.c
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
#include <linux/sched.h>
|
||||||
|
#undef CONFIG_DEVFS_FS
|
||||||
|
#ifndef UTS_RELEASE
|
||||||
|
- #include "linux/utsrelease.h"
|
||||||
|
+ #include <utsrelease.h>
|
||||||
|
#endif /* UTC_RELEASE */
|
||||||
|
#else
|
||||||
|
#include <linux/tqueue.h>
|
||||||
|
--- a/src/drv_tapi_linux.c
|
||||||
|
+++ b/src/drv_tapi_linux.c
|
||||||
|
@@ -47,6 +47,7 @@
|
||||||
|
#include <linux/errno.h>
|
||||||
|
#include <asm/uaccess.h> /* copy_from_user(), ... */
|
||||||
|
#include <asm/byteorder.h>
|
||||||
|
+#include <linux/smp_lock.h> /* lock_kernel() */
|
||||||
|
#include <asm/io.h>
|
||||||
|
|
||||||
|
#ifdef LINUX_2_6
|
||||||
|
@@ -55,12 +56,11 @@
|
||||||
|
#include <linux/sched.h>
|
||||||
|
#undef CONFIG_DEVFS_FS
|
||||||
|
#ifndef UTS_RELEASE
|
||||||
|
- #include <utsrelease.h>
|
||||||
|
+ #include <generated/utsrelease.h>
|
||||||
|
#endif /* UTC_RELEASE */
|
||||||
|
#else
|
||||||
|
#include <linux/tqueue.h>
|
||||||
|
#include <linux/sched.h>
|
||||||
|
- #include <linux/smp_lock.h> /* lock_kernel() */
|
||||||
|
#endif /* LINUX_2_6 */
|
||||||
|
|
||||||
|
#include "drv_tapi.h"
|
||||||
|
@@ -3600,7 +3600,11 @@ IFX_void_t TAPI_OS_ThreadKill(IFXOS_Thre
|
||||||
|
flag and released after the down() call. */
|
||||||
|
lock_kernel();
|
||||||
|
mb();
|
||||||
|
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,28)
|
||||||
|
kill_proc(pThrCntrl->tid, SIGKILL, 1);
|
||||||
|
+#else
|
||||||
|
+ kill_pid(find_vpid(pThrCntrl->tid), SIGKILL, 1);
|
||||||
|
+#endif
|
||||||
|
/* release the big kernel lock */
|
||||||
|
unlock_kernel();
|
||||||
|
wait_for_completion (&pThrCntrl->thrCompletion);
|
96
package/ifx-tapi/patches-2.6.33/100-ifxmips.patch
Normal file
96
package/ifx-tapi/patches-2.6.33/100-ifxmips.patch
Normal file
@ -0,0 +1,96 @@
|
|||||||
|
--- a/src/drv_tapi_linux.c
|
||||||
|
+++ b/src/drv_tapi_linux.c
|
||||||
|
@@ -544,7 +544,7 @@ static ssize_t ifx_tapi_write (struct fi
|
||||||
|
IFX_uint8_t *pData;
|
||||||
|
IFX_size_t buf_size;
|
||||||
|
#endif /* TAPI_PACKET */
|
||||||
|
- IFX_ssize_t size = 0;
|
||||||
|
+ ssize_t size = 0;
|
||||||
|
|
||||||
|
#ifdef TAPI_PACKET
|
||||||
|
if (pTapiDev->bInitialized == IFX_FALSE)
|
||||||
|
--- a/src/drv_tapi_osmap.h
|
||||||
|
+++ b/src/drv_tapi_osmap.h
|
||||||
|
@@ -17,39 +17,6 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include "ifx_types.h" /* ifx type definitions */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_ULONG_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_ulong_t
|
||||||
|
- /* unsigned long type - valid for 32bit systems only */
|
||||||
|
- typedef unsigned long IFX_ulong_t;
|
||||||
|
- #define HAVE_IFX_ULONG_T
|
||||||
|
-#endif /* HAVE_IFX_ULONG_T */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_LONG_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_long_t
|
||||||
|
- /* long type - valid for 32bit systems only */
|
||||||
|
- typedef long IFX_long_t;
|
||||||
|
- #define HAVE_IFX_LONG_T
|
||||||
|
-#endif /* HAVE_IFX_LONG_T */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_INTPTR_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_intptr_t
|
||||||
|
- typedef IFX_long_t IFX_intptr_t;
|
||||||
|
- #define HAVE_IFX_INTPTR_T
|
||||||
|
-#endif /* HAVE_IFX_INTPTR_T */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_SIZE_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_size_t
|
||||||
|
- typedef IFX_ulong_t IFX_size_t;
|
||||||
|
- #define HAVE_IFX_SIZE_T
|
||||||
|
-#endif /* HAVE_IFX_SIZE_T */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_SSIZE_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_ssize_t
|
||||||
|
- typedef IFX_long_t IFX_ssize_t;
|
||||||
|
- #define HAVE_IFX_SSIZE_T
|
||||||
|
-#endif /* HAVE_IFX_SSIZE_T */
|
||||||
|
-
|
||||||
|
#include "ifxos_interrupt.h"
|
||||||
|
#include "ifxos_memory_alloc.h"
|
||||||
|
#include "ifxos_copy_user_space.h"
|
||||||
|
--- a/include/drv_tapi_ll_interface.h
|
||||||
|
+++ b/include/drv_tapi_ll_interface.h
|
||||||
|
@@ -40,13 +40,6 @@
|
||||||
|
#include "ifxos_select.h"
|
||||||
|
#endif /* TAPI_PACKET */
|
||||||
|
|
||||||
|
-#ifndef HAVE_IFX_ULONG_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_ulong_t
|
||||||
|
- /* unsigned long type - valid for 32bit systems only */
|
||||||
|
- typedef unsigned long IFX_ulong_t;
|
||||||
|
- #define HAVE_IFX_ULONG_T
|
||||||
|
-#endif /* HAVE_IFX_ULONG_T */
|
||||||
|
-
|
||||||
|
/* ============================= */
|
||||||
|
/* Local Macros Definitions */
|
||||||
|
/* ============================= */
|
||||||
|
--- a/src/lib/lib_bufferpool/lib_bufferpool.c
|
||||||
|
+++ b/src/lib/lib_bufferpool/lib_bufferpool.c
|
||||||
|
@@ -80,24 +80,6 @@
|
||||||
|
#include <linux/slab.h>
|
||||||
|
#endif /* LINUX */
|
||||||
|
|
||||||
|
-
|
||||||
|
-/* ============================= */
|
||||||
|
-/* Extra type definitions */
|
||||||
|
-/* ============================= */
|
||||||
|
-#ifndef HAVE_IFX_ULONG_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_ulong_t
|
||||||
|
- /* unsigned long type - valid for 32bit systems only */
|
||||||
|
- typedef unsigned long IFX_ulong_t;
|
||||||
|
- #define HAVE_IFX_ULONG_T
|
||||||
|
-#endif /* HAVE_IFX_ULONG_T */
|
||||||
|
-
|
||||||
|
-#ifndef HAVE_IFX_UINTPTR_T
|
||||||
|
- #warning please update your ifx_types.h, using local definition of IFX_uintptr_t
|
||||||
|
- typedef IFX_ulong_t IFX_uintptr_t;
|
||||||
|
- #define HAVE_IFX_UINTPTR_T
|
||||||
|
-#endif /* HAVE_IFX_UINTPTR_T */
|
||||||
|
-
|
||||||
|
-
|
||||||
|
/* ============================= */
|
||||||
|
/* Local Macros & Definitions */
|
||||||
|
/* ============================= */
|
@ -24,3 +24,46 @@
|
|||||||
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
$(MAKE) ARCH=@KERNEL_ARCH@ -C @KERNEL_BUILD_PATH@ O=@KERNEL_BUILD_PATH@ M=$(PWD) modules
|
||||||
|
|
||||||
clean-generic:
|
clean-generic:
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -128,7 +128,7 @@ dnl Set kernel build path
|
||||||
|
AC_ARG_ENABLE(kernelbuild,
|
||||||
|
AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path),
|
||||||
|
[
|
||||||
|
- if test -r $enableval/include/linux/autoconf.h; then
|
||||||
|
+ if test -e $enableval/include/linux/autoconf.h -o -e $enableval/include/generated/autoconf.h; then
|
||||||
|
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
|
||||||
|
else
|
||||||
|
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
|
||||||
|
--- a/src/drv_tapi_linux.h
|
||||||
|
+++ b/src/drv_tapi_linux.h
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include <linux/version.h>
|
||||||
|
#include <linux/interrupt.h> /* in_interrupt() */
|
||||||
|
#include <linux/delay.h> /* mdelay - udelay */
|
||||||
|
+#include <linux/workqueue.h> /* work_struct */
|
||||||
|
#include <asm/poll.h> /* POLLIN, POLLOUT */
|
||||||
|
|
||||||
|
#include "ifx_types.h" /* ifx type definitions */
|
||||||
|
--- a/src/drv_tapi_linux.c
|
||||||
|
+++ b/src/drv_tapi_linux.c
|
||||||
|
@@ -47,6 +47,7 @@
|
||||||
|
#include <linux/errno.h>
|
||||||
|
#include <asm/uaccess.h> /* copy_from_user(), ... */
|
||||||
|
#include <asm/byteorder.h>
|
||||||
|
+#include <linux/smp_lock.h> /* lock_kernel() */
|
||||||
|
#include <asm/io.h>
|
||||||
|
|
||||||
|
#ifdef LINUX_2_6
|
||||||
|
@@ -3600,7 +3600,11 @@ IFX_void_t TAPI_OS_ThreadKill(IFXOS_Thre
|
||||||
|
flag and released after the down() call. */
|
||||||
|
lock_kernel();
|
||||||
|
mb();
|
||||||
|
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,28)
|
||||||
|
kill_proc(pThrCntrl->tid, SIGKILL, 1);
|
||||||
|
+#else
|
||||||
|
+ kill_pid(find_vpid(pThrCntrl->tid), SIGKILL, 1);
|
||||||
|
+#endif
|
||||||
|
/* release the big kernel lock */
|
||||||
|
unlock_kernel();
|
||||||
|
wait_for_completion (&pThrCntrl->thrCompletion);
|
||||||
|
@ -9,18 +9,6 @@
|
|||||||
|
|
||||||
#ifdef TAPI_PACKET
|
#ifdef TAPI_PACKET
|
||||||
if (pTapiDev->bInitialized == IFX_FALSE)
|
if (pTapiDev->bInitialized == IFX_FALSE)
|
||||||
@@ -3600,7 +3600,11 @@ IFX_void_t TAPI_OS_ThreadKill(IFXOS_Thre
|
|
||||||
flag and released after the down() call. */
|
|
||||||
lock_kernel();
|
|
||||||
mb();
|
|
||||||
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,28)
|
|
||||||
kill_proc(pThrCntrl->tid, SIGKILL, 1);
|
|
||||||
+#else
|
|
||||||
+ kill_pid(find_vpid(pThrCntrl->tid), SIGKILL, 1);
|
|
||||||
+#endif
|
|
||||||
/* release the big kernel lock */
|
|
||||||
unlock_kernel();
|
|
||||||
wait_for_completion (&pThrCntrl->thrCompletion);
|
|
||||||
--- a/src/drv_tapi_osmap.h
|
--- a/src/drv_tapi_osmap.h
|
||||||
+++ b/src/drv_tapi_osmap.h
|
+++ b/src/drv_tapi_osmap.h
|
||||||
@@ -17,39 +17,6 @@
|
@@ -17,39 +17,6 @@
|
||||||
|
Loading…
x
Reference in New Issue
Block a user