mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:01:52 +02:00
[kernel] refresh 3.3 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33887 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
12fc0a21be
commit
577eacbdb0
@ -44,11 +44,9 @@ To unsubscribe from this list: send the line "unsubscribe netdev" in
|
|||||||
the body of a message to majordomo@vger.kernel.org
|
the body of a message to majordomo@vger.kernel.org
|
||||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||||
|
|
||||||
diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
|
|
||||||
index 2fd2bc9..fa2c2c2 100644
|
|
||||||
--- a/net/ipv4/tcp_input.c
|
--- a/net/ipv4/tcp_input.c
|
||||||
+++ b/net/ipv4/tcp_input.c
|
+++ b/net/ipv4/tcp_input.c
|
||||||
@@ -237,7 +237,11 @@ static inline void TCP_ECN_check_ce(struct tcp_sock *tp, const struct sk_buff *s
|
@@ -231,7 +231,11 @@ static inline void TCP_ECN_check_ce(stru
|
||||||
tcp_enter_quickack_mode((struct sock *)tp);
|
tcp_enter_quickack_mode((struct sock *)tp);
|
||||||
break;
|
break;
|
||||||
case INET_ECN_CE:
|
case INET_ECN_CE:
|
||||||
|
@ -16,11 +16,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
|
|||||||
net/sched/sch_fq_codel.c | 2 +-
|
net/sched/sch_fq_codel.c | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/net/sched/sch_fq_codel.c b/net/sched/sch_fq_codel.c
|
|
||||||
index 9fc1c62..4e606fc 100644
|
|
||||||
--- a/net/sched/sch_fq_codel.c
|
--- a/net/sched/sch_fq_codel.c
|
||||||
+++ b/net/sched/sch_fq_codel.c
|
+++ b/net/sched/sch_fq_codel.c
|
||||||
@@ -191,7 +191,6 @@ static int fq_codel_enqueue(struct sk_buff *skb, struct Qdisc *sch)
|
@@ -191,7 +191,6 @@ static int fq_codel_enqueue(struct sk_bu
|
||||||
|
|
||||||
if (list_empty(&flow->flowchain)) {
|
if (list_empty(&flow->flowchain)) {
|
||||||
list_add_tail(&flow->flowchain, &q->new_flows);
|
list_add_tail(&flow->flowchain, &q->new_flows);
|
||||||
@ -28,7 +26,7 @@ index 9fc1c62..4e606fc 100644
|
|||||||
q->new_flow_count++;
|
q->new_flow_count++;
|
||||||
flow->deficit = q->quantum;
|
flow->deficit = q->quantum;
|
||||||
flow->dropped = 0;
|
flow->dropped = 0;
|
||||||
@@ -418,6 +417,7 @@ static int fq_codel_init(struct Qdisc *sch, struct nlattr *opt)
|
@@ -418,6 +417,7 @@ static int fq_codel_init(struct Qdisc *s
|
||||||
struct fq_codel_flow *flow = q->flows + i;
|
struct fq_codel_flow *flow = q->flows + i;
|
||||||
|
|
||||||
INIT_LIST_HEAD(&flow->flowchain);
|
INIT_LIST_HEAD(&flow->flowchain);
|
||||||
@ -36,6 +34,3 @@ index 9fc1c62..4e606fc 100644
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
if (sch->limit >= 1)
|
if (sch->limit >= 1)
|
||||||
--
|
|
||||||
1.7.9.5
|
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/phy/Kconfig
|
--- a/drivers/net/phy/Kconfig
|
||||||
+++ b/drivers/net/phy/Kconfig
|
+++ b/drivers/net/phy/Kconfig
|
||||||
@@ -206,3 +206,8 @@ endif # PHYLIB
|
@@ -210,3 +210,8 @@ endif # PHYLIB
|
||||||
config MICREL_KS8995MA
|
config MICREL_KS8995MA
|
||||||
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
|
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
|
||||||
depends on SPI
|
depends on SPI
|
||||||
@ -11,8 +11,8 @@
|
|||||||
+ select ETHERNET_PACKET_MANGLE
|
+ select ETHERNET_PACKET_MANGLE
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
|
@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
|
||||||
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
|
obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
|
||||||
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
||||||
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
||||||
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
|
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
|
||||||
|
Loading…
Reference in New Issue
Block a user