mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-16 17:59:41 +02:00
[package] broadcom-wl: fix build after IRQF_SAMPLE_RANDOM flag removal (#12248)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33617 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
10aa4d9fcb
commit
59aa4df1d5
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||||||
|
|
||||||
PKG_NAME:=broadcom-wl
|
PKG_NAME:=broadcom-wl
|
||||||
PKG_VERSION:=5.10.56.27.3
|
PKG_VERSION:=5.10.56.27.3
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
|
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
|
||||||
|
@ -0,0 +1,11 @@
|
|||||||
|
--- a/driver/wl_linux.c 2012-09-26 20:51:48.099454971 -0400
|
||||||
|
+++ b/driver/wl_linux.c 2012-09-26 20:53:24.115453441 -0400
|
||||||
|
@@ -691,7 +691,7 @@
|
||||||
|
if (wl->bustype != JTAG_BUS)
|
||||||
|
#endif /* BCMJTAG */
|
||||||
|
{
|
||||||
|
- if (request_irq(irq, wl_isr, IRQF_SHARED|IRQF_SAMPLE_RANDOM, dev->name, wl)) {
|
||||||
|
+ if (request_irq(irq, wl_isr, IRQF_SHARED, dev->name, wl)) {
|
||||||
|
WL_ERROR(("wl%d: request_irq() failed\n", unit));
|
||||||
|
goto fail;
|
||||||
|
}
|
Loading…
Reference in New Issue
Block a user