mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-17 23:03:44 +02:00
[package] acx-mac80211: update to v2012-09-23-WIP
Patch from Daniel Gimpelevich. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33746 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
bb96890d83
commit
5bf5d0ac12
@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=acx-mac80211
|
PKG_NAME:=acx-mac80211
|
||||||
PKG_REV:=v20120607
|
PKG_REV:=v2012-09-23-WIP
|
||||||
PKG_VERSION:=20120607
|
PKG_VERSION:=20121004
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/acx_func.h
|
--- a/main.h
|
||||||
+++ b/acx_func.h
|
+++ b/main.h
|
||||||
@@ -335,8 +335,11 @@ void acx_process_rxbuf(acx_device_t *ade
|
@@ -44,8 +44,11 @@ void acx_process_rxbuf(acx_device_t *ade
|
||||||
*/
|
|
||||||
#if CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(2, 6, 39)
|
#if CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(2, 6, 39)
|
||||||
int acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
|
int acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
|
||||||
-#else
|
-#else
|
||||||
@ -12,23 +12,10 @@
|
|||||||
+ struct sk_buff *skb);
|
+ struct sk_buff *skb);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
void acx_tx_work(struct work_struct *work);
|
|
||||||
--- a/common.c
|
|
||||||
+++ b/common.c
|
|
||||||
@@ -232,8 +232,11 @@ static void acx_rx(acx_device_t *adev, r
|
|
||||||
/* Tx Path */
|
|
||||||
#if CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(2, 6, 39)
|
|
||||||
int acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
|
|
||||||
-#else
|
|
||||||
+#elif CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(3, 7, 0)
|
|
||||||
void acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
|
|
||||||
+#else
|
|
||||||
+void acx_op_tx(struct ieee80211_hw *hw, struct ieee80211_tx_control *control,
|
|
||||||
+ struct sk_buff *skb);
|
|
||||||
#endif
|
|
||||||
|
|
||||||
//-void acx_tx_work(struct work_struct *work);
|
--- a/main.c
|
||||||
@@ -5183,7 +5186,12 @@ out:
|
+++ b/main.c
|
||||||
|
@@ -1024,7 +1024,12 @@ out:
|
||||||
* acx_compat, and hiding this #if/else. OTOH, inclusion doesnt care
|
* acx_compat, and hiding this #if/else. OTOH, inclusion doesnt care
|
||||||
* about old kernels
|
* about old kernels
|
||||||
*/
|
*/
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- a/common.c
|
|
||||||
+++ b/common.c
|
|
||||||
@@ -34,6 +34,7 @@
|
|
||||||
#include <linux/pci.h>
|
|
||||||
#include <linux/nl80211.h>
|
|
||||||
#include <linux/ieee80211.h>
|
|
||||||
+#include <linux/ratelimit.h>
|
|
||||||
|
|
||||||
#include <net/mac80211.h>
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user