mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2025-02-20 02:34:43 +02:00
upgrade mklibs to 0.1.29 - fixes runtime errors in mklibs-readelf
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17171 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
36ee26128c
commit
5d8da1c596
@ -7,11 +7,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mklibs
|
PKG_NAME:=mklibs
|
||||||
PKG_VERSION:=0.1.26
|
PKG_VERSION:=0.1.29
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
|
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
|
||||||
PKG_MD5SUM:=708f284975f1b567b817d27f7677a95f
|
PKG_MD5SUM:=7f35dfdbde249a090199829c1a1222d8
|
||||||
|
|
||||||
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mklibs
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -urN mklibs-0.1.26/src/mklibs-readelf/main.cpp mklibs-0.1.26.new/src/mklibs-readelf/main.cpp
|
--- a/src/mklibs-readelf/main.cpp
|
||||||
--- mklibs-0.1.26/src/mklibs-readelf/main.cpp 2007-09-20 19:41:34.000000000 +0200
|
+++ b/src/mklibs-readelf/main.cpp
|
||||||
+++ mklibs-0.1.26.new/src/mklibs-readelf/main.cpp 2009-08-07 12:20:21.000000000 +0200
|
@@ -7,6 +7,7 @@
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
|
|
||||||
#include <elf.h>
|
#include <elf.h>
|
||||||
#include <getopt.h>
|
#include <getopt.h>
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/src/mklibs.py
|
--- a/src/mklibs.py
|
||||||
+++ b/src/mklibs.py
|
+++ b/src/mklibs.py
|
||||||
@@ -429,7 +429,7 @@ while 1:
|
@@ -500,7 +500,7 @@ while 1:
|
||||||
# No progress in last pass. Verify all remaining symbols are weak.
|
# No progress in last pass. Verify all remaining symbols are weak.
|
||||||
for name in unresolved:
|
for name in unresolved:
|
||||||
if not needed_symbols[name].weak:
|
if not needed_symbols[name].weak:
|
||||||
@ -9,13 +9,13 @@
|
|||||||
break
|
break
|
||||||
|
|
||||||
previous_pass_unresolved = unresolved
|
previous_pass_unresolved = unresolved
|
||||||
@@ -467,10 +467,7 @@ while 1:
|
@@ -533,10 +533,7 @@ while 1:
|
||||||
|
|
||||||
# which symbols are actually used from each lib
|
# which symbols are actually used from each lib
|
||||||
for name in needed_symbols:
|
for name in needed_symbols:
|
||||||
- if not name in symbol_provider:
|
- if not name in symbol_provider:
|
||||||
- if not needed_symbols[name].weak:
|
- if not needed_symbols[name].weak:
|
||||||
- raise "No library provides non-weak %s" % symbol
|
- raise "No library provides non-weak %s" % name
|
||||||
- else:
|
- else:
|
||||||
+ if name in symbol_provider:
|
+ if name in symbol_provider:
|
||||||
lib = symbol_provider[name]
|
lib = symbol_provider[name]
|
||||||
|
Loading…
x
Reference in New Issue
Block a user