mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 16:36:16 +02:00
Update to version 0.12, add a default configuration file, thanks to eatnumber1 !
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3612 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
92a8d8214c
commit
622f6d12b6
@ -3,11 +3,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vncrepeater
|
PKG_NAME:=vncrepeater
|
||||||
PKG_VERSION:=0.007
|
PKG_VERSION:=0.12
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=7e13b0b784d683473d418f7295aff500
|
PKG_MD5SUM:=bf89c31d7cb51a267a8d5ac388e0508d
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://downloads.openwrt.org
|
PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
@ -32,8 +32,9 @@ $(PKG_BUILD_DIR)/.built:
|
|||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
$(IPKG_VNCREPEATER):
|
$(IPKG_VNCREPEATER):
|
||||||
install -d -m0755 $(IDIR_VNCREPEATER)/usr/sbin
|
install -d -m0755 $(IDIR_VNCREPEATER)/usr/sbin $(IDIR_VNCREPEATER)/etc
|
||||||
$(CP) $(PKG_BUILD_DIR)/repeater $(IDIR_VNCREPEATER)/usr/sbin/$(PKG_NAME)
|
$(CP) $(PKG_BUILD_DIR)/repeater $(IDIR_VNCREPEATER)/usr/sbin/$(PKG_NAME)
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/u$(PKG_NAME).ini $(IDIR_VNCREPEATER)/etc/
|
||||||
$(RSTRIP) $(IDIR_VNCREPEATER)
|
$(RSTRIP) $(IDIR_VNCREPEATER)
|
||||||
$(IPKG_BUILD) $(IDIR_VNCREPEATER) $(PACKAGE_DIR)
|
$(IPKG_BUILD) $(IDIR_VNCREPEATER) $(PACKAGE_DIR)
|
||||||
|
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
diff -urN vncrepeater-0.007/Makefile vncrepeater-0.007.new/Makefile
|
diff -urN vncrepeater-0.12/Makefile vncrepeater-0.12.new/Makefile
|
||||||
--- vncrepeater-0.007/Makefile 2005-10-03 20:22:48.000000000 +0200
|
--- vncrepeater-0.12/Makefile 2006-03-31 07:40:14.000000000 +0200
|
||||||
+++ vncrepeater-0.007.new/Makefile 2006-04-10 16:15:50.495599944 +0200
|
+++ vncrepeater-0.12.new/Makefile 2006-04-11 10:26:06.345879104 +0200
|
||||||
@@ -1,15 +1,15 @@
|
@@ -1,21 +1,21 @@
|
||||||
CFLAGS=-Wall
|
-CFLAGS=-Wall
|
||||||
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o
|
+CFLAGS=-Wall
|
||||||
- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o
|
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
|
||||||
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
|
- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
|
||||||
|
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
|
||||||
|
|
||||||
repeater.o: repeater.cpp
|
repeater.o: repeater.cpp
|
||||||
- g++ $(CFLAGS) -c repeater.cpp
|
- g++ $(CFLAGS) -c repeater.cpp
|
||||||
@ -19,5 +20,13 @@ diff -urN vncrepeater-0.007/Makefile vncrepeater-0.007.new/Makefile
|
|||||||
- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
|
- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
|
||||||
+ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
|
+ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
|
||||||
|
|
||||||
|
iniparser.o: iniparser.cpp
|
||||||
|
- g++ $(CFLAGS) -c iniparser.cpp
|
||||||
|
+ $(CC) $(CFLAGS) -c iniparser.cpp
|
||||||
|
|
||||||
|
readini.o: readini.cpp
|
||||||
|
- g++ $(CFLAGS) -c readini.cpp
|
||||||
|
+ $(CC) $(CFLAGS) -c readini.cpp
|
||||||
|
|
||||||
clean:
|
clean:
|
||||||
rm -f *.o repeater
|
rm -f *.o repeater
|
||||||
|
Loading…
Reference in New Issue
Block a user